]> git.pld-linux.org Git - packages/eric6.git/commitdiff
- drop bad python3 detection
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 3 Apr 2022 19:39:19 +0000 (21:39 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 3 Apr 2022 19:39:19 +0000 (21:39 +0200)
eric6.spec
python3.patch [new file with mode: 0644]

index 03dcd78a3711185ad2ade25a7b34373a85f64ce7..f4477c578cf4dd664934df188204b257330b85c8 100644 (file)
@@ -4,7 +4,7 @@
 # "eric6 can be used with  Python2 or Python3 and with PyQt5 or PyQt4. 
 # However, the recommended combination is PyQt5 on Python3.
 
-%define        module  eric6
+%define                module  eric6
 Summary:       Eric6 - a full featured Python IDE
 Summary(pl.UTF-8):     Eric6 - pełnowartościowe IDE dla Pythona
 Name:          eric6
@@ -14,6 +14,7 @@ License:      GPL v3
 Group:         Libraries/Python
 Source0:       https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: c21c097bf36259ff61187e2698b7c50d
+Patch0:                python3.patch
 URL:           http://eric-ide.python-projects.org/index.html
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
@@ -21,7 +22,7 @@ BuildRequires:        rpmbuild(macros) >= 1.714
 BuildRequires: python-modules
 BuildRequires: python-setuptools
 # NOTE: As for 6.1.8  eric6 still tries to import PyQt5 while having PyQt4 leading to crash
-#      http://die-offenbachs.homelinux.org:48888/issues/issue204
+#      http://die-offenbachs.homelinux.org:48888/issues/issue204
 # for --pyqt=4
 # BuildRequires:       python-PyQt4-qscintilla2
 # BuildRequires:       python-PyQt4-uic
@@ -58,6 +59,7 @@ używającym PyQt i QScintilla.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 
diff --git a/python3.patch b/python3.patch
new file mode 100644 (file)
index 0000000..b4a60ce
--- /dev/null
@@ -0,0 +1,64 @@
+--- eric6-17.07/install.py~    2017-07-02 12:13:55.000000000 +0200
++++ eric6-17.07/install.py     2022-04-03 21:23:52.313234712 +0200
+@@ -1136,9 +1136,6 @@
+     elif sys.version_info < (3, 4, 0) and sys.version_info[0] == 3:
+         print('Sorry, you must have Python 3.4.0 or higher.')
+         exit(5)
+-    if sys.version_info > (3, 9, 9):
+-        print('Sorry, eric6 requires Python 3 or Python 2 for running.')
+-        exit(5)
+     
+     try:
+         import xml.etree            # __IGNORE_WARNING__
+@@ -1397,7 +1397,7 @@
+     global macAppBundlePath, macAppBundleName, macPythonExe
+     global pyqtVariant, pyqtOverride, installApis
+     
+-    if sys.version_info < (2, 7, 0) or sys.version_info > (3, 9, 9):
++    if sys.version_info < (2, 7, 0):
+         print('Sorry, eric6 requires at least Python 2.7 or '
+               'Python 3 for running.')
+         exit(5)
+--- eric6-17.07/eric/install-debugclients.py~  2017-04-07 18:26:12.000000000 +0200
++++ eric6-17.07/eric/install-debugclients.py   2022-04-03 21:24:48.690481445 +0200
+@@ -249,7 +249,7 @@
+     global progName, modDir, doCleanup, doCompile, distDir
+     global sourceDir
+     
+-    if sys.version_info < (2, 7, 0) or sys.version_info > (3, 9, 9):
++    if sys.version_info < (2, 7, 0):
+         print('Sorry, eric6 requires at least Python 2.7 or '
+               'Python 3 for running.')
+         exit(5)
+--- eric6-17.07/eric/install.py~       2017-05-06 13:37:48.000000000 +0200
++++ eric6-17.07/eric/install.py        2022-04-03 21:25:30.767597607 +0200
+@@ -1136,9 +1136,6 @@
+     elif sys.version_info < (3, 4, 0) and sys.version_info[0] == 3:
+         print('Sorry, you must have Python 3.4.0 or higher.')
+         exit(5)
+-    if sys.version_info > (3, 9, 9):
+-        print('Sorry, eric6 requires Python 3 or Python 2 for running.')
+-        exit(5)
+     
+     try:
+         import xml.etree            # __IGNORE_WARNING__
+@@ -1394,7 +1394,7 @@
+     global macAppBundlePath, macAppBundleName, macPythonExe
+     global pyqtVariant, pyqtOverride, installApis
+     
+-    if sys.version_info < (2, 7, 0) or sys.version_info > (3, 9, 9):
++    if sys.version_info < (2, 7, 0):
+         print('Sorry, eric6 requires at least Python 2.7 or '
+               'Python 3 for running.')
+         exit(5)
+--- eric6-17.07/install-debugclients.py~       2017-07-02 12:13:55.000000000 +0200
++++ eric6-17.07/install-debugclients.py        2022-04-03 21:35:34.435071319 +0200
+@@ -249,7 +249,7 @@
+     global progName, modDir, doCleanup, doCompile, distDir
+     global sourceDir
+     
+-    if sys.version_info < (2, 7, 0) or sys.version_info > (3, 9, 9):
++    if sys.version_info < (2, 7, 0):
+         print('Sorry, eric6 requires at least Python 2.7 or '
+               'Python 3 for running.')
+         exit(5)
This page took 0.047149 seconds and 4 git commands to generate.