]> git.pld-linux.org Git - packages/eric6.git/blob - eric6.spec
03dcd78a3711185ad2ade25a7b34373a85f64ce7
[packages/eric6.git] / eric6.spec
1 %bcond_with     python2 # Use python2 (NOTE: as for 17.03.1 it has issuses in PLD)
2
3 # NOTE: Detlev Offenbach <detlev@die-offenbachs.de> (author) 2017/04/13 wrote:
4 # "eric6 can be used with  Python2 or Python3 and with PyQt5 or PyQt4. 
5 # However, the recommended combination is PyQt5 on Python3.
6
7 %define         module  eric6
8 Summary:        Eric6 - a full featured Python IDE
9 Summary(pl.UTF-8):      Eric6 - pełnowartościowe IDE dla Pythona
10 Name:           eric6
11 Version:        17.07
12 Release:        7
13 License:        GPL v3
14 Group:          Libraries/Python
15 Source0:        https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  c21c097bf36259ff61187e2698b7c50d
17 URL:            http://eric-ide.python-projects.org/index.html
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules
22 BuildRequires:  python-setuptools
23 # NOTE: As for 6.1.8  eric6 still tries to import PyQt5 while having PyQt4 leading to crash
24 #       http://die-offenbachs.homelinux.org:48888/issues/issue204
25 # for --pyqt=4
26 # BuildRequires:        python-PyQt4-qscintilla2
27 # BuildRequires:        python-PyQt4-uic
28 # for --pyqt=5
29 BuildRequires:  python-PyQt5-qscintilla2
30 BuildRequires:  python-PyQt5-uic
31 Requires:       python-PyQt5-qscintilla2
32 Requires:       python-modules
33 Suggests:       python-pylint
34 %else
35 BuildRequires:  python3-PyQt5-qscintilla2
36 BuildRequires:  python3-PyQt5-uic
37 BuildRequires:  python3-modules
38 BuildRequires:  python3-setuptools
39 # NOTE: Not sure if Qt5Svg should be listed here or be R by other BRs.
40 BuildRequires:  Qt5Svg
41 Requires:       python3-PyQt5-qscintilla2
42 Requires:       python3-modules
43 Suggests:       python3-pylint
44 %endif
45
46 BuildArch:      noarch
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Eric is a Python IDE written using PyQt and QScintilla. It provides
51 various features such as any number of open editors, an integrated
52 (remote) debugger, project management facilities, unit test,
53 refactoring and much more.
54
55 %description -l pl.UTF-8
56 Eric jest pythonowym graficznym środowiskiem programistycznym
57 używającym PyQt i QScintilla.
58
59 %prep
60 %setup -q
61
62 %build
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %if %{with python2}
67 python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
68 %else
69 python3 install.py -z -c -b %{_bindir} -d %{py3_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
70 %endif
71 mkdir $RPM_BUILD_ROOT%{_datadir}/appdata
72 mv $RPM_BUILD_ROOT%{_datadir}/metainfo/eric6.appdata.xml $RPM_BUILD_ROOT%{_datadir}/appdata
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README.rst
80 %if %{with python2}
81 %{py_sitescriptdir}/%{module}
82 %else
83 %{py3_sitescriptdir}/%{module}
84 %endif
85
86 %attr(755,root,root) %{_bindir}/eric6
87 %attr(755,root,root) %{_bindir}/eric6_*
88 # for --pyqt=4
89 # %{_datadir}/qt4/qsci/api/qss/
90 # %{_datadir}/qt4/qsci/api/ruby/
91 # NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
92 # %{_datadir}/qt4/qsci/api/python/eric6.*
93 # %{_datadir}/qt4/qsci/api/python/zope-*.api
94
95 # for --pyqt=5
96 %{_datadir}/qt5/qsci/api/qss/
97 %{_datadir}/qt5/qsci/api/ruby/
98 %{_datadir}/qt5/qsci/api/python/eric6.*
99 %{_datadir}/qt5/qsci/api/python/zope-*.api
100
101 %{_pixmapsdir}/eric*.png
102 %{_desktopdir}/eric6.desktop
103 %{_desktopdir}/eric6_webbrowser.desktop
104 %{_desktopdir}/eric6_browser.desktop
105 %{_datadir}/appdata/eric6.appdata.xml
106 %if %{with python2}
107 %{py_sitescriptdir}/eric6config.py
108 %{py_sitescriptdir}/eric6plugins
109 %else
110 %{py3_sitescriptdir}/eric6config.py
111 %{py3_sitescriptdir}/eric6plugins
112 %endif
This page took 0.071185 seconds and 2 git commands to generate.