]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
- release 4
[packages/epiphany.git] / epiphany.spec
1 # Conditinal build:
2 %bcond_without  mozilla_firefox # build without mozilla-firefox-devel
3 #
4 %define         basever 2.14
5 Summary:        Epiphany - gecko-based GNOME web browser
6 Summary(es):    Epiphany - navigador Web de GNOME basado en gecko
7 Summary(pl):    Epiphany - przegl±darka WWW dla GNOME
8 Name:           epiphany
9 Version:        2.14.1
10 Release:        4
11 License:        GPL v2
12 Group:          X11/Applications/Networking
13 Source0:        http://ftp.gnome.org/pub/gnome/sources/epiphany/%{basever}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  69f9760646b736d953f24442e0e38f7b
15 Patch0:         %{name}-first-tab.patch
16 Patch1:         %{name}-desktop.patch
17 Patch2:         %{name}-mozilla_includes.patch
18 Patch3:         %{name}-pld-homepage.patch
19 Patch4:         %{name}-configure.patch
20 URL:            http://www.gnome.org/projects/epiphany/
21 BuildRequires:  GConf2-devel >= 2.14.0
22 BuildRequires:  ORBit2-devel >= 1:2.14.0
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake >= 1.8
25 BuildRequires:  dbus-glib-devel >= 0.60
26 BuildRequires:  gnome-common >= 2.8.0
27 BuildRequires:  gnome-desktop-devel >= 2.14.0
28 BuildRequires:  gnome-doc-utils >= 0.3.2-1
29 BuildRequires:  gnome-vfs2-devel >= 2.14.0
30 BuildRequires:  gtk+2-devel >= 2:2.8.3
31 BuildRequires:  gtk-doc >= 1.3
32 BuildRequires:  intltool >= 0.33
33 BuildRequires:  iso-codes >= 0.35
34 BuildRequires:  libglade2-devel >= 1:2.5.1
35 BuildRequires:  libgnomeprintui-devel >= 2.12.0
36 BuildRequires:  libgnomeui-devel >= 2.14.0
37 BuildRequires:  startup-notification-devel >= 0.5
38 BuildRequires:  libtool
39 BuildRequires:  libxslt-devel >= 1.1.15
40 %if %{with mozilla_firefox}
41 BuildRequires:  mozilla-firefox-devel >= 1.0.5
42 %else
43 BuildRequires:  mozilla-devel >= 5:1.7.9
44 %endif
45 BuildRequires:  pkgconfig
46 BuildRequires:  python-gnome-devel >= 2.6.0
47 BuildRequires:  python-pygtk-devel >= 2.6.0
48 BuildRequires:  rpmbuild(macros) >= 1.197
49 BuildRequires:  scrollkeeper
50 Requires(post,preun):   GConf2
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  scrollkeeper
53 Requires:       dbus >= 0.60
54 Requires:       gnome-icon-theme >= 2.14.0
55 Requires:       gtk+2 >= 2:2.8.3
56 Requires:       libgnomeui >= 2.14.0
57 %if %{with mozilla_firefox}
58 %requires_eq    mozilla-firefox
59 %else
60 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
61 %endif
62 Obsoletes:      python-epiphany
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 # can be provided by mozilla or mozilla-embedded
66 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
67
68 %description
69 GNOME browser based on Gecko (Mozilla rendering engine).
70
71 %description -l es
72 Navigador Web de GNOME basado en Gecko (el engine plasmante de Mozilla).
73
74 %description -l pl
75 Epiphany jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
76 interpretacji stron Mozilli).
77
78 %package devel
79 Summary:        Epiphany header files
80 Summary(es):    Ficheros de cabecera de Epiphany
81 Summary(pl):    Pliki nag³ówkowe Epiphany
82 Group:          X11/Applications/Networking
83 # doesn't require base
84 Requires:       gtk+2-devel >= 2:2.8.3
85 Requires:       libxslt-devel >= 1.1.15
86
87 %description devel
88 Epiphany header files for plugin development.
89
90 %description devel -l es
91 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
92
93 %description devel -l pl
94 Pliki nag³ówkowe Epiphany do tworzenia wtyczek.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101 %patch3 -p1
102 %patch4 -p1
103
104 %build
105 gnome-doc-prepare --copy --force
106 %{__gnome_doc_common}
107 %{__glib_gettextize}
108 %{__intltoolize}
109 %{__libtoolize}
110 %{__aclocal} -I m4
111 %{__autoheader}
112 %{__automake}
113 %{__autoconf}
114
115 %configure \
116         --disable-schemas-install \
117         --enable-dbus \
118         --enable-gtk-doc \
119         --enable-python \
120         --with-html-dir=%{_gtkdocdir}
121 # CFLAGS is a hack for gcc 3.3
122 %{__make} \
123         CFLAGS="%{rpmcflags} -fno-strict-aliasing"
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT \
131         HTML_DIR=%{_gtkdocdir}
132
133 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
134 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
135
136 # epiphany-2.0.mo, but gnome/help/epiphany
137 %find_lang %{name}-2.0 --with-gnome --all-name
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 %gconf_schema_install epiphany-fonts.schemas
144 %gconf_schema_install epiphany-lockdown.schemas
145 %gconf_schema_install epiphany-pango.schemas
146 %gconf_schema_install epiphany.schemas
147 %scrollkeeper_update_post
148 %update_desktop_database_post
149
150 %preun
151 %gconf_schema_uninstall epiphany-fonts.schemas
152 %gconf_schema_uninstall epiphany-lockdown.schemas
153 %gconf_schema_uninstall epiphany-pango.schemas
154 %gconf_schema_uninstall epiphany.schemas
155
156 %postun
157 %scrollkeeper_update_postun
158 %update_desktop_database_postun
159
160 %files -f %{name}-2.0.lang
161 %defattr(644,root,root,755)
162 %doc AUTHORS ChangeLog NEWS README
163 %attr(755,root,root) %{_bindir}/*
164 %{_datadir}/dbus-1/services/*.service
165 %{_datadir}/%{name}
166 %{_desktopdir}/*
167 %{_pixmapsdir}/*
168 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
169 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
170 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
171 %{_sysconfdir}/gconf/schemas/epiphany.schemas
172 %{_omf_dest_dir}/*
173 %dir %{_libdir}/%{name}
174 %dir %{_libdir}/%{name}/%{basever}
175 %dir %{_libdir}/%{name}/%{basever}/extensions
176 %dir %{_libdir}/%{name}/%{basever}/plugins
177 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
178 %{_mandir}/man1/*
179
180 %files devel
181 %defattr(644,root,root,755)
182 %{_aclocaldir}/*
183 %{_includedir}/epiphany
184 %{_pkgconfigdir}/*.pc
185 %{_datadir}/pygtk/*/defs/epiphany.defs
186 %{_gtkdocdir}/*
This page took 0.126153 seconds and 4 git commands to generate.