]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
- use real build date, not tarball release date
[packages/epiphany.git] / epiphany.spec
1 #
2 #Conditional build:
3 %bcond_with     webkit          # Build with experimental webkit suppor instead of xulrunner
4 #
5 %define         basever         2.22
6 Summary:        Epiphany - gecko-based GNOME web browser
7 Summary(es.UTF-8):      Epiphany - navigador Web de GNOME basado en gecko
8 Summary(pl.UTF-8):      Epiphany - przeglądarka WWW dla GNOME
9 Name:           epiphany
10 Version:        2.22.3
11 Release:        2
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.22/%{name}-%{version}.tar.bz2
15 # Source0-md5:  7d058b57cb3e992889e456848fcc89a9
16 Patch0:         %{name}-pld-homepage.patch
17 Patch1:         %{name}-configure.patch
18 Patch2:         %{name}-ti-agent.patch
19 Patch3:         %{name}-agent.patch
20 Patch4:         %{name}-lt.patch
21 Patch5:         %{name}-libxul.patch
22 Patch6:         %{name}-ssl_oldapi.patch
23 Patch7:         %{name}-build_date.patch
24 URL:            http://www.gnome.org/projects/epiphany/
25 BuildRequires:  GConf2-devel >= 2.20.0
26 BuildRequires:  NetworkManager-devel
27 BuildRequires:  ORBit2-devel >= 1:2.14.9
28 BuildRequires:  autoconf >= 2.59
29 BuildRequires:  automake >= 1:1.9
30 BuildRequires:  dbus-glib-devel >= 0.73
31 BuildRequires:  enchant-devel >= 1.0
32 BuildRequires:  gnome-common >= 2.20.0
33 BuildRequires:  gnome-desktop-devel >= 2.20.0
34 BuildRequires:  gnome-doc-utils >= 0.12.0
35 BuildRequires:  gnome-vfs2-devel >= 2.22.0
36 BuildRequires:  gtk+2-devel >= 2:2.12.0
37 BuildRequires:  gtk-doc >= 1.8
38 %if %{with webkit}
39 BuildRequires:  gtk-webkit-devel
40 BuildRequires:  libssh2-devel
41 %endif
42 BuildRequires:  intltool >= 0.36.2
43 BuildRequires:  iso-codes >= 0.53
44 BuildRequires:  libglade2-devel >= 1:2.6.2
45 BuildRequires:  libgnomeprintui-devel >= 2.18.0
46 BuildRequires:  libgnomeui-devel >= 2.22.0
47 BuildRequires:  libtool
48 BuildRequires:  libxml2-devel >= 1:2.6.28
49 BuildRequires:  libxslt-devel >= 1.1.20
50 BuildRequires:  pkgconfig
51 BuildRequires:  python-gnome-devel >= 2.20.0
52 BuildRequires:  python-pygtk-devel >= 2:2.12.0
53 BuildRequires:  rpm >= 4.4.9-56
54 BuildRequires:  rpmbuild(find_lang) >= 1.23
55 BuildRequires:  rpmbuild(macros) >= 1.311
56 BuildRequires:  scrollkeeper
57 BuildRequires:  startup-notification-devel >= 0.8
58 %if %{without webkit}
59 BuildRequires:  xulrunner
60 BuildRequires:  xulrunner-devel >= 1.9.0.1-1
61 %endif
62 Requires(post,postun):  desktop-file-utils
63 Requires(post,postun):  gtk+2
64 Requires(post,postun):  hicolor-icon-theme
65 Requires(post,postun):  scrollkeeper
66 Requires(post,preun):   GConf2
67 Requires:       dbus >= 1.0.2
68 Requires:       gnome-icon-theme >= 2.22.0
69 Requires:       libgnomeui >= 2.22.0
70 %if %{without webkit}
71 %requires_eq    xulrunner
72 %endif
73 Obsoletes:      python-epiphany
74 # sr@Latn vs. sr@latin
75 Conflicts:      glibc-misc < 6:2.7
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %if %{without webkit}
79 # can be provided by mozilla or mozilla-embedded
80 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
81 # we have strict deps for it
82 %define         _noautoreq      libxpcom.so
83 %endif
84
85 %description
86 GNOME browser based on Gecko (Mozilla rendering engine).
87
88 %description -l es.UTF-8
89 Navigador Web de GNOME basado en Gecko (el engine plasmante de
90 Mozilla).
91
92 %description -l pl.UTF-8
93 Epiphany jest przeglądarką WWW bazującą na Gecko (mechanizmie
94 interpretacji stron Mozilli).
95
96 %package devel
97 Summary:        Epiphany header files
98 Summary(es.UTF-8):      Ficheros de cabecera de Epiphany
99 Summary(pl.UTF-8):      Pliki nagłówkowe Epiphany
100 Group:          X11/Applications/Networking
101 # doesn't require base
102 Requires:       gtk+2-devel >= 2:2.12.0
103 Requires:       libxslt-devel >= 1.1.20
104
105 %description devel
106 Epiphany header files for plugin development.
107
108 %description devel -l es.UTF-8
109 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
110
111 %description devel -l pl.UTF-8
112 Pliki nagłówkowe Epiphany do tworzenia wtyczek.
113
114 %package apidocs
115 Summary:        Epiphany API documentation
116 Summary(pl.UTF-8):      Dokumentacja API Epiphany
117 Group:          Documentation
118 Requires:       gtk-doc-common
119
120 %description apidocs
121 Epiphany API documentation.
122
123 %description apidocs -l pl.UTF-8
124 Dokumentacja API Epiphany.
125
126 %prep
127 %setup -q
128 %patch0 -p1
129 %patch1 -p1
130 %if "%{pld_release}" == "ti"
131 %patch2 -p1
132 %else
133 %patch3 -p1
134 %endif
135 %patch4 -p1
136 %patch5 -p1
137 %patch6 -p1
138 %patch7 -p1
139
140 sed -i -e 's#sr@Latn#sr@latin#' po/LINGUAS
141 mv po/sr@{Latn,latin}.po
142
143 %build
144 %{__gnome_doc_prepare}
145 %{__gnome_doc_common}
146 %{__glib_gettextize}
147 %{__intltoolize}
148 %{__libtoolize}
149 %{__aclocal} -I m4
150 %{__autoheader}
151 %{__automake}
152 %{__autoconf}
153 %configure \
154         --disable-schemas-install \
155         --enable-dbus \
156         %{?!with_webkit:--enable-gtk-doc} \
157         --enable-network-manager \
158         --enable-python \
159         %if %{with webkit}
160         --with-engine=webkit \
161         %else
162         --with-gecko=libxul-embedding \
163         %endif
164         --with-html-dir=%{_gtkdocdir}
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT \
173         HTML_DIR=%{_gtkdocdir}
174
175 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
176 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/LowContrastLargePrint
177
178 %find_lang %{name} --with-gnome --with-omf
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post
184 %gconf_schema_install epiphany-fonts.schemas
185 %gconf_schema_install epiphany-lockdown.schemas
186 %gconf_schema_install epiphany-pango.schemas
187 %gconf_schema_install epiphany.schemas
188 %scrollkeeper_update_post
189 %update_desktop_database_post
190 %update_icon_cache hicolor
191
192 %preun
193 %gconf_schema_uninstall epiphany-fonts.schemas
194 %gconf_schema_uninstall epiphany-lockdown.schemas
195 %gconf_schema_uninstall epiphany-pango.schemas
196 %gconf_schema_uninstall epiphany.schemas
197
198 %postun
199 %scrollkeeper_update_postun
200 %update_desktop_database_postun
201 %update_icon_cache hicolor
202
203 %files -f %{name}.lang
204 %defattr(644,root,root,755)
205 %doc AUTHORS ChangeLog NEWS README
206 %attr(755,root,root) %{_bindir}/*
207 %{_datadir}/dbus-1/services/*.service
208 %{_datadir}/%{name}
209 %{_desktopdir}/*.desktop
210 %{_iconsdir}/*/*/apps/*.*
211 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
212 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
213 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
214 %{_sysconfdir}/gconf/schemas/epiphany.schemas
215 %dir %{_libdir}/%{name}
216 %dir %{_libdir}/%{name}/%{basever}
217 %dir %{_libdir}/%{name}/%{basever}/extensions
218 %if %{without webkit}
219 %dir %{_libdir}/%{name}/%{basever}/plugins
220 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
221 %endif
222 %{_mandir}/man1/*
223
224 %files devel
225 %defattr(644,root,root,755)
226 %{_aclocaldir}/*
227 %{_includedir}/epiphany
228 %{_pkgconfigdir}/*.pc
229 %{_datadir}/pygtk/*/defs/epiphany.defs
230
231 %files apidocs
232 %defattr(644,root,root,755)
233 %{_gtkdocdir}/*
This page took 0.103387 seconds and 3 git commands to generate.