]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
- build with firefox by default
[packages/epiphany.git] / epiphany.spec
1 # Conditinal build:
2 %bcond_without  mozilla_firefox # build without mozilla-firefox-devel
3 #
4 %define         basever 2.14
5 Summary:        Epiphany - gecko-based GNOME web browser
6 Summary(es):    Epiphany - navigador Web de GNOME basado en gecko
7 Summary(pl):    Epiphany - przegl±darka WWW dla GNOME
8 Name:           epiphany
9 Version:        2.14.1
10 Release:        2
11 License:        GPL v2
12 Group:          X11/Applications/Networking
13 Source0:        http://ftp.gnome.org/pub/gnome/sources/epiphany/%{basever}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  69f9760646b736d953f24442e0e38f7b
15 Patch0:         %{name}-first-tab.patch
16 Patch1:         %{name}-desktop.patch
17 Patch2:         %{name}-mozilla_includes.patch
18 Patch3:         %{name}-pld-homepage.patch
19 Patch4:         %{name}-configure.patch
20 URL:            http://www.gnome.org/projects/epiphany/
21 BuildRequires:  GConf2-devel >= 2.10.0
22 BuildRequires:  ORBit2-devel >= 1:2.12.1
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake >= 1.8
25 BuildRequires:  dbus-glib-devel >= 0.34
26 BuildRequires:  gnome-common >= 2.8.0
27 BuildRequires:  gnome-desktop-devel >= 2.10.0-2
28 BuildRequires:  gnome-doc-utils >= 0.3.2-1
29 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
30 BuildRequires:  gtk+2-devel >= 2:2.8.3
31 BuildRequires:  gtk-doc >= 1.3
32 BuildRequires:  intltool >= 0.33
33 BuildRequires:  iso-codes >= 0.35
34 BuildRequires:  libglade2-devel >= 1:2.5.1
35 BuildRequires:  libgnomeprintui-devel >= 2.11.0-3
36 BuildRequires:  libgnomeui-devel >= 2.10.0-2
37 BuildRequires:  startup-notification-devel >= 0.5
38 BuildRequires:  libtool
39 BuildRequires:  libxslt-devel >= 1.1.15
40 %if %{with mozilla_firefox}
41 BuildRequires:  mozilla-firefox-devel >= 1.0.5
42 %else
43 BuildRequires:  mozilla-devel >= 5:1.7.9
44 %endif
45 BuildRequires:  pkgconfig
46 BuildRequires:  python-gnome-devel >= 2.6.0
47 BuildRequires:  python-pygtk-devel >= 2.6.0
48 BuildRequires:  rpmbuild(macros) >= 1.197
49 BuildRequires:  scrollkeeper
50 Requires(post,preun):   GConf2
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  scrollkeeper
53 Requires:       dbus >= 0.34
54 Requires:       gnome-icon-theme >= 2.10.0
55 Requires:       gtk+2 >= 2:2.8.3
56 %if %{with mozilla_firefox}
57 %requires_eq    mozilla-firefox
58 %else
59 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
60 %endif
61 Obsoletes:      python-epiphany
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 # can be provided by mozilla or mozilla-embedded
65 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
66
67 %description
68 GNOME browser based on Gecko (Mozilla rendering engine).
69
70 %description -l es
71 Navigador Web de GNOME basado en Gecko (el engine plasmante de Mozilla).
72
73 %description -l pl
74 Epiphany jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
75 interpretacji stron Mozilli).
76
77 %package devel
78 Summary:        Epiphany header files
79 Summary(es):    Ficheros de cabecera de Epiphany
80 Summary(pl):    Pliki nag³ówkowe Epiphany
81 Group:          X11/Applications/Networking
82 # doesn't require base
83 Requires:       gtk+2-devel >= 2:2.8.3
84 Requires:       libxslt-devel >= 1.1.15
85
86 %description devel
87 Epiphany header files for plugin development.
88
89 %description devel -l es
90 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
91
92 %description devel -l pl
93 Pliki nag³ówkowe Epiphany do tworzenia wtyczek.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100 %patch3 -p1
101 %patch4 -p1
102
103 %build
104 gnome-doc-prepare --copy --force
105 %{__gnome_doc_common}
106 %{__glib_gettextize}
107 %{__intltoolize}
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoheader}
111 %{__automake}
112 %{__autoconf}
113
114 %configure \
115         --disable-schemas-install \
116         --enable-dbus \
117         --enable-gtk-doc \
118         --enable-python \
119         --with-html-dir=%{_gtkdocdir}
120 # CFLAGS is a hack for gcc 3.3
121 %{__make} \
122         CFLAGS="%{rpmcflags} -fno-strict-aliasing"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT \
130         HTML_DIR=%{_gtkdocdir}
131
132 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
133 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
134
135 # epiphany-2.0.mo, but gnome/help/epiphany
136 %find_lang %{name}-2.0 --with-gnome --all-name
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 %gconf_schema_install epiphany-fonts.schemas
143 %gconf_schema_install epiphany-lockdown.schemas
144 %gconf_schema_install epiphany-pango.schemas
145 %gconf_schema_install epiphany.schemas
146 %scrollkeeper_update_post
147 %update_desktop_database_post
148
149 %preun
150 %gconf_schema_uninstall epiphany-fonts.schemas
151 %gconf_schema_uninstall epiphany-lockdown.schemas
152 %gconf_schema_uninstall epiphany-pango.schemas
153 %gconf_schema_uninstall epiphany.schemas
154
155 %postun
156 %scrollkeeper_update_postun
157 %update_desktop_database_postun
158
159 %files -f %{name}-2.0.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog NEWS README
162 %attr(755,root,root) %{_bindir}/*
163 %{_datadir}/dbus-1/services/*.service
164 %{_datadir}/%{name}
165 %{_desktopdir}/*
166 %{_pixmapsdir}/*
167 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
168 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
169 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
170 %{_sysconfdir}/gconf/schemas/epiphany.schemas
171 %{_omf_dest_dir}/*
172 %dir %{_libdir}/%{name}
173 %dir %{_libdir}/%{name}/%{basever}
174 %dir %{_libdir}/%{name}/%{basever}/extensions
175 %dir %{_libdir}/%{name}/%{basever}/plugins
176 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
177 %{_mandir}/man1/*
178
179 %files devel
180 %defattr(644,root,root,755)
181 %{_aclocaldir}/*
182 %{_includedir}/epiphany
183 %{_pkgconfigdir}/*.pc
184 %{_datadir}/pygtk/*/defs/epiphany.defs
185 %{_gtkdocdir}/*
This page took 0.130575 seconds and 3 git commands to generate.