]> git.pld-linux.org Git - packages/encfs.git/blob - encfs.spec
- disable deprecated blowsfish cipher, rebuild with openssl 3.0.0, rel 3
[packages/encfs.git] / encfs.spec
1 # TODO: duplicated locales (es vs es_ES, fr vs fr_FR)
2 %bcond_without  tests
3 Summary:        Encrypted pass-thru filesystem for Linux
4 Summary(pl.UTF-8):      Zaszyfrowany system plików dla Linuksa
5 Name:           encfs
6 Version:        1.9.5
7 Release:        3
8 License:        GPL v2
9 Group:          Applications/System
10 Source0:        https://github.com/vgough/encfs/archive/v%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  0244c6a6c0399a068c02ea078ce393d1
12 URL:            http://www.arg0.net/encfs
13 BuildRequires:  boost-devel >= 1.34.0
14 BuildRequires:  gettext-tools >= 0.17
15 BuildRequires:  libfuse-devel >= 2.5
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  openssl-devel >= 0.9.7d
18 BuildRequires:  perl-tools-pod
19 BuildRequires:  pkgconfig
20 BuildRequires:  rlog-devel >= 1.3
21 Requires:       rlog >= 1.3
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 EncFS implements an encrypted filesystem in userspace using FUSE. FUSE
26 provides a Linux kernel module which allows virtual filesystems to be
27 written in userspace. EncFS encrypts all data and filenames in the
28 filesystem and passes access through to the underlying filesystem.
29 Similar to CFS except that it does not use NFS.
30
31 %description -l pl.UTF-8
32 EncFS jest implementacją zaszyfrowanego systemu plików w przestrzeni
33 użytkownika przy użyciu FUSE. FUSE dostarcza moduł jądra Linuksa
34 pozwalający na obsługę wirtualnych systemów plików w przestrzeni
35 użytkownika. EncFS szyfruje wszystkie dane oraz nazwy plików w
36 systemie plików i przekazuje kontrolę do leżącego niżej systemu
37 plików. Jest podobny do CFS-a, ale nie używa NFS-a.
38
39 %prep
40 %setup -q
41
42 %build
43 install -d build
44 cd build
45 export CXXFLAGS="%{rpmcxxflags} -DOPENSSL_NO_BF"
46 %cmake .. \
47         -DBUILD_SHARED_LIBS:BOOL=OFF
48
49 %{__make}
50
51 %if %{with tests}
52 %{__make} unittests
53 %{__make} test
54 %endif
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} -C build install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 # duplicate of de,es,fr,hu,pt
63 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{de_DE,es_ES,fr_FR,pt_PT}
64
65 %find_lang %{name}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files -f %{name}.lang
71 %defattr(644,root,root,755)
72 %doc AUTHORS ChangeLog README.md
73 %attr(755,root,root) %{_bindir}/encfs
74 %attr(755,root,root) %{_bindir}/encfsctl
75 %attr(755,root,root) %{_bindir}/encfssh
76 %{_mandir}/man1/encfs.1*
77 %{_mandir}/man1/encfsctl.1*
78 %{_mandir}/man1/encfssh.1*
This page took 0.090102 seconds and 4 git commands to generate.