]> git.pld-linux.org Git - packages/enca.git/blob - enca.spec
- added apidocs bcond and subpackage
[packages/enca.git] / enca.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # disable gtk-doc
4 %bcond_without  recode  # build without recode support
5 #
6 Summary:        Extremely Naive Charset Analyser
7 Summary(pl.UTF-8):      Skrajnie naiwny analizator zestawów znaków
8 Name:           enca
9 Version:        1.9
10 Release:        3
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://trific.ath.cx/Ftp/enca/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b3581e28d68d452286fb0bfe58bed3b3
15 Patch0:         %{name}-libdir.patch
16 URL:            http://trific.ath.cx/software/enca/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{?with_apidocs:BuildRequires: gtk-doc >= 1.0}
20 BuildRequires:  iconv
21 %{?with_recode:BuildRequires:   recode-devel}
22 Requires:       /bin/mktemp
23 Requires:       %{name}-libs = %{version}-%{release}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Enca is an Extremely Naive Charset Analyser. It detects character set
28 and encoding of text files and can also convert them to other
29 encodings using either a built-in converter or external libraries and
30 tools like libiconv, librecode, or cstocs.
31
32 Currently, it has support for Belarussian, Bulgarian, Croatian, Czech,
33 Estonian, Latvian, Lithuanian, Polish, Russian, Slovak, Slovene, and
34 Ukrainian and some multibyte encodings (mostly variants of Unicode)
35 independently on the language.
36
37 %description -l pl.UTF-8
38 Enca to Extremely Naive Charset Analyser (skrajnie naiwny analizator
39 zestawów znaków). Wykrywa zestaw znaków i kodowanie plików tekstowych,
40 może także konwertować do innych kodowań przy użyciu wbudowanego
41 konwertera lub zewnętrznych bibliotek i narzędzi takich jak libiconv,
42 librecode czy cstocs.
43
44 Aktualnie obsługiwane są znaki białoruskie, bułgarskie, chorwackie,
45 czeskie, estońskie, litewskie, łotewskie, polskie, rosyjskie,
46 słowackie, słoweńskie i ukraińskie oraz niektóre kodowania
47 wielobajtowe (głównie warianty unikodu) niezależnie od języka.
48
49 %package libs
50 Summary:        Shared Enca library
51 Summary(pl.UTF-8):      Biblioteka współdzielona Enca
52 Group:          Libraries
53
54 %description libs
55 This package contains shared Enca library other programs can make use
56 of.
57
58 %description libs -l pl.UTF-8
59 Ten pakiet zawiera bibliotekę współdzieloną Enca, która może być
60 wykorzystywana przez inne programy.
61
62 %package devel
63 Summary:        Header files for ENCA library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ENCA
65 Group:          Development/Libraries
66 Requires:       %{name}-libs = %{version}-%{release}
67
68 %description devel
69 Header files for ENCA library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki ENCA.
73
74 %package static
75 Summary:        Static ENCA library
76 Summary(pl.UTF-8):      Statyczna biblioteka ENCA
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static ENCA library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka ENCA.
85
86 %package apidocs
87 Summary:        ENCA library API documentation
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki ENCA
89 Group:          Documentation
90 Requires:       gtk-doc-common
91
92 %description apidocs
93 ENCA library API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API biblioteki ENCA.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103 cp -f /usr/share/automake/config.sub .
104 %{__autoconf}
105 %configure \
106         MKTEMP_PROG=/bin/mktemp \
107         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
108         --with-html-dir=%{_gtkdocdir}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/enconv.1
119 echo '.so enca.1' > $RPM_BUILD_ROOT%{_mandir}/man1/enconv.1
120
121 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   libs -p /sbin/ldconfig
127 %postun libs -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog FAQ NEWS README THANKS TODO
132 %attr(755,root,root) %{_bindir}/*
133 %attr(755,root,root) %{_libexecdir}/enca
134 %{_mandir}/man1/*
135
136 %files libs
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
139
140 %files devel
141 %defattr(644,root,root,755)
142 %doc README.devel
143 %attr(755,root,root) %{_libdir}/lib*.so
144 %{_libdir}/lib*.la
145 %{_includedir}/*.h
146 %{_pkgconfigdir}/*.pc
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/lib*.a
151
152 %if %{with apidocs}
153 %files apidocs
154 %defattr(644,root,root,755)
155 %{_gtkdocdir}/libenca
156 %endif
This page took 0.061554 seconds and 3 git commands to generate.