]> git.pld-linux.org Git - packages/enca.git/blame_incremental - enca.spec
Release 2 (by relup.sh)
[packages/enca.git] / enca.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # disable gtk-doc
4%bcond_without recode # build without recode support
5
6Summary: Extremely Naive Charset Analyser
7Summary(pl.UTF-8): Skrajnie naiwny analizator zestawów znaków
8Name: enca
9Version: 1.19
10Release: 2
11License: GPL v2
12Group: Libraries
13Source0: http://dl.cihar.com/enca/%{name}-%{version}.tar.xz
14# Source0-md5: a7a0c152658e012db701a48ae8b79525
15URL: http://cihar.com/software/enca/
16BuildRequires: autoconf >= 2.52
17BuildRequires: automake >= 1:1.8
18%{?with_apidocs:BuildRequires: gtk-doc >= 1.0}
19BuildRequires: iconv
20BuildRequires: libtool
21%{?with_recode:BuildRequires: recode-devel}
22BuildRequires: tar >= 1:1.22
23BuildRequires: xz
24Requires: %{name}-libs = %{version}-%{release}
25Requires: /bin/mktemp
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Enca is an Extremely Naive Charset Analyser. It detects character set
30and encoding of text files and can also convert them to other
31encodings using either a built-in converter or external libraries and
32tools like libiconv, librecode, or cstocs.
33
34Currently, it has support for Belarussian, Bulgarian, Croatian, Czech,
35Estonian, Latvian, Lithuanian, Polish, Russian, Slovak, Slovene, and
36Ukrainian and some multibyte encodings (mostly variants of Unicode)
37independently on the language.
38
39%description -l pl.UTF-8
40Enca to Extremely Naive Charset Analyser (skrajnie naiwny analizator
41zestawów znaków). Wykrywa zestaw znaków i kodowanie plików tekstowych,
42może także konwertować do innych kodowań przy użyciu wbudowanego
43konwertera lub zewnętrznych bibliotek i narzędzi takich jak libiconv,
44librecode czy cstocs.
45
46Aktualnie obsługiwane są znaki białoruskie, bułgarskie, chorwackie,
47czeskie, estońskie, litewskie, łotewskie, polskie, rosyjskie,
48słowackie, słoweńskie i ukraińskie oraz niektóre kodowania
49wielobajtowe (głównie warianty unikodu) niezależnie od języka.
50
51%package libs
52Summary: Shared Enca library
53Summary(pl.UTF-8): Biblioteka współdzielona Enca
54Group: Libraries
55
56%description libs
57This package contains shared Enca library other programs can make use
58of.
59
60%description libs -l pl.UTF-8
61Ten pakiet zawiera bibliotekę współdzieloną Enca, która może być
62wykorzystywana przez inne programy.
63
64%package devel
65Summary: Header files for ENCA library
66Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ENCA
67Group: Development/Libraries
68Requires: %{name}-libs = %{version}-%{release}
69
70%description devel
71Header files for ENCA library.
72
73%description devel -l pl.UTF-8
74Pliki nagłówkowe biblioteki ENCA.
75
76%package static
77Summary: Static ENCA library
78Summary(pl.UTF-8): Statyczna biblioteka ENCA
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81
82%description static
83Static ENCA library.
84
85%description static -l pl.UTF-8
86Statyczna biblioteka ENCA.
87
88%package apidocs
89Summary: ENCA library API documentation
90Summary(pl.UTF-8): Dokumentacja API biblioteki ENCA
91Group: Documentation
92Requires: gtk-doc-common
93BuildArch: noarch
94
95%description apidocs
96ENCA library API documentation.
97
98%description apidocs -l pl.UTF-8
99Dokumentacja API biblioteki ENCA.
100
101%prep
102%setup -q
103
104%build
105%{__libtoolize}
106%{__aclocal} -I m4
107%{__autoconf}
108%{__autoheader}
109%{__automake}
110%configure \
111 MKTEMP_PROG=/bin/mktemp \
112 --enable-gtk-doc%{!?with_apidocs:=no} \
113 --with-html-dir=%{_gtkdocdir}
114
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
119
120%{__make} install \
121 DESTDIR=$RPM_BUILD_ROOT
122
123%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/enconv.1
124echo '.so enca.1' > $RPM_BUILD_ROOT%{_mandir}/man1/enconv.1
125
126%{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%post libs -p /sbin/ldconfig
132%postun libs -p /sbin/ldconfig
133
134%files
135%defattr(644,root,root,755)
136%doc AUTHORS ChangeLog FAQ NEWS README THANKS TODO
137%attr(755,root,root) %{_bindir}/enca
138%attr(755,root,root) %{_bindir}/enconv
139%attr(755,root,root) %{_libexecdir}/enca
140%{_mandir}/man1/enca.1*
141%{_mandir}/man1/enconv.1*
142
143%files libs
144%defattr(644,root,root,755)
145%attr(755,root,root) %{_libdir}/libenca.so.*.*.*
146%attr(755,root,root) %ghost %{_libdir}/libenca.so.0
147
148%files devel
149%defattr(644,root,root,755)
150%doc DEVELOP.md
151%attr(755,root,root) %{_libdir}/libenca.so
152%{_libdir}/libenca.la
153%{_includedir}/enca.h
154%{_pkgconfigdir}/enca.pc
155
156%files static
157%defattr(644,root,root,755)
158%{_libdir}/libenca.a
159
160%if %{with apidocs}
161%files apidocs
162%defattr(644,root,root,755)
163%{_gtkdocdir}/libenca
164%endif
This page took 0.293387 seconds and 5 git commands to generate.