]> git.pld-linux.org Git - packages/emotion.git/blob - emotion.spec
- rebuild with DirectFB 1.6.x
[packages/emotion.git] / emotion.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # don't build gstreamer decoder
4 %bcond_without  vlc             # don't build vlc generic decoder
5 %bcond_without  xine            # don't build xine decoder
6 %bcond_without  static_libs     # don't build static library
7 #
8 %define         ecore_ver       1.7.0
9 %define         edje_ver        1.7.0
10 %define         eet_ver         1.7.0
11 %define         eeze_ver        1.7.0
12 %define         eina_ver        1.7.0
13 %define         eio_ver         1.7.0
14 %define         evas_ver        1.7.0
15
16 Summary:        Emotion - EFL media playback library
17 Summary(pl.UTF-8):      Emotion - biblioteka EFL do odtwarzania multimediów
18 Name:           emotion
19 Version:        1.7.0
20 Release:        2
21 License:        BSD-like
22 Group:          Libraries
23 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
24 # Source0-md5:  26516d3e5ba55ba64f097e9d4e88af0f
25 URL:            http://trac.enlightenment.org/e/wiki/Emotion
26 BuildRequires:  autoconf >= 2.60
27 BuildRequires:  automake >= 1.6
28 BuildRequires:  ecore-devel >= %{ecore_ver}
29 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
30 BuildRequires:  ecore-fb-devel >= %{ecore_ver}
31 BuildRequires:  ecore-x-devel >= %{ecore_ver}
32 BuildRequires:  edje >= %{edje_ver}
33 BuildRequires:  edje-devel >= %{edje_ver}
34 BuildRequires:  eet-devel >= %{eet_ver}
35 BuildRequires:  eeze-devel >= %{eeze_ver}
36 BuildRequires:  eio-devel >= %{eio_ver}
37 BuildRequires:  eina-devel >= %{eina_ver}
38 BuildRequires:  evas-devel >= %{evas_ver}
39 %if %{with gstreamer}
40 BuildRequires:  gstreamer-devel >= 0.10.2
41 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.34
42 %endif
43 BuildRequires:  libtool
44 BuildRequires:  pkgconfig >= 1:0.22
45 %{?with_vlc:BuildRequires:      vlc-devel >= 0.9}
46 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
47 Requires:       ecore >= %{ecore_ver}
48 Requires:       ecore-evas >= %{ecore_ver}
49 Requires:       ecore-fb >= %{ecore_ver}
50 Requires:       ecore-x >= %{ecore_ver}
51 Requires:       edje-libs >= %{edje_ver}
52 Requires:       eet >= %{eet_ver}
53 Requires:       eeze >= %{eeze_ver}
54 Requires:       eina >= %{eina_ver}
55 Requires:       eio >= %{eio_ver}
56 Requires:       evas >= %{evas_ver}
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Emotion is a library to easily integrate media playback into EFL
61 applications, it will take care of using Ecore's main loop and video
62 display is done using Evas.
63
64 %description -l pl.UTF-8
65 Emotion to biblioteka pozwalająca na łatwą integrację odtwarzania
66 multimediów w aplikacjach EFL. Współpracuje z główną pętlą Ecore, a do
67 wyświetlania wykorzystuje bibliotekę Evas.
68
69 %package devel
70 Summary:        Emotion header files
71 Summary(pl.UTF-8):      Pliki nagłówkowe Emotion
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       ecore-devel >= %{ecore_ver}
75 Requires:       eio-devel >= %{eio_ver}
76 Requires:       eet-devel >= %{eet_ver}
77 Requires:       eeze-devel >= %{eeze_ver}
78 Requires:       eina-devel >= %{eina_ver}
79 Requires:       evas-devel >= %{evas_ver}
80
81 %description devel
82 Header files for Emotion.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe Emotion.
86
87 %package static
88 Summary:        Static Emotion library
89 Summary(pl.UTF-8):      Statyczna biblioteka Emotion
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static Emotion library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka Emotion.
98
99 %package decoder-gstreamer
100 Summary:        Emotion decoder using gstreamer
101 Summary(pl.UTF-8):      Dekoder Emotion używający gstreamera
102 Group:          Development/Libraries
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       gstreamer >= 0.10.2
105 Requires:       gstreamer-plugins-base >= 0.10.34
106
107 %description decoder-gstreamer
108 Emotion decoder using gstreamer.
109
110 %description decoder-gstreamer -l pl.UTF-8
111 Dekoder Emotion używający gstreamera.
112
113 %package decoder-xine
114 Summary:        Emotion decoder using xine
115 Summary(pl.UTF-8):      Dekoder Emotion używający xine
116 Group:          Development/Libraries
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       xine-lib >= 2:1.1.1
119
120 %description decoder-xine
121 Emotion decoder using xine.
122
123 %description decoder-xine -l pl.UTF-8
124 Dekoder Emotion używający xine.
125
126 %package decoder-vlc
127 Summary:        Emotion decoder using vlc
128 Summary(pl.UTF-8):      Dekoder Emotion używający vlc
129 Group:          Development/Libraries
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       vlc >= 0.9
132
133 %description decoder-vlc
134 Emotion decoder using vlc and Emotion generic plugin.
135
136 %description decoder-vlc -l pl.UTF-8
137 Dekoder Emotion używający vlc i wtyczkę generic biblioteki Emotion.
138
139 %prep
140 %setup -q
141
142 %build
143 %{__libtoolize}
144 %{__aclocal} -I m4
145 %{__autoconf}
146 %{__autoheader}
147 %{__automake}
148 %configure \
149         --disable-silent-rules \
150         %{!?with_static_libs:--disable-static} \
151         %{!?with_vlc:--disable-generic-vlc} \
152         %{!?with_gstreamer:--disable-gstreamer} \
153         %{!?with_xine:--disable-xine}
154 %{__make}
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la \
163         $RPM_BUILD_ROOT%{_libdir}/edje/modules/emotion/linux-gnu-*/*.la
164
165 %if %{without vlc}
166 # dir not installed if vlc module not installed
167 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/utils
168 %endif
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %doc AUTHORS COPYING ChangeLog README TODO
179 %attr(755,root,root) %{_bindir}/emotion_test
180 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libemotion.so.1
182 %dir %{_libdir}/%{name}
183 %attr(755,root,root) %{_libdir}/%{name}/em_generic.so
184 %dir %{_libdir}/%{name}/utils
185 %dir %{_libdir}/edje/modules/emotion
186 %dir %{_libdir}/edje/modules/emotion/linux-gnu-*
187 %attr(755,root,root) %{_libdir}/edje/modules/emotion/linux-gnu-*/module.so
188 %{_datadir}/%{name}
189
190 %files devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libemotion.so
193 %{_libdir}/libemotion.la
194 %{_includedir}/emotion-1
195 %{_pkgconfigdir}/emotion.pc
196
197 %if %{with static_libs}
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/libemotion.a
201 %endif
202
203 %if %{with gstreamer}
204 %files decoder-gstreamer
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/%{name}/gstreamer.so
207 %endif
208
209 %if %{with xine}
210 %files decoder-xine
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/%{name}/xine.so
213 %endif
214
215 %if %{with vlc}
216 %files decoder-vlc
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/%{name}/utils/em_generic_vlc
219 %endif
This page took 0.092765 seconds and 3 git commands to generate.