]> git.pld-linux.org Git - packages/emotion.git/blob - emotion.spec
- updated to 0.0.1.005
[packages/emotion.git] / emotion.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # don't build gstreamer decoder
4 %bcond_without  xine            # don't build xine decoder
5 %bcond_without  static_libs     # don't build static library
6 #
7 %if !%{with gstreamer} && !%{with xine}
8 %error at last one backend must be enabled
9 %endif
10 #
11 Summary:        Enlightenment Fundation Libraries - Emotion
12 Summary(pl.UTF-8):      Podstawowe biblioteki Enlightenmenta - Emotion
13 Name:           emotion
14 Version:        0.0.1.005
15 Release:        1
16 License:        BSD
17 Group:          X11/Libraries
18 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
19 # Source0-md5:  e1550ff7a8f68b76b76a4d857073b3ee
20 URL:            http://enlightenment.org/p.php?p=about/libs/emotion
21 BuildRequires:  autoconf
22 BuildRequires:  automake >= 1.4
23 # ecore-evas ecore-job
24 BuildRequires:  ecore-devel >= 0.9.9
25 BuildRequires:  edje >= 0.5.0
26 BuildRequires:  edje-devel >= 0.5.0
27 BuildRequires:  evas-devel >= 0.9.9
28 %if %{with gstreamer}
29 BuildRequires:  gstreamer-devel >= 0.10.2
30 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.1
31 # gstreamer-cdio,gstreamer-ffmpeg for runtime, configure just warns if missing
32 %endif
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig
35 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
36 Requires:       ecore-evas >= 0.9.9
37 Requires:       ecore-job >= 0.9.9
38 Requires:       edje-libs >= 0.5.0
39 Requires:       evas >= 0.9.9
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Emotion is a Media Library.
44
45 %description -l pl.UTF-8
46 Emotion to biblioteka multimedialna.
47
48 %package devel
49 Summary:        Emotion header files
50 Summary(pl.UTF-8):      Pliki nagłówkowe Emotion
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 # ecore-evas ecore-job
54 Requires:       ecore-devel >= 0.9.9
55 Requires:       edje-devel >= 0.5.0
56 Requires:       evas-devel >= 0.9.9
57
58 %description devel
59 Header files for Emotion.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe Emotion.
63
64 %package static
65 Summary:        Static Emotion library
66 Summary(pl.UTF-8):      Statyczna biblioteka Emotion
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static Emotion library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka Emotion.
75
76 %package decoder-gstreamer
77 Summary:        Emotion decoder using gstreamer
78 Summary(pl.UTF-8):      Dekoder Emotion używający gstreamera
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       gstreamer >= 0.10.2
82 Requires:       gstreamer-plugins-base >= 0.10.1
83 Suggests:       gstreamer-cdio
84 Suggests:       gstreamer-ffmpeg
85
86 %description decoder-gstreamer
87 Emotion decoder using gstreamer.
88
89 %description decoder-gstreamer -l pl.UTF-8
90 Dekoder Emotion używający gstreamera.
91
92 %package decoder-xine
93 Summary:        Emotion decoder using xine
94 Summary(pl.UTF-8):      Dekoder Emotion używający xine
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       xine-lib >= 2:1.1.1
98
99 %description decoder-xine
100 Emotion decoder using xine.
101
102 %description decoder-xine -l pl.UTF-8
103 Dekoder Emotion używający xine.
104
105 %prep
106 %setup -q
107
108 %build
109 %{__libtoolize}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         %{!?with_static_libs:--disable-static} \
116         %{!?with_gstreamer:--disable-gstreamer} \
117         %{!?with_xine:--disable-xine}
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS COPYING COPYING-PLAIN README TODO
137 %attr(755,root,root) %{_bindir}/emotion_*
138 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
139 %dir %{_libdir}/%{name}
140 %{_datadir}/%{name}
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/emotion-config
145 %attr(755,root,root) %{_libdir}/libemotion.so
146 %{_libdir}/libemotion.la
147 %{_includedir}/Emotion.h
148 %{_pkgconfigdir}/emotion.pc
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libemotion.a
154 %endif
155
156 %if %{with gstreamer}
157 %files decoder-gstreamer
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_gstreamer.so
160 %endif
161
162 %if %{with xine}
163 %files decoder-xine
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_xine.so
166 %endif
This page took 0.114263 seconds and 3 git commands to generate.