]> git.pld-linux.org Git - packages/emotion.git/blob - emotion.spec
- release 2
[packages/emotion.git] / emotion.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # don't build gstreamer decoder
4 %bcond_without  vlc             # don't build vlc generic decoder
5 %bcond_without  xine            # don't build xine decoder
6 %bcond_without  static_libs     # don't build static library
7 #
8 %define         ecore_ver       1.0.0
9 %define         edje_ver        1.0.0
10 %define         eet_ver         1.4.0
11 %define         eeze_ver        1.1.0
12 %define         eina_ver        1.0.0
13 %define         evas_ver        1.0.0
14
15 Summary:        Emotion - EFL media playback library
16 Summary(pl.UTF-8):      Emotion - biblioteka EFL do odtwarzania multimediów
17 Name:           emotion
18 Version:        0.2.0.65643
19 Release:        2
20 License:        BSD-like
21 Group:          Libraries
22 Source0:        http://download.enlightenment.org/snapshots/LATEST/%{name}-%{version}.tar.bz2
23 # Source0-md5:  1c4fb7c26f4324f4fcc343d6baa21e42
24 Patch0:         %{name}-am.patch
25 URL:            http://trac.enlightenment.org/e/wiki/Emotion
26 BuildRequires:  autoconf >= 2.60
27 BuildRequires:  automake >= 1.6
28 BuildRequires:  ecore-devel >= %{ecore_ver}
29 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
30 BuildRequires:  ecore-fb-devel >= %{ecore_ver}
31 BuildRequires:  ecore-x-devel >= %{ecore_ver}
32 BuildRequires:  edje >= %{edje_ver}
33 BuildRequires:  edje-devel >= %{edje_ver}
34 BuildRequires:  eet-devel >= %{eet_ver}
35 BuildRequires:  eeze-devel >= %{eeze_ver}
36 BuildRequires:  eio-devel
37 BuildRequires:  eina-devel >= %{eina_ver}
38 BuildRequires:  evas-devel >= %{evas_ver}
39 %if %{with gstreamer}
40 BuildRequires:  gstreamer-devel >= 0.10.2
41 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.34
42 %endif
43 BuildRequires:  libtool
44 BuildRequires:  pkgconfig >= 1:0.22
45 BuildRequires:  sed >= 4.0
46 %{?with_vlc:BuildRequires:      vlc-devel >= 0.9}
47 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
48 Requires:       ecore >= %{ecore_ver}
49 Requires:       ecore-evas >= %{ecore_ver}
50 Requires:       ecore-fb >= %{ecore_ver}
51 Requires:       ecore-x >= %{ecore_ver}
52 Requires:       edje-libs >= %{edje_ver}
53 Requires:       eet >= %{eet_ver}
54 Requires:       eeze >= %{eeze_ver}
55 Requires:       eina >= %{eina_ver}
56 Requires:       evas >= %{evas_ver}
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Emotion is a library to easily integrate media playback into EFL
61 applications, it will take care of using Ecore's main loop and video
62 display is done using Evas.
63
64 %description -l pl.UTF-8
65 Emotion to biblioteka pozwalająca na łatwą integrację odtwarzania
66 multimediów w aplikacjach EFL. Współpracuje z główną pętlą Ecore, a do
67 wyświetlania wykorzystuje bibliotekę Evas.
68
69 %package devel
70 Summary:        Emotion header files
71 Summary(pl.UTF-8):      Pliki nagłówkowe Emotion
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       ecore-devel >= %{ecore_ver}
75 Requires:       eio-devel
76 Requires:       eet-devel >= %{eet_ver}
77 Requires:       eeze-devel >= %{eeze_ver}
78 Requires:       eina-devel >= %{eina_ver}
79 Requires:       evas-devel >= %{evas_ver}
80
81 %description devel
82 Header files for Emotion.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe Emotion.
86
87 %package static
88 Summary:        Static Emotion library
89 Summary(pl.UTF-8):      Statyczna biblioteka Emotion
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static Emotion library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka Emotion.
98
99 %package decoder-gstreamer
100 Summary:        Emotion decoder using gstreamer
101 Summary(pl.UTF-8):      Dekoder Emotion używający gstreamera
102 Group:          Development/Libraries
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       gstreamer >= 0.10.2
105 Requires:       gstreamer-plugins-base >= 0.10.34
106
107 %description decoder-gstreamer
108 Emotion decoder using gstreamer.
109
110 %description decoder-gstreamer -l pl.UTF-8
111 Dekoder Emotion używający gstreamera.
112
113 %package decoder-xine
114 Summary:        Emotion decoder using xine
115 Summary(pl.UTF-8):      Dekoder Emotion używający xine
116 Group:          Development/Libraries
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       xine-lib >= 2:1.1.1
119
120 %description decoder-xine
121 Emotion decoder using xine.
122
123 %description decoder-xine -l pl.UTF-8
124 Dekoder Emotion używający xine.
125
126 %package decoder-vlc
127 Summary:        Emotion decoder using vlc
128 Summary(pl.UTF-8):      Dekoder Emotion używający vlc
129 Group:          Development/Libraries
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       vlc >= 0.9
132
133 %description decoder-vlc
134 Emotion decoder using vlc and Emotion generic plugin.
135
136 %description decoder-vlc -l pl.UTF-8
137 Dekoder Emotion używający vlc i wtyczkę generic biblioteki Emotion.
138
139 %prep
140 %setup -q
141 %patch0 -p1
142
143 # fix version for tarball not being svn checkout
144 %{__sed} -i -e 's/^m4_define.*v_rev.*svnversion.*/m4_define([v_rev], [65643])/' configure.ac
145
146 %build
147 %{__libtoolize}
148 %{__aclocal} -I m4
149 %{__autoconf}
150 %{__autoheader}
151 %{__automake}
152 %configure \
153         --disable-silent-rules \
154         %{!?with_static_libs:--disable-static} \
155         %{!?with_vlc:--disable-generic-vlc} \
156         %{!?with_gstreamer:--disable-gstreamer} \
157         %{!?with_xine:--disable-xine}
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 %{__make} install \
164         DESTDIR=$RPM_BUILD_ROOT
165
166 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la \
167         $RPM_BUILD_ROOT%{_libdir}/edje/modules/emotion/linux-gnu-*/*.la
168
169 %if %{without vlc}
170 # dir not installed if vlc module not installed
171 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/utils
172 %endif
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 %doc AUTHORS COPYING COPYING-PLAIN ChangeLog README TODO
183 %attr(755,root,root) %{_bindir}/emotion_test
184 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libemotion.so.0
186 %dir %{_libdir}/%{name}
187 %attr(755,root,root) %{_libdir}/%{name}/em_generic.so
188 %dir %{_libdir}/%{name}/utils
189 %dir %{_libdir}/edje/modules/emotion
190 %dir %{_libdir}/edje/modules/emotion/linux-gnu-*
191 %attr(755,root,root) %{_libdir}/edje/modules/emotion/linux-gnu-*/module.so
192 %{_datadir}/%{name}
193
194 %files devel
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libemotion.so
197 %{_libdir}/libemotion.la
198 %{_includedir}/emotion-0
199 %{_pkgconfigdir}/emotion.pc
200
201 %if %{with static_libs}
202 %files static
203 %defattr(644,root,root,755)
204 %{_libdir}/libemotion.a
205 %endif
206
207 %if %{with gstreamer}
208 %files decoder-gstreamer
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/%{name}/gstreamer.so
211 %endif
212
213 %if %{with xine}
214 %files decoder-xine
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/%{name}/xine.so
217 %endif
218
219 %if %{with vlc}
220 %files decoder-vlc
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/%{name}/utils/em_generic_vlc
223 %endif
This page took 0.121208 seconds and 3 git commands to generate.