]> git.pld-linux.org Git - packages/emotion.git/blob - emotion.spec
- release 3 (by relup.sh)
[packages/emotion.git] / emotion.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # don't build gstreamer decoder
4 %bcond_without  vlc             # don't build vlc generic decoder
5 %bcond_without  xine            # don't build xine decoder
6 %bcond_without  static_libs     # don't build static library
7 #
8 %define         ecore_ver       1.7.7
9 %define         edje_ver        1.7.7
10 %define         eet_ver         1.7.7
11 %define         eeze_ver        1.7.7
12 %define         eina_ver        1.7.7
13 %define         eio_ver         1.7.7
14 %define         evas_ver        1.7.7
15
16 Summary:        Emotion - EFL media playback library
17 Summary(pl.UTF-8):      Emotion - biblioteka EFL do odtwarzania multimediów
18 Name:           emotion
19 Version:        1.7.7
20 Release:        3
21 License:        BSD-like
22 Group:          Libraries
23 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
24 # Source0-md5:  b2621c0663b6fdc1408d0387a4d60c4b
25 Patch0:         %{name}-am.patch
26 URL:            http://trac.enlightenment.org/e/wiki/Emotion
27 BuildRequires:  autoconf >= 2.60
28 BuildRequires:  automake >= 1.6
29 BuildRequires:  ecore-devel >= %{ecore_ver}
30 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
31 BuildRequires:  ecore-fb-devel >= %{ecore_ver}
32 BuildRequires:  ecore-x-devel >= %{ecore_ver}
33 BuildRequires:  edje >= %{edje_ver}
34 BuildRequires:  edje-devel >= %{edje_ver}
35 BuildRequires:  eet-devel >= %{eet_ver}
36 BuildRequires:  eeze-devel >= %{eeze_ver}
37 BuildRequires:  eio-devel >= %{eio_ver}
38 BuildRequires:  eina-devel >= %{eina_ver}
39 BuildRequires:  evas-devel >= %{evas_ver}
40 %if %{with gstreamer}
41 BuildRequires:  gstreamer0.10-devel >= 0.10.2
42 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10.34
43 %endif
44 BuildRequires:  libtool
45 BuildRequires:  pkgconfig >= 1:0.22
46 %{?with_vlc:BuildRequires:      vlc-devel >= 0.9}
47 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
48 Requires:       ecore >= %{ecore_ver}
49 Requires:       ecore-evas >= %{ecore_ver}
50 Requires:       ecore-fb >= %{ecore_ver}
51 Requires:       ecore-x >= %{ecore_ver}
52 Requires:       edje-libs >= %{edje_ver}
53 Requires:       eet >= %{eet_ver}
54 Requires:       eeze >= %{eeze_ver}
55 Requires:       eina >= %{eina_ver}
56 Requires:       eio >= %{eio_ver}
57 Requires:       evas >= %{evas_ver}
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 Emotion is a library to easily integrate media playback into EFL
62 applications, it will take care of using Ecore's main loop and video
63 display is done using Evas.
64
65 %description -l pl.UTF-8
66 Emotion to biblioteka pozwalająca na łatwą integrację odtwarzania
67 multimediów w aplikacjach EFL. Współpracuje z główną pętlą Ecore, a do
68 wyświetlania wykorzystuje bibliotekę Evas.
69
70 %package devel
71 Summary:        Emotion header files
72 Summary(pl.UTF-8):      Pliki nagłówkowe Emotion
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       ecore-devel >= %{ecore_ver}
76 Requires:       eio-devel >= %{eio_ver}
77 Requires:       eet-devel >= %{eet_ver}
78 Requires:       eeze-devel >= %{eeze_ver}
79 Requires:       eina-devel >= %{eina_ver}
80 Requires:       evas-devel >= %{evas_ver}
81
82 %description devel
83 Header files for Emotion.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe Emotion.
87
88 %package static
89 Summary:        Static Emotion library
90 Summary(pl.UTF-8):      Statyczna biblioteka Emotion
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Static Emotion library.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka Emotion.
99
100 %package decoder-gstreamer
101 Summary:        Emotion decoder using gstreamer
102 Summary(pl.UTF-8):      Dekoder Emotion używający gstreamera
103 Group:          Development/Libraries
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       gstreamer0.10 >= 0.10.2
106 Requires:       gstreamer0.10-plugins-base >= 0.10.34
107
108 %description decoder-gstreamer
109 Emotion decoder using gstreamer.
110
111 %description decoder-gstreamer -l pl.UTF-8
112 Dekoder Emotion używający gstreamera.
113
114 %package decoder-xine
115 Summary:        Emotion decoder using xine
116 Summary(pl.UTF-8):      Dekoder Emotion używający xine
117 Group:          Development/Libraries
118 Requires:       %{name} = %{version}-%{release}
119 Requires:       xine-lib >= 2:1.1.1
120
121 %description decoder-xine
122 Emotion decoder using xine.
123
124 %description decoder-xine -l pl.UTF-8
125 Dekoder Emotion używający xine.
126
127 %package decoder-vlc
128 Summary:        Emotion decoder using vlc
129 Summary(pl.UTF-8):      Dekoder Emotion używający vlc
130 Group:          Development/Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       vlc >= 0.9
133
134 %description decoder-vlc
135 Emotion decoder using vlc and Emotion generic plugin.
136
137 %description decoder-vlc -l pl.UTF-8
138 Dekoder Emotion używający vlc i wtyczkę generic biblioteki Emotion.
139
140 %prep
141 %setup -q
142 %patch0 -p1
143
144 %build
145 %{__libtoolize}
146 %{__aclocal} -I m4
147 %{__autoconf}
148 %{__autoheader}
149 %{__automake}
150 %configure \
151         --disable-silent-rules \
152         %{!?with_static_libs:--disable-static} \
153         %{!?with_vlc:--disable-generic-vlc} \
154         %{!?with_gstreamer:--disable-gstreamer} \
155         %{!?with_xine:--disable-xine}
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la \
165         $RPM_BUILD_ROOT%{_libdir}/edje/modules/emotion/linux-gnu-*/*.la
166
167 %if %{without vlc}
168 # dir not installed if vlc module not installed
169 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/utils
170 %endif
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files
179 %defattr(644,root,root,755)
180 %doc AUTHORS COPYING ChangeLog README TODO
181 %attr(755,root,root) %{_bindir}/emotion_test
182 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libemotion.so.1
184 %dir %{_libdir}/%{name}
185 %attr(755,root,root) %{_libdir}/%{name}/em_generic.so
186 %dir %{_libdir}/%{name}/utils
187 %dir %{_libdir}/edje/modules/emotion
188 %dir %{_libdir}/edje/modules/emotion/linux-gnu-*
189 %attr(755,root,root) %{_libdir}/edje/modules/emotion/linux-gnu-*/module.so
190 %{_datadir}/%{name}
191
192 %files devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libemotion.so
195 %{_libdir}/libemotion.la
196 %{_includedir}/emotion-1
197 %{_pkgconfigdir}/emotion.pc
198
199 %if %{with static_libs}
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/libemotion.a
203 %endif
204
205 %if %{with gstreamer}
206 %files decoder-gstreamer
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/%{name}/gstreamer.so
209 %endif
210
211 %if %{with xine}
212 %files decoder-xine
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/%{name}/xine.so
215 %endif
216
217 %if %{with vlc}
218 %files decoder-vlc
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/%{name}/utils/em_generic_vlc
221 %endif
This page took 0.084157 seconds and 3 git commands to generate.