]> git.pld-linux.org Git - packages/emotion.git/blob - emotion.spec
- ghost soname symlink
[packages/emotion.git] / emotion.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # don't build gstreamer decoder
4 %bcond_without  xine            # don't build xine decoder
5 %bcond_without  static_libs     # don't build static library
6 #
7 %if !%{with gstreamer} && !%{with xine}
8 %error at last one backend must be enabled
9 %endif
10 #
11 %define         ecore_ver       0.9.9.043
12 %define         edje_ver        0.9.9.043
13 %define         evas_ver        0.9.9.043
14
15 Summary:        Enlightenment Fundation Libraries - Emotion
16 Summary(pl.UTF-8):      Podstawowe biblioteki Enlightenmenta - Emotion
17 Name:           emotion
18 Version:        0.1.0.042
19 Release:        1
20 License:        BSD
21 Group:          X11/Libraries
22 Source0:        http://download.enlightenment.org/snapshots/2008-01-25/%{name}-%{version}.tar.bz2
23 # Source0-md5:  123c043d02f4da22fb36eede930a44e5
24 URL:            http://enlightenment.org/p.php?p=about/libs/emotion
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake >= 1.6
27 # ecore-evas ecore-job
28 BuildRequires:  ecore-devel >= %{ecore_ver}
29 BuildRequires:  edje >= %{edje_ver}
30 BuildRequires:  edje-devel >= %{edje_ver}
31 BuildRequires:  evas-devel >= %{evas_ver}
32 %if %{with gstreamer}
33 BuildRequires:  gstreamer-devel >= 0.10.2
34 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.1
35 # gstreamer-cdio,gstreamer-ffmpeg for runtime, configure just warns if missing
36 %endif
37 BuildRequires:  libtool
38 BuildRequires:  pkgconfig
39 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
40 Requires:       ecore-evas >= %{ecore_ver}
41 Requires:       ecore-job >= %{ecore_ver}
42 Requires:       edje-libs >= %{edje_ver}
43 Requires:       evas >= %{evas_ver}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Emotion is a Media Library.
48
49 %description -l pl.UTF-8
50 Emotion to biblioteka multimedialna.
51
52 %package devel
53 Summary:        Emotion header files
54 Summary(pl.UTF-8):      Pliki nagłówkowe Emotion
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 # ecore-evas ecore-job
58 Requires:       ecore-devel >= %{ecore_ver}
59 Requires:       edje-devel >= %{edje_ver}
60 Requires:       evas-devel >= %{evas_ver}
61
62 %description devel
63 Header files for Emotion.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe Emotion.
67
68 %package static
69 Summary:        Static Emotion library
70 Summary(pl.UTF-8):      Statyczna biblioteka Emotion
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Emotion library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka Emotion.
79
80 %package decoder-gstreamer
81 Summary:        Emotion decoder using gstreamer
82 Summary(pl.UTF-8):      Dekoder Emotion używający gstreamera
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       gstreamer >= 0.10.2
86 Requires:       gstreamer-plugins-base >= 0.10.1
87 Suggests:       gstreamer-cdio
88 Suggests:       gstreamer-ffmpeg
89
90 %description decoder-gstreamer
91 Emotion decoder using gstreamer.
92
93 %description decoder-gstreamer -l pl.UTF-8
94 Dekoder Emotion używający gstreamera.
95
96 %package decoder-xine
97 Summary:        Emotion decoder using xine
98 Summary(pl.UTF-8):      Dekoder Emotion używający xine
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       xine-lib >= 2:1.1.1
102
103 %description decoder-xine
104 Emotion decoder using xine.
105
106 %description decoder-xine -l pl.UTF-8
107 Dekoder Emotion używający xine.
108
109 %prep
110 %setup -q
111
112 %build
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         %{!?with_static_libs:--disable-static} \
120         %{!?with_gstreamer:--disable-gstreamer} \
121         %{!?with_xine:--disable-xine}
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS COPYING COPYING-PLAIN README TODO
141 %attr(755,root,root) %{_bindir}/emotion_*
142 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libemotion.so.0
144 %dir %{_libdir}/%{name}
145 %{_datadir}/%{name}
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libemotion.so
150 %{_libdir}/libemotion.la
151 %{_includedir}/Emotion.h
152 %{_pkgconfigdir}/emotion.pc
153
154 %if %{with static_libs}
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libemotion.a
158 %endif
159
160 %if %{with gstreamer}
161 %files decoder-gstreamer
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/%{name}/gstreamer.so
164 %endif
165
166 %if %{with xine}
167 %files decoder-xine
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/%{name}/xine.so
170 %endif
This page took 0.181402 seconds and 3 git commands to generate.