]> git.pld-linux.org Git - packages/emby-server.git/blob - emby-server.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/emby-server.git] / emby-server.spec
1 # TODO
2 # - emby user
3 Summary:        Emby: home media server
4 Name:           emby-server
5 Version:        3.0.5607.2
6 Release:        0.1
7 License:        GPL
8 Group:          Applications/Multimedia
9 Source0:        https://github.com/MediaBrowser/MediaBrowser/archive/%{version}.tar.gz
10 # Source0-md5:  84f0e9a3ee083622562cae203583a65b
11 URL:            http://emby.media/
12 BuildRequires:  mono >= 3.2.7
13 BuildRequires:  rpmbuild(macros) >= 1.268
14 BuildRequires:  rpmbuild(monoautodeps)
15 Requires:       ImageMagick >= 6.8
16 Requires:       libmediainfo
17 Requires:       mono >= 3.2.7
18 Requires:       sqlite3 >= 3.8.2
19 Obsoletes:      MediaBrowserServer
20 Obsoletes:      MediaBrowserServer-dev
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _appdir %{_prefix}/lib/%{name}
25
26 %description
27 Emby (formely known as Media Browser) is a home media server built on
28 top of other popular open source technologies such as Service Stack,
29 jQuery, jQuery mobile, and Mono. It features a REST-based api with
30 built-in documention to facilitate client development. We also have
31 client libraries for our API to enable rapid development.
32
33 %prep
34 %setup -qc
35 mv MediaBrowser-%{version} src
36 install -d bin
37
38 %build
39 cd src
40 xbuild /p:Configuration="Release Mono" /p:Platform="Any CPU" /t:clean MediaBrowser.Mono.sln
41 xbuild /p:Configuration="Release Mono" /p:Platform="Any CPU" /t:build MediaBrowser.Mono.sln
42
43 mv MediaBrowser.Server.Mono/bin/Release\ Mono/* ../bin
44 cd ..
45
46 rm -v bin/lib*.dylib
47 rm -v bin/MediaInfo/osx/lib*.dylib
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_appdir}
52 cp -a bin/* $RPM_BUILD_ROOT%{_appdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %dir %{_appdir}
60 %{_appdir}/BDInfo.dll
61 %{_appdir}/DvdLib.dll
62 %{_appdir}/Emby.Drawing.dll
63 %{_appdir}/Emby.Drawing.dll.mdb
64 %{_appdir}/ImageMagickSharp.dll
65 %{_appdir}/ImageMagickSharp.dll.config
66 %{_appdir}/Interfaces.IO.dll
67 %{_appdir}/MediaBrowser.Api.dll
68 %{_appdir}/MediaBrowser.Common.Implementations.dll
69 %{_appdir}/MediaBrowser.Common.dll
70 %{_appdir}/MediaBrowser.Controller.dll
71 %{_appdir}/MediaBrowser.Dlna.dll
72 %{_appdir}/MediaBrowser.IsoMounting.Linux.dll
73 %{_appdir}/MediaBrowser.LocalMetadata.dll
74 %{_appdir}/MediaBrowser.MediaEncoding.dll
75 %{_appdir}/MediaBrowser.MediaInfo.dll
76 %{_appdir}/MediaBrowser.MediaInfo.dll.config
77 %{_appdir}/MediaBrowser.Model.dll
78 %{_appdir}/MediaBrowser.Model.dll.mdb
79 %{_appdir}/MediaBrowser.Naming.dll
80 %{_appdir}/MediaBrowser.Providers.dll
81 %{_appdir}/MediaBrowser.Server.Implementations.dll
82 %{_appdir}/MediaBrowser.Server.Mono.exe
83 %{_appdir}/MediaBrowser.Server.Mono.exe.config
84 %{_appdir}/MediaBrowser.Server.Startup.Common.dll
85 %{_appdir}/MediaBrowser.WebDashboard.dll
86 %{_appdir}/MediaBrowser.XbmcMetadata.dll
87 %{_appdir}/Mono.Nat.dll
88 %{_appdir}/Mono.Posix.dll
89 %{_appdir}/MoreLinq.dll
90 %{_appdir}/NLog.dll
91 %{_appdir}/OpenSubtitlesHandler.dll
92 %{_appdir}/Patterns.Logging.dll
93 %{_appdir}/ServiceStack.Api.Swagger.dll
94 %{_appdir}/ServiceStack.Client.dll
95 %{_appdir}/ServiceStack.Common.dll
96 %{_appdir}/ServiceStack.Interfaces.dll
97 %{_appdir}/ServiceStack.Text.dll
98 %{_appdir}/ServiceStack.dll
99 %{_appdir}/SharpCompress.dll
100 %{_appdir}/SimpleInjector.dll
101 %{_appdir}/SocketHttpListener.dll
102 %{_appdir}/System.Data.SQLite.dll
103 %{_appdir}/System.Data.SQLite.dll.config
104 %{_appdir}/UniversalDetector.dll
105 %{_appdir}/WebMarkupMin.Core.dll
106 %{_appdir}/taglib-sharp.dll
107
108 %{_appdir}/dashboard-ui
109 %{_appdir}/swagger-ui
This page took 0.121738 seconds and 4 git commands to generate.