]> git.pld-linux.org Git - packages/embryo.git/blob - embryo.spec
- updated to 1.0.0.beta3
[packages/embryo.git] / embryo.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Enlightenment Fundation Libraries - Embryo
6 Summary(pl.UTF-8):      Podstawowe biblioteki Enlightenmenta - Embryo
7 Name:           embryo
8 %define subver  beta3
9 Version:        1.0.0
10 Release:        0.%{subver}.1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
14 # Source0-md5:  20495de8cc2c375cde1a3a98caf919d7
15 URL:            http://enlightenment.org/p.php?p=about/libs/embryo
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1.6
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig >= 1:0.22
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %undefine       __cxx
23
24 %description
25 Embryo is a tiny library designed as a virtual machine to interpret a
26 limited set of small compiled programs.
27
28 %description -l pl.UTF-8
29 Embryo to mała biblioteka zaprojektowana jako maszyna wirtualna do
30 interpretowania ograniczonego zbioru małych skompilowanych programów.
31
32 %package devel
33 Summary:        Embryo header files
34 Summary(pl.UTF-8):      Pliki nagłówkowe Embryo
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for Embryo.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe Embryo.
43
44 %package static
45 Summary:        Static Embryo library
46 Summary(pl.UTF-8):      Statyczna biblioteka Embryo
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static Embryo library.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka Embryo.
55
56 %prep
57 %setup -q -n %{name}-%{version}.%{subver}
58
59 %build
60 %{__libtoolize}
61 %{__aclocal} -I m4
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         --disable-silent-rules \
67         %{!?with_static_libs:--disable-static}
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS COPYING README
85 %attr(755,root,root) %{_bindir}/embryo_cc
86 %attr(755,root,root) %{_libdir}/libembryo.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libembryo.so.1
88 # for embryo_cc
89 %{_datadir}/%{name}
90
91 %files devel
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_libdir}/libembryo.so
94 %{_libdir}/libembryo.la
95 %{_includedir}/embryo-1
96 %{_pkgconfigdir}/embryo.pc
97
98 %if %{with static_libs}
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libembryo.a
102 %endif
This page took 0.072556 seconds and 3 git commands to generate.