]> git.pld-linux.org Git - packages/embryo.git/blob - embryo.spec
- x32 rebuild
[packages/embryo.git] / embryo.spec
1 # NOTE: for versions >= 1.8 see efl.spec
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define eina_ver        1.7.10
7 Summary:        Enlightenment Fundation Libraries - Embryo
8 Summary(pl.UTF-8):      Podstawowe biblioteki Enlightenmenta - Embryo
9 Name:           embryo
10 Version:        1.7.10
11 Release:        2
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
15 # Source0-md5:  1ed477bcc75124a143b4d86bea02c671
16 URL:            http://trac.enlightenment.org/e/wiki/Embryo
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  eina-devel >= %{eina_ver}
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig >= 1:0.22
22 Requires:       eina >= %{eina_ver}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %undefine       __cxx
26
27 %description
28 Embryo is a tiny library designed as a virtual machine to interpret a
29 limited set of small compiled programs.
30
31 %description -l pl.UTF-8
32 Embryo to mała biblioteka zaprojektowana jako maszyna wirtualna do
33 interpretowania ograniczonego zbioru małych skompilowanych programów.
34
35 %package devel
36 Summary:        Embryo header files
37 Summary(pl.UTF-8):      Pliki nagłówkowe Embryo
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       eina-devel >= %{eina_ver}
41
42 %description devel
43 Header files for Embryo.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe Embryo.
47
48 %package static
49 Summary:        Static Embryo library
50 Summary(pl.UTF-8):      Statyczna biblioteka Embryo
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static Embryo library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka Embryo.
59
60 %prep
61 %setup -q
62
63 %build
64 %{__libtoolize}
65 %{__aclocal} -I m4
66 %{__autoconf}
67 %{__autoheader}
68 %{__automake}
69 %configure \
70         --disable-silent-rules \
71         %{!?with_static_libs:--disable-static}
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS COPYING ChangeLog NEWS README
89 %attr(755,root,root) %{_bindir}/embryo_cc
90 %attr(755,root,root) %{_libdir}/libembryo.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libembryo.so.1
92 # for embryo_cc
93 %{_datadir}/%{name}
94
95 %files devel
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/libembryo.so
98 %{_libdir}/libembryo.la
99 %{_includedir}/embryo-1
100 %{_pkgconfigdir}/embryo.pc
101
102 %if %{with static_libs}
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/libembryo.a
106 %endif
This page took 0.093664 seconds and 3 git commands to generate.