]> git.pld-linux.org Git - packages/emacsen-ecb-pkg.git/blob - emacsen-ecb-pkg.spec
a37edb0fe11cae572a55cb33ad5fd1b148773d15
[packages/emacsen-ecb-pkg.git] / emacsen-ecb-pkg.spec
1 # TODO: build for xemacs
2 #
3 # Conditional build:
4 %bcond_with     xemacs  # Build without XEmacs support
5 %bcond_without  emacs   # Build without GNU Emacs support
6 #
7 %define         _the_name ecb
8 Summary:        Emacs Code Browser IDE
9 Summary(pl.UTF-8):      Środowisko programistyczne dla Emacsa
10 Name:           emacsen-%{_the_name}-pkg
11 Version:        2.26
12 Release:        0.1
13 License:        GPL
14 Group:          Applications/Editors/Emacs
15 Source0:        http://dl.sourceforge.net/ecb/%{_the_name}-%{version}.tar.gz
16 # Source0-md5:  89bea4c856b96a943e83f14ef650e753
17 URL:            http://ecb.sourceforge.net/
18 BuildRequires:  emacsen-cedet-pkg
19 %if %{with emacs}
20 BuildRequires:  emacs
21 %endif
22 %if %{with xemacs}
23 BuildRequires:  xemacs
24 %endif
25 Requires:       cedet-elisp-code = %{version}-%{release}
26 Conflicts:      xemacs-cedet-pkg
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ECB is a global minor-mode which offers a couple of ECB-windows for
32 browsing your sources comfortable with the mouse and the keyboard.
33
34 This package contains files common to both GNU Emacs and XEmacs.
35
36 %description -l pl.UTF-8
37 ECB jest globalnym minor mode wyświetlającym kilka własnych okienek
38 ułatwiających przeglądanie kodu myszą i klawiaturą.
39
40 Ten pakiet zawiera pliki wspólne dla GNU Emacsa i XEmacsa.
41
42 %define version_of() %{expand:%%(rpm -q %1 --queryformat '%%%%{version}-%%%%{release}')}
43
44 %package emacs
45 Summary:        ECB compiled elisp files for GNU Emacs
46 Summary(pl.UTF-8):      Skompilowany kod elisp ECB dla GNU Emacsa
47 Group:          Applications/Editors/Emacs
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       emacs = %{version_of emacs}
50 Provides:       cedet-elisp-code = %{version}-%{release}
51
52 %description emacs
53 This package contains compiled elisp files needed to run ECB on GNU Emacs
54
55 %description emacs -l pl.UTF-8
56 Pakiet zawiera skompilowane pliki elisp z kodem ECB dla GNU Emacsa.
57
58 %package emacs-el
59 Summary:        ECB elisp files for GNU Emacs
60 Summary(pl.UTF-8):      Kod elisp ECB dla GNU Emacsa
61 Group:          Applications/Editors/Emacs
62 Requires:       %{name}-emacs = %{version}-%{release}
63
64 %description emacs-el
65 This package contains ECB source elisp files for GNU Emacs
66
67 %description emacs-el -l pl.UTF-8
68 Pakiet zawiera źródłowe pliki elisp z kodem ECB dla GNU Emacsa.
69
70 %package xemacs
71 Summary:        ECB elisp files for XEmacs
72 Summary(pl.UTF-8):      Kod elisp ECB dla XEmacsa
73 Group:          Applications/Editors/Emacs
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       xemacs = %{version_of xemacs}
76 Provides:       cedet-elisp-code = %{version}-%{release}
77
78 %description xemacs
79 This package contains compiled elisp files needed to run ECB on XEmacs
80
81 %description xemacs -l pl.UTF-8
82 Pakiet zawiera skompilowane pliki elisp z kodem ECB dla XEmacsa.
83
84 %package xemacs-el
85 Summary:        ECB elisp source files for XEmacs
86 Summary(pl.UTF-8):      Kod źródłowy elisp ECB dla XEmacsa
87 Group:          Applications/Editors/Emacs
88 Requires:       %{name}-xemacs = %{version}-%{release}
89
90 %description xemacs-el
91 This package contains source ECB elisp files for XEmacs
92
93 %description xemacs-el -l pl.UTF-8
94 Pakiet zawiera pliki źródłowe elisp z kodem ECB dla XEmacsa.
95
96 %prep
97 %setup -q -n %{_the_name}-%{version}
98
99 %build
100 %if %{with xemacs}
101 mkdir _xemacs
102 %endif
103
104 %if %{with emacs}
105 mkdir _emacs
106 cp -a [!_]* _emacs
107 %{__make} -C _emacs \
108         EMACS=emacs \
109         CEDET=%{_datadir}/emacs/cedet
110 %endif
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{_infodir}
115
116 %if %{with xemacs}
117 %endif
118
119 %if %{with emacs}
120 install -d $RPM_BUILD_ROOT%{_emacs_lispdir}
121 install _emacs/*.{el,elc} $RPM_BUILD_ROOT%{_emacs_lispdir}
122 rm _emacs/ecb-images/klaus.sh
123 cp -a _emacs/ecb-images $RPM_BUILD_ROOT%{_emacs_lispdir}
124 %endif
125
126 install info-help/* $RPM_BUILD_ROOT%{_infodir}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %doc NEWS README RELEASE_NOTES html-help
134 %{_infodir}/*.info*
135
136 %if %{with emacs}
137 %files emacs
138 %defattr(644,root,root,755)
139 %{_emacs_lispdir}/*.elc
140 %{_emacs_lispdir}/ecb-images
141 %{_emacs_lispdir}/ecb-autoloads.el
142
143 %files emacs-el
144 %defattr(644,root,root,755)
145 # All except ecb-autoloads.el
146 %{_emacs_lispdir}/[!e]*.el
147 %{_emacs_lispdir}/ecb-[!a]*.el
148 %{_emacs_lispdir}/ecb-autogen.el
149 %endif
150
151 %if %{with xemacs}
152 %files xemacs
153 %defattr(644,root,root,755)
154 %dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
155 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
156 %{_datadir}/xemacs-packages/etc/%{_the_name}
157
158 %files xemacs-el
159 %defattr(644,root,root,755)
160 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
161 %endif
This page took 0.144617 seconds and 2 git commands to generate.