]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- release ...4
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2
3 # Conditional build:
4 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
5 %bcond_with     lzma            # Enable lzma support
6 %bcond_with     python          # Enable Python scripting support
7 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
8 %bcond_with     smb             # Enable smb protocol support (smb requires libsmbclient)
9 #The latest libsmbclient is GPLv3, while ELinks is GPL v2 only.
10 %bcond_with     verbose         # verbose build (V=1)
11 %bcond_with     x               # Use the X Windows System
12 %bcond_without  256             # Disable 256 colors support
13 %bcond_without  bittorrent      # Disable BitTorrent support
14 %bcond_without  cgi             # Disable Local CGI support
15 %bcond_without  fsp             # Disable FSP support
16 %bcond_without  guile           # Disable Guile scripting
17 %bcond_without  idn             # Disable Internation Domain Names support
18 %bcond_without  ipv6            # Disable IPv6 support
19 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
20 %bcond_without  led             # Disable LEDs
21 %bcond_without  lua             # Disable Lua scripting
22 %bcond_without  openssl         # Disable OpenSSL support
23 %bcond_without  perl            # Disable Perl scripting
24
25 %if %{with gnutls}
26 %undefine       with_openssl
27 %endif
28 #
29 %define         pre     pre5
30 Summary:        Experimantal Links (text WWW browser)
31 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
32 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
33 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
34 Name:           elinks
35 Version:        0.12
36 Release:        0.%{pre}.4
37 Epoch:          1
38 License:        GPL v2
39 Group:          Applications/Networking
40 Source0:        http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
41 # Source0-md5:  92790144290131ac5e63b44548b45e08
42 Source1:        %{name}.desktop
43 Source2:        links.png
44 Patch0:         %{name}-home_etc.patch
45 Patch1:         %{name}-lua40.patch
46 Patch2:         %{name}-date-format.patch
47 Patch3:         %{name}-old_incremental.patch
48 Patch4:         %{name}-fbterm.patch
49 URL:            http://www.elinks.cz/
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  bzip2-devel
53 BuildRequires:  expat-devel
54 %{?with_fsp:BuildRequires:      fsplib-devel}
55 BuildRequires:  gettext-devel
56 BuildRequires:  gpm-devel
57 %{?with_guile:BuildRequires: guile-devel}
58 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
59 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
60 %{?with_idn:BuildRequires:      libidn-devel}
61 %{?with_smb:BuildRequires:      libsmbclient-devel}
62 %{?with_lua:BuildRequires:      lua50-devel}
63 %{?with_lzma:BuildRequires:     lzma-devel}
64 BuildRequires:  ncurses-devel >= 5.1
65 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
66 %{?with_perl:BuildRequires:     perl-devel}
67 BuildRequires:  pkgconfig
68 %{?with_python:BuildRequires:   python-devel}
69 %{?with_ruby:BuildRequires:     ruby-devel}
70 BuildRequires:  tre-devel
71 BuildRequires:  which
72 BuildRequires:  zlib-devel
73 Suggests:       mailcap
74 Provides:       webclient
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _sysconfdir     /etc/elinks
78 %define         specflags_ia32  -fomit-frame-pointer 
79
80 %description
81 This is the elinks tree - intended to provide feature-rich version of
82 links, however not rock-stable and dedicated mainly for testing. Its
83 purpose is to make alternative to links, until Mikulas will have some
84 time to maintain it, and to test and tune various patches for Mikulas
85 to be able to include them in the official links releases.
86
87 %description -l es.UTF-8
88 Links es un browser WWW modo texto, similar al Lynx. El links muestra
89 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
90 keepalive.
91
92 %description -l pl.UTF-8
93 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
94 elinks jednak jest dedykowana głównie do testowania.
95
96 %description -l pt_BR.UTF-8
97 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
98 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
99 keepalive.
100
101 %prep
102 %setup -q -n %{name}-%{version}%{pre}
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 # restores old behaviour of type-ahead search
107 #%patch3 -p1
108 %patch4 -p1
109
110 %build
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %configure \
115         %{?with_smb:--enable-smb} \
116         --disable-no-root \
117         %{!?debug:--enable-fastmem} \
118         %{?debug:--enable-debug} \
119         %{!?with_ipv6:--disable-ipv6} \
120         %{?with_bittorrent:--enable-bittorrent} \
121         %{?with_cgi:--enable-cgi} \
122         --enable-finger \
123         --enable-gopher \
124         --enable-nntp \
125         %{?with_256:--enable-256-colors} \
126         --enable-exmode \
127         %{?with_fsp:--enable-fsp} \
128         %{?with_leds:--enable-leds} \
129         --enable-marks \
130         --enable-html-highlight \
131         %{!?with_idn:--without-idn} \
132         %{?with_guile:--with-guile} \
133         %{?with_perl:--with-perl} \
134         %{!?with_lua:--without-lua} \
135         %{?with_python:--with-python} \
136         %{?with_ruby:--with-ruby} \
137         %{!?with_js:--without-spidermonkey} \
138         %{?with_gnutls:--with-gnutls} \
139         %{!?with_openssl:--without-openssl} \
140         --with%{!?with_x:out}-x \
141         %{!?with_lzma:--without-lzma}
142 # xterm -e is default, one might want to change it to
143 # something else
144 #       --with-xterm="xterm -e"
145
146 %{__make} %{?with_verbose:V=1}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT%{_desktopdir} \
151         $RPM_BUILD_ROOT%{_datadir}/%{name} \
152         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
153
154 %{__make} install %{?with_verbose:V=1} \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
158 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
159
160 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
161
162 %find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %files -f %{name}.lang
168 %defattr(644,root,root,755)
169 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
170 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
171 %doc contrib/conv/{*awk,*.pl,*.sh}
172 %doc doc/html/*.html
173 %attr(755,root,root) %{_bindir}/*
174 %{_mandir}/man*/*
175 %{_desktopdir}/*.desktop
176 %{_pixmapsdir}/*
177 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.046087 seconds and 3 git commands to generate.