]> git.pld-linux.org Git - packages/elinks.git/blame - elinks.spec
- release ...4
[packages/elinks.git] / elinks.spec
CommitLineData
2e552f3e 1# TODO: consider lua51
fb650491 2
21bf3c6a 3# Conditional build:
b67326b7 4%bcond_with gnutls # Enable GNUTLS SSL support (disables openssl)
505355c8 5%bcond_with lzma # Enable lzma support
507bef3e 6%bcond_with python # Enable Python scripting support
b67326b7 7%bcond_with ruby # Enable (experimental) Ruby scripting support
d8169248 8%bcond_with smb # Enable smb protocol support (smb requires libsmbclient)
9#The latest libsmbclient is GPLv3, while ELinks is GPL v2 only.
247545b3 10%bcond_with verbose # verbose build (V=1)
9cd7feaf 11%bcond_with x # Use the X Windows System
b67326b7
JB
12%bcond_without 256 # Disable 256 colors support
13%bcond_without bittorrent # Disable BitTorrent support
14%bcond_without cgi # Disable Local CGI support
b631af97 15%bcond_without fsp # Disable FSP support
b67326b7
JB
16%bcond_without guile # Disable Guile scripting
17%bcond_without idn # Disable Internation Domain Names support
18%bcond_without ipv6 # Disable IPv6 support
19%bcond_without js # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
20%bcond_without led # Disable LEDs
21%bcond_without lua # Disable Lua scripting
22%bcond_without openssl # Disable OpenSSL support
23%bcond_without perl # Disable Perl scripting
3d4d38d9
AG
24#
25%if %{with gnutls}
26%undefine with_openssl
27%endif
21bf3c6a 28#
41425071 29%define pre pre5
17631700 30Summary: Experimantal Links (text WWW browser)
f85cbf5d
ER
31Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
32Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
33Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
17631700 34Name: elinks
80cd88a3 35Version: 0.12
154c9231 36Release: 0.%{pre}.4
e2affc83 37Epoch: 1
d8169248 38License: GPL v2
17631700 39Group: Applications/Networking
80cd88a3 40Source0: http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
41425071 41# Source0-md5: 92790144290131ac5e63b44548b45e08
17631700 42Source1: %{name}.desktop
5a8f1bd1 43Source2: links.png
ef0f233a
AG
44Patch0: %{name}-home_etc.patch
45Patch1: %{name}-lua40.patch
505355c8 46Patch2: %{name}-date-format.patch
9cd7feaf 47Patch3: %{name}-old_incremental.patch
42ac557b 48Patch4: %{name}-fbterm.patch
8ca357a6 49URL: http://www.elinks.cz/
17631700
AM
50BuildRequires: autoconf
51BuildRequires: automake
5a8f1bd1 52BuildRequires: bzip2-devel
fcffdc5b 53BuildRequires: expat-devel
b631af97 54%{?with_fsp:BuildRequires: fsplib-devel}
ab99996e 55BuildRequires: gettext-devel
17631700 56BuildRequires: gpm-devel
3d4d38d9 57%{?with_guile:BuildRequires: guile-devel}
69d969c4 58%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
3d4d38d9
AG
59%{?with_js:BuildRequires: js-devel >= 1.5-0.rc6a.1}
60%{?with_idn:BuildRequires: libidn-devel}
505355c8 61%{?with_smb:BuildRequires: libsmbclient-devel}
8eb57a4f 62%{?with_lua:BuildRequires: lua50-devel}
505355c8 63%{?with_lzma:BuildRequires: lzma-devel}
1c33e430 64BuildRequires: ncurses-devel >= 5.1
3d4d38d9
AG
65%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
66%{?with_perl:BuildRequires: perl-devel}
f28e64c7 67BuildRequires: pkgconfig
9659fcbf 68%{?with_python:BuildRequires: python-devel}
8ca357a6 69%{?with_ruby:BuildRequires: ruby-devel}
42ac557b 70BuildRequires: tre-devel
f28e64c7 71BuildRequires: which
5a8f1bd1 72BuildRequires: zlib-devel
e1bc1545 73Suggests: mailcap
17631700
AM
74Provides: webclient
75BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
c4be24e9 77%define _sysconfdir /etc/elinks
ef0f233a 78%define specflags_ia32 -fomit-frame-pointer
4fc089e9 79
17631700 80%description
cd6ad879
JB
81This is the elinks tree - intended to provide feature-rich version of
82links, however not rock-stable and dedicated mainly for testing. Its
83purpose is to make alternative to links, until Mikulas will have some
84time to maintain it, and to test and tune various patches for Mikulas
85to be able to include them in the official links releases.
17631700 86
3328f371 87%description -l es.UTF-8
c15f1e53 88Links es un browser WWW modo texto, similar al Lynx. El links muestra
89tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
90keepalive.
91
3328f371
JR
92%description -l pl.UTF-8
93Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
94elinks jednak jest dedykowana głównie do testowania.
17631700 95
3328f371
JR
96%description -l pt_BR.UTF-8
97Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
98tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
c15f1e53 99keepalive.
100
17631700 101%prep
80cd88a3 102%setup -q -n %{name}-%{version}%{pre}
fb650491 103%patch0 -p1
1fa8ef0a 104%patch1 -p1
fb650491 105%patch2 -p1
9cd7feaf
TP
106# restores old behaviour of type-ahead search
107#%patch3 -p1
42ac557b 108%patch4 -p1
0b57a582 109
17631700 110%build
663b78ce 111%{__aclocal}
285e9f62 112%{__autoconf}
115d3038 113%{__autoheader}
ad628403 114%configure \
505355c8 115 %{?with_smb:--enable-smb} \
2e552f3e 116 --disable-no-root \
3d4d38d9
AG
117 %{!?debug:--enable-fastmem} \
118 %{?debug:--enable-debug} \
cc7f804f 119 %{!?with_ipv6:--disable-ipv6} \
8ca357a6 120 %{?with_bittorrent:--enable-bittorrent} \
3d4d38d9
AG
121 %{?with_cgi:--enable-cgi} \
122 --enable-finger \
123 --enable-gopher \
124 --enable-nntp \
125 %{?with_256:--enable-256-colors} \
126 --enable-exmode \
b631af97 127 %{?with_fsp:--enable-fsp} \
3d4d38d9 128 %{?with_leds:--enable-leds} \
8ca357a6 129 --enable-marks \
3d4d38d9 130 --enable-html-highlight \
3d4d38d9
AG
131 %{!?with_idn:--without-idn} \
132 %{?with_guile:--with-guile} \
133 %{?with_perl:--with-perl} \
62c5be6a 134 %{!?with_lua:--without-lua} \
507bef3e 135 %{?with_python:--with-python} \
8ca357a6 136 %{?with_ruby:--with-ruby} \
3d4d38d9
AG
137 %{!?with_js:--without-spidermonkey} \
138 %{?with_gnutls:--with-gnutls} \
139 %{!?with_openssl:--without-openssl} \
505355c8 140 --with%{!?with_x:out}-x \
141 %{!?with_lzma:--without-lzma}
82dd9b93
AG
142# xterm -e is default, one might want to change it to
143# something else
144# --with-xterm="xterm -e"
3d4d38d9 145
247545b3 146%{__make} %{?with_verbose:V=1}
17631700
AM
147
148%install
149rm -rf $RPM_BUILD_ROOT
1568d5eb 150install -d $RPM_BUILD_ROOT%{_desktopdir} \
ad628403 151 $RPM_BUILD_ROOT%{_datadir}/%{name} \
c4be24e9 152 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
17631700 153
247545b3 154%{__make} install %{?with_verbose:V=1} \
834d1634 155 DESTDIR=$RPM_BUILD_ROOT
17631700 156
1568d5eb 157install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
5a8f1bd1 158install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
159
ef0f233a 160%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
347f019c 161
269a2ef7 162%find_lang %{name}
163
17631700
AM
164%clean
165rm -rf $RPM_BUILD_ROOT
166
269a2ef7 167%files -f %{name}.lang
17631700 168%defattr(644,root,root,755)
bf7521cb 169%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
ab99996e 170%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
5a8f1bd1 171%doc contrib/conv/{*awk,*.pl,*.sh}
cf865ed3 172%doc doc/html/*.html
17631700 173%attr(755,root,root) %{_bindir}/*
17631700 174%{_mandir}/man*/*
1faa0547 175%{_desktopdir}/*.desktop
06096625 176%{_pixmapsdir}/*
a153230d 177%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.060525 seconds and 4 git commands to generate.