]> git.pld-linux.org Git - packages/elinks.git/blame - elinks.spec
- up to 0.11.4rc1 (this is marked as the latest stable
[packages/elinks.git] / elinks.spec
CommitLineData
2e552f3e 1# TODO: consider lua51
1c33e430 2#
21bf3c6a 3# Conditional build:
b67326b7
JB
4%bcond_with x # Use the X Windows System
5%bcond_with gnutls # Enable GNUTLS SSL support (disables openssl)
6%bcond_with ruby # Enable (experimental) Ruby scripting support
7%bcond_without 256 # Disable 256 colors support
8%bcond_without bittorrent # Disable BitTorrent support
9%bcond_without cgi # Disable Local CGI support
b631af97 10%bcond_without fsp # Disable FSP support
b67326b7
JB
11%bcond_without guile # Disable Guile scripting
12%bcond_without idn # Disable Internation Domain Names support
13%bcond_without ipv6 # Disable IPv6 support
14%bcond_without js # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15%bcond_without led # Disable LEDs
16%bcond_without lua # Disable Lua scripting
17%bcond_without openssl # Disable OpenSSL support
18%bcond_without perl # Disable Perl scripting
3d4d38d9
AG
19#
20%if %{with gnutls}
21%undefine with_openssl
22%endif
21bf3c6a 23#
7d0ab6ea 24%define pre rc1
17631700 25Summary: Experimantal Links (text WWW browser)
f85cbf5d
ER
26Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
27Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
28Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
17631700 29Name: elinks
7d0ab6ea 30Version: 0.11.4
31Release: 0.%{pre}
e2affc83 32Epoch: 1
17631700
AM
33License: GPL
34Group: Applications/Networking
7d0ab6ea 35Source0: http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
36# Source0-md5: 7fc7c36844be9c528c2ef28dbd4c5e6f
17631700 37Source1: %{name}.desktop
5a8f1bd1 38Source2: links.png
ef0f233a
AG
39Patch0: %{name}-home_etc.patch
40Patch1: %{name}-lua40.patch
9136119b 41Patch2: %{name}-bug517.patch
7d0ab6ea 42Patch3: %{name}-date-format.patch
43Patch4: %{name}-chunked.patch
44Patch5: %{name}-mailcap_DISPLAY.patch
8ca357a6 45URL: http://www.elinks.cz/
17631700
AM
46BuildRequires: autoconf
47BuildRequires: automake
5a8f1bd1 48BuildRequires: bzip2-devel
fcffdc5b 49BuildRequires: expat-devel
b631af97 50%{?with_fsp:BuildRequires: fsplib-devel}
ab99996e 51BuildRequires: gettext-devel
17631700 52BuildRequires: gpm-devel
3d4d38d9 53%{?with_guile:BuildRequires: guile-devel}
69d969c4 54%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
3d4d38d9
AG
55%{?with_js:BuildRequires: js-devel >= 1.5-0.rc6a.1}
56%{?with_idn:BuildRequires: libidn-devel}
8eb57a4f 57%{?with_lua:BuildRequires: lua50-devel}
1c33e430 58BuildRequires: ncurses-devel >= 5.1
3d4d38d9
AG
59%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
60%{?with_perl:BuildRequires: perl-devel}
8ca357a6 61%{?with_ruby:BuildRequires: ruby-devel}
5a8f1bd1 62BuildRequires: zlib-devel
17631700
AM
63Provides: webclient
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
c4be24e9 66%define _sysconfdir /etc/elinks
ef0f233a 67%define specflags_ia32 -fomit-frame-pointer
4fc089e9 68
17631700 69%description
cd6ad879
JB
70This is the elinks tree - intended to provide feature-rich version of
71links, however not rock-stable and dedicated mainly for testing. Its
72purpose is to make alternative to links, until Mikulas will have some
73time to maintain it, and to test and tune various patches for Mikulas
74to be able to include them in the official links releases.
17631700 75
3328f371 76%description -l es.UTF-8
c15f1e53 77Links es un browser WWW modo texto, similar al Lynx. El links muestra
78tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
79keepalive.
80
3328f371
JR
81%description -l pl.UTF-8
82Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
83elinks jednak jest dedykowana głównie do testowania.
17631700 84
3328f371
JR
85%description -l pt_BR.UTF-8
86Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
87tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
c15f1e53 88keepalive.
89
17631700 90%prep
7d0ab6ea 91%setup -q -n %{name}-%{version}%{pre}
ef0f233a 92%patch0 -p1
1fa8ef0a 93%patch1 -p1
9136119b 94%patch2 -p1
bfae6673 95%patch3 -p1
96%patch4 -p1
ba6d29fc 97%patch5 -p1
0b57a582 98
17631700 99%build
663b78ce 100%{__aclocal}
285e9f62 101%{__autoconf}
115d3038 102%{__autoheader}
ad628403 103%configure \
eda372dc 104 HAVE_SMBCLIENT=yes \
2e552f3e 105 --disable-no-root \
3d4d38d9
AG
106 %{!?debug:--enable-fastmem} \
107 %{?debug:--enable-debug} \
cc7f804f 108 %{!?with_ipv6:--disable-ipv6} \
8ca357a6 109 %{?with_bittorrent:--enable-bittorrent} \
3d4d38d9
AG
110 %{?with_cgi:--enable-cgi} \
111 --enable-finger \
112 --enable-gopher \
113 --enable-nntp \
114 %{?with_256:--enable-256-colors} \
115 --enable-exmode \
b631af97 116 %{?with_fsp:--enable-fsp} \
3d4d38d9 117 %{?with_leds:--enable-leds} \
8ca357a6 118 --enable-marks \
3d4d38d9 119 --enable-html-highlight \
3d4d38d9
AG
120 %{!?with_idn:--without-idn} \
121 %{?with_guile:--with-guile} \
122 %{?with_perl:--with-perl} \
62c5be6a 123 %{!?with_lua:--without-lua} \
8ca357a6 124 %{?with_ruby:--with-ruby} \
3d4d38d9
AG
125 %{!?with_js:--without-spidermonkey} \
126 %{?with_gnutls:--with-gnutls} \
127 %{!?with_openssl:--without-openssl} \
82dd9b93
AG
128 --with%{!?with_x:out}-x
129# xterm -e is default, one might want to change it to
130# something else
131# --with-xterm="xterm -e"
3d4d38d9 132
1378c2d4 133%{__make} V=1
17631700
AM
134
135%install
136rm -rf $RPM_BUILD_ROOT
1568d5eb 137install -d $RPM_BUILD_ROOT%{_desktopdir} \
ad628403 138 $RPM_BUILD_ROOT%{_datadir}/%{name} \
c4be24e9 139 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
17631700 140
1378c2d4 141%{__make} install V=1 \
834d1634 142 DESTDIR=$RPM_BUILD_ROOT
17631700 143
1568d5eb 144install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
5a8f1bd1 145install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
146
ef0f233a 147%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
347f019c 148
269a2ef7 149%find_lang %{name}
150
17631700
AM
151%clean
152rm -rf $RPM_BUILD_ROOT
153
269a2ef7 154%files -f %{name}.lang
17631700 155%defattr(644,root,root,755)
bf7521cb 156%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
ab99996e 157%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
5a8f1bd1 158%doc contrib/conv/{*awk,*.pl,*.sh}
cf865ed3 159%doc doc/html/*.html
17631700 160%attr(755,root,root) %{_bindir}/*
17631700 161%{_mandir}/man*/*
1faa0547 162%{_desktopdir}/*.desktop
06096625 163%{_pixmapsdir}/*
a153230d 164%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.06197 seconds and 4 git commands to generate.