]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- updated (and applied upstream)
[packages/elinks.git] / elinks.spec
1 #
2 # TODO: typos in pl.po ("tackerem", "Minumalny", "¿adañ")
3 # Conditional build:
4 %bcond_with     x               # Use the X Windows System
5 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
6 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
7 %bcond_without  256             # Disable 256 colors support
8 %bcond_without  bittorrent      # Disable BitTorrent support
9 %bcond_without  cgi             # Disable Local CGI support
10 %bcond_without  guile           # Disable Guile scripting
11 %bcond_without  idn             # Disable Internation Domain Names support
12 %bcond_without  ipv6            # Disable IPv6 support
13 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
14 %bcond_without  led             # Disable LEDs
15 %bcond_without  lua             # Disable Lua scripting
16 %bcond_without  openssl         # Disable OpenSSL support
17 %bcond_without  perl            # Disable Perl scripting
18
19 %if %{with gnutls}
20 %undefine       with_openssl
21 %endif
22 #
23 Summary:        Experimantal Links (text WWW browser)
24 Summary(es):    El links es un browser para modo texto, similar a lynx
25 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
26 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
27 Name:           elinks
28 Version:        0.11.2
29 Release:        1
30 Epoch:          1
31 License:        GPL
32 Group:          Applications/Networking
33 #Source0Download:       http://www.elinks.cz/download.html
34 Source0:        http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
35 # Source0-md5:  5a8f83afb527cf443f58b372136a81fc
36 Source1:        %{name}.desktop
37 Source2:        links.png
38 Patch0:         %{name}-home_etc.patch
39 Patch1:         %{name}-lua40.patch
40 Patch2:         %{name}-pl.po-update.patch
41 URL:            http://www.elinks.cz/
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  bzip2-devel
45 BuildRequires:  expat-devel
46 BuildRequires:  fsplib-devel
47 BuildRequires:  gettext-devel
48 BuildRequires:  gpm-devel
49 %{?with_guile:BuildRequires: guile-devel}
50 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
51 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
52 %{?with_idn:BuildRequires:      libidn-devel}
53 %{?with_lua:BuildRequires:      lua50-devel}
54 BuildRequires:  ncurses-devel >= 5.1
55 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
56 %{?with_perl:BuildRequires:     perl-devel}
57 %{?with_ruby:BuildRequires:     ruby-devel}
58 BuildRequires:  zlib-devel
59 Provides:       webclient
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         _sysconfdir     /etc/elinks
63 %define         specflags_ia32  -fomit-frame-pointer 
64
65 %description
66 This is the elinks tree - intended to provide feature-rich version of
67 links, however not rock-stable and dedicated mainly for testing. Its
68 purpose is to make alternative to links, until Mikulas will have some
69 time to maintain it, and to test and tune various patches for Mikulas
70 to be able to include them in the official links releases.
71
72 %description -l es
73 Links es un browser WWW modo texto, similar al Lynx. El links muestra
74 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
75 keepalive.
76
77 %description -l pl
78 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
79 elinks jednak jest dedykowana g³ównie do testowania.
80
81 %description -l pt_BR
82 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
83 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
84 keepalive.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91
92 %build
93 %{__aclocal}
94 %{__autoconf}
95 %{__autoheader}
96 %configure \
97         --disable-no-root \
98         HAVE_SMBCLIENT=yes \
99         %{!?debug:--enable-fastmem} \
100         %{?debug:--enable-debug} \
101         %{!?with_ipv6:--disable-ipv6} \
102         %{?with_bittorrent:--enable-bittorrent} \
103         %{?with_cgi:--enable-cgi} \
104         --enable-finger \
105         --enable-gopher \
106         --enable-nntp \
107         %{?with_256:--enable-256-colors} \
108         --enable-exmode \
109         --enable-fsp \
110         %{?with_leds:--enable-leds} \
111         --enable-marks \
112         --enable-html-highlight \
113         %{!?with_idn:--without-idn} \
114         %{?with_guile:--with-guile} \
115         %{?with_perl:--with-perl} \
116         %{!?with_lua:--without-lua} \
117         %{?with_ruby:--with-ruby} \
118         %{!?with_js:--without-spidermonkey} \
119         %{?with_gnutls:--with-gnutls} \
120         %{!?with_openssl:--without-openssl} \
121         --with%{!?with_x:out}-x
122 # xterm -e is default, one might want to change it to
123 # something else
124 #       --with-xterm="xterm -e"
125
126 %{__make} V=1
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT%{_desktopdir} \
131         $RPM_BUILD_ROOT%{_datadir}/%{name} \
132         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
133
134 %{__make} install V=1 \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
138 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
139
140 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
150 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
151 %doc contrib/conv/{*awk,*.pl,*.sh}
152 %doc doc/html/*.html
153 %attr(755,root,root) %{_bindir}/*
154 %{_mandir}/man*/*
155 %{_desktopdir}/*.desktop
156 %{_pixmapsdir}/*
157 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.106144 seconds and 3 git commands to generate.