]> git.pld-linux.org Git - packages/elfio.git/blob - elfio.spec
- pl, devel dependency on libstdc++-devel
[packages/elfio.git] / elfio.spec
1 Summary:        ELF (Executable and Linkable Format) reader and producer implemented as a C++ library
2 Summary(pl.UTF-8):      Biblioteka C++ do odczytu i tworzenia plików w formacie ELF
3 Name:           elfio
4 Version:        2.1
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/elfio/%{name}-%{version}.tar.gz
9 # Source0-md5:  d370c4e4ff432626dba661f9a30ff2f1
10 URL:            http://elfio.sourceforge.net/
11 BuildRequires:  libstdc++-devel
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 ELFIO is a C++ library for reading and generating files in the ELF
16 binary format. This library is unique and not based on any other
17 product. It is also platform independent. The library uses standard
18 ANSI C++ constructions and runs on a wide variety of architectures.
19
20 %description -l pl.UTF-8
21 ELFIO to biblioteka C++ do odczytu i tworzenia plików w formacie
22 binarnym ELF (Executable and Linkable Format). Biblioteka ta jest
23 unikalna, nie oparta na żadnym innym produkcie. Jest także niezależna
24 od platformy. Wykorzystuje standardowe konstrukcje ANSI C++ i działa
25 na wielu architekturach.
26
27 %package devel
28 Summary:        Development headers for programs using the elfio library
29 Summary(pl.UTF-8):      Pliki nagłówkowe dla programów wykorzystujących bibliotekę elfio
30 Group:          Development/Libraries
31 Requires:       libstdc++-devel
32 # doesn't require base (header-only library)
33
34 %description devel
35 This package contains the header files needed for developing programs
36 using the elfio library.
37
38 %description devel -l pl.UTF-8
39 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia programów
40 wykorzystujących bibliotekę elfio.
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{tutorial,write_obj,writer}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc AUTHORS COPYING README
62 %attr(755,root,root) %{_bindir}/elfdump
63
64 %files devel
65 %defattr(644,root,root,755)
66 %doc doc/elfio.pdf
67 %{_includedir}/elfio
This page took 0.048451 seconds and 3 git commands to generate.