]> git.pld-linux.org Git - packages/elementary.git/blob - elementary.spec
- enable wayland by default
[packages/elementary.git] / elementary.spec
1 # TODO: (some) plugins in separate packages?
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 %bcond_without  drm             # Ecore DRM support
6 %bcond_without  fb              # Ecore FB support
7 %bcond_without  sdl             # Ecore SDL support
8 %bcond_without  wayland         # Ecore Wayland support
9 %bcond_without  elocation       # Elocation support
10 %bcond_with     emap            # Emap support [not available yet in PLD]
11 %bcond_without  eweather        # Eweather support
12 %bcond_without  ewebkit         # Web (WebKit) support
13 #
14
15 %define         efl_ver         1.10.2
16
17 Summary:        Basic widget set
18 Summary(pl.UTF-8):      Zestaw prostych widżetów
19 Name:           elementary
20 Version:        1.10.3
21 Release:        1
22 License:        LGPL v2.1
23 Group:          Libraries
24 Source0:        http://download.enlightenment.org/rel/libs/elementary/%{name}-%{version}.tar.bz2
25 # Source0-md5:  b478a3167ec95a7129ac2d69ee608320
26 URL:            http://trac.enlightenment.org/e/wiki/Elementary
27 BuildRequires:  ecore-con-devel >= %{efl_ver}
28 BuildRequires:  ecore-devel >= %{efl_ver}
29 %{?with_drm:BuildRequires:      ecore-drm-devel >= %{efl_ver}}
30 BuildRequires:  ecore-evas-devel >= %{efl_ver}
31 %{?with_fb:BuildRequires:       ecore-fb-devel >= %{efl_ver}}
32 BuildRequires:  ecore-file-devel >= %{efl_ver}
33 BuildRequires:  ecore-imf-devel >= %{efl_ver}
34 BuildRequires:  ecore-input-devel >= %{efl_ver}
35 %{?with_sdl:BuildRequires:      ecore-sdl-devel >= %{efl_ver}}
36 %{?with_wayland:BuildRequires:  ecore-wayland-devel >= %{efl_ver}}
37 BuildRequires:  ecore-x-devel >= %{efl_ver}
38 BuildRequires:  edje >= %{efl_ver}
39 BuildRequires:  edje-devel >= %{efl_ver}
40 BuildRequires:  eet-devel >= %{efl_ver}
41 BuildRequires:  efreet-devel >= %{efl_ver}
42 BuildRequires:  eina-devel >= %{efl_ver}
43 BuildRequires:  eio-devel >= %{efl_ver}
44 BuildRequires:  eldbus-devel >= %{efl_ver}
45 %{?with_elocation:BuildRequires:        elocation-devel >= 0.1.0}
46 %{?with_emap:BuildRequires:     emap-devel}
47 BuildRequires:  emotion-devel >= %{efl_ver}
48 BuildRequires:  eo-devel >= %{efl_ver}
49 BuildRequires:  eolian-devel >= %{efl_ver}
50 BuildRequires:  ethumb-devel >= %{efl_ver}
51 BuildRequires:  evas-devel >= %{efl_ver}
52 BuildRequires:  evas-loader-jpeg >= %{evas_ver}
53 %{?with_webkit:BuildRequires:   ewebkit-devel >= 0-0.r127150.1}
54 BuildRequires:  gettext-devel >= 0.17
55 %{?with_eweather:BuildRequires: libeweather-devel}
56 BuildRequires:  pkgconfig >= 1:0.22
57 Requires:       %{name}-libs = %{version}-%{release}
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         efl_arch_tag    v-1.10
61 %define         elm_arch_tag    v-%{version}
62
63 %description
64 Elementary - a basic widget set that is easy to use based on EFL for
65 mobile touch-screen devices.
66
67 %description -l pl.UTF-8
68 Elementary - zestaw prostych, łatwych w użyciu widżetów, oparty na EFL
69 dla urządzeń mobilnych.
70
71 %package libs
72 Summary:        Elementary library
73 Summary(pl.UTF-8):      Bilblioteka Elementary
74 Group:          Libraries
75 Requires:       ecore-con >= %{efl_ver}
76 Requires:       ecore >= %{efl_ver}
77 %{?with_drm:Requires:   ecore-drm >= %{efl_ver}}
78 Requires:       ecore-evas >= %{efl_ver}
79 %{?with_fb:Requires:    ecore-fb >= %{efl_ver}}
80 Requires:       ecore-file >= %{efl_ver}
81 Requires:       ecore-imf >= %{efl_ver}
82 Requires:       ecore-input >= %{efl_ver}
83 %{?with_sdl:Requires:   ecore-sdl >= %{efl_ver}}
84 %{?with_wayland:Requires:       ecore-wayland >= %{efl_ver}}
85 Requires:       ecore-x >= %{efl_ver}
86 Requires:       edje-libs >= %{efl_ver}
87 Requires:       eet >= %{efl_ver}
88 Requires:       efreet-libs >= %{efl_ver}
89 Requires:       eina >= %{efl_ver}
90 Requires:       eio >= %{efl_ver}
91 Requires:       eldbus >= %{efl_ver}
92 %{?with_elocation:Requires:     elocation >= 0.1.0}
93 Requires:       emotion >= %{efl_ver}
94 Requires:       eo >= %{efl_ver}
95 Requires:       ethumb-libs >= %{efl_ver}
96 Requires:       evas >= %{efl_ver}
97 %{?with_webkit:Requires:        ewebkit >= 0-0.r127150.1}
98
99 %description libs
100 Elementary library files.
101
102 %description libs -l pl.UTF-8
103 Biblioteka Elementary.
104
105 %package devel
106 Summary:        Elementary header files
107 Summary(pl.UTF-8):      Pliki nagłówkowe Elementary
108 Group:          Development/Libraries
109 Requires:       %{name}-libs = %{version}-%{release}
110 Requires:       ecore-con-devel >= %{efl_ver}
111 Requires:       ecore-devel >= %{efl_ver}
112 %{?with_drm:Requires:   ecore-drm-devel >= %{efl_ver}}
113 Requires:       ecore-evas-devel >= %{efl_ver}
114 %{?with_fb:Requires:    ecore-fb-devel >= %{efl_ver}}
115 Requires:       ecore-file-devel >= %{efl_ver}
116 Requires:       ecore-imf-devel >= %{efl_ver}
117 Requires:       ecore-input-devel >= %{efl_ver}
118 %{?with_sdl:Requires:   ecore-sdl-devel >= %{efl_ver}}
119 %{?with_wayland:Requires:       ecore-wayland-devel >= %{efl_ver}}
120 Requires:       ecore-x-devel >= %{efl_ver}
121 Requires:       edje-devel >= %{efl_ver}
122 Requires:       eet-devel >= %{efl_ver}
123 Requires:       efreet-devel >= %{efl_ver}
124 Requires:       eina-devel >= %{efl_ver}
125 Requires:       eio-devel >= %{efl_ver}
126 Requires:       eldbus-devel >= %{efl_ver}
127 %{?with_elocation:Requires:     elocation-devel >= 0.1.0}
128 %{?with_emap:Requires:  emap-devel}
129 Requires:       emotion-devel >= %{efl_ver}
130 Requires:       eo-devel >= %{efl_ver}
131 Requires:       ethumb-devel >= %{efl_ver}
132 Requires:       evas-devel >= %{efl_ver}
133 Requires:       evas-loader-jpeg >= %{evas_ver}
134 %{?with_webkit:Requires:        ewebkit-devel >= 0-0.r127150.1}
135 %{?with_eweather:Requires:      libeweather-devel}
136
137 %description devel
138 Header files for Elementary.
139
140 %description devel -l pl.UTF-8
141 Pliki nagłówkowe Elementary.
142
143 %package static
144 Summary:        Static Elementary library
145 Summary(pl.UTF-8):      Statyczna biblioteka Elementary
146 Group:          Development/Libraries
147 Requires:       %{name}-devel = %{version}-%{release}
148
149 %description static
150 Static Elementary library.
151
152 %description static -l pl.UTF-8
153 Statyczna biblioteka Elementary.
154
155 %package -n eolian-elementary
156 Summary:        Eolian API for Elementary library
157 Summary(pl.UTF-8):      API Eolian dla biblioteki Elementary
158 Group:          Development/Libraries
159 Requires:       eolian >= %{efl_ver}
160
161 %description -n eolian-elementary
162 Eolian API for Elementary library.
163
164 %description -n eolian-elementary -l pl.UTF-8
165 API Eolian dla biblioteki Elementary.
166
167 %prep
168 %setup -q
169
170 %build
171 %configure \
172         --disable-ecore-cocoa \
173         %{!?with_drm:--disable-ecore-drm} \
174         %{!?with_fb:--disable-ecore-fb} \
175         --disable-ecore-psl1ght \
176         %{!?with_sdl:--disable-ecore-sdl} \
177         %{!?with_wayland:--disable-ecore-wayland} \
178         --disable-ecore-win32 \
179         --disable-ecore-wince \
180         %{!?with_elocation:--disable-elocation} \
181         %{!?with_emap:--disable-emap} \
182         %{!?with_eweather:--disable-eweather} \
183         --disable-silent-rules \
184         %{!?with_ewebkit:--disable-web} \
185         %{?with_static_libs:--enable-static}
186
187 %{__make}
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191
192 # icon is non-themed, so install in %{_pixmapsdir}
193 %{__make} install \
194         DESTDIR=$RPM_BUILD_ROOT \
195         icondir=%{_pixmapsdir}
196
197 %{__rm} $RPM_BUILD_ROOT%{_libdir}/edje/modules/elm/%{efl_arch_tag}/*.la \
198         $RPM_BUILD_ROOT%{_libdir}/elementary/modules/*/%{elm_arch_tag}/*.la
199
200 mv $RPM_BUILD_ROOT%{_localedir}/ko{_KR,}
201 # obsoleted by pkg-config
202 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libelementary.la
203
204 %find_lang %{name}
205
206 %clean
207 rm -rf $RPM_BUILD_ROOT
208
209 %post   libs -p /sbin/ldconfig
210 %postun libs -p /sbin/ldconfig
211
212 %files
213 %defattr(644,root,root,755)
214 %doc AUTHORS README TODO
215 %attr(755,root,root) %{_bindir}/elementary_config
216 %attr(755,root,root) %{_bindir}/elementary_quicklaunch
217 %attr(755,root,root) %{_bindir}/elementary_run
218 %attr(755,root,root) %{_bindir}/elementary_test
219 %attr(755,root,root) %{_bindir}/elm_prefs_cc
220 %{_desktopdir}/elementary_config.desktop
221 %{_desktopdir}/elementary_test.desktop
222 %{_datadir}/elementary
223 %{_pixmapsdir}/elementary.png
224
225 %files libs -f %{name}.lang
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/libelementary.so.*.*.*
228 %attr(755,root,root) %ghost %{_libdir}/libelementary.so.1
229 %dir %{_libdir}/edje/modules/elm
230 %dir %{_libdir}/edje/modules/elm/%{efl_arch_tag}
231 %attr(755,root,root) %{_libdir}/edje/modules/elm/%{efl_arch_tag}/module.so
232 %dir %{_libdir}/elementary
233 %dir %{_libdir}/elementary/modules
234 %dir %{_libdir}/elementary/modules/access_output
235 %dir %{_libdir}/elementary/modules/access_output/%{elm_arch_tag}
236 %attr(755,root,root) %{_libdir}/elementary/modules/access_output/%{elm_arch_tag}/module.so
237 %dir %{_libdir}/elementary/modules/datetime_input_ctxpopup
238 %dir %{_libdir}/elementary/modules/datetime_input_ctxpopup/%{elm_arch_tag}
239 %attr(755,root,root) %{_libdir}/elementary/modules/datetime_input_ctxpopup/%{elm_arch_tag}/module.so
240 %dir %{_libdir}/elementary/modules/prefs
241 %dir %{_libdir}/elementary/modules/prefs/%{elm_arch_tag}
242 %attr(755,root,root) %{_libdir}/elementary/modules/prefs/%{elm_arch_tag}/module.so
243 %{_libdir}/elementary/modules/prefs/%{elm_arch_tag}/elm_prefs_swallow.edj
244 %dir %{_libdir}/elementary/modules/test_entry
245 %dir %{_libdir}/elementary/modules/test_entry/%{elm_arch_tag}
246 %attr(755,root,root) %{_libdir}/elementary/modules/test_entry/%{elm_arch_tag}/module.so
247 %dir %{_libdir}/elementary/modules/test_map
248 %dir %{_libdir}/elementary/modules/test_map/%{elm_arch_tag}
249 %attr(755,root,root) %{_libdir}/elementary/modules/test_map/%{elm_arch_tag}/module.so
250
251 %files devel
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/elementary_codegen
254 %attr(755,root,root) %{_libdir}/libelementary.so
255 %{_includedir}/elementary-1
256 %{_pkgconfigdir}/elementary.pc
257 %{_libdir}/cmake/Elementary
258
259 %if %{with static_libs}
260 %files static
261 %defattr(644,root,root,755)
262 %{_libdir}/libelementary.a
263 %endif
264
265 %files -n eolian-elementary
266 %defattr(644,root,root,755)
267 %{_datadir}/eolian/include/elementary-1
This page took 0.107996 seconds and 3 git commands to generate.