]> git.pld-linux.org Git - packages/elektra.git/blob - elektra.spec
- files update
[packages/elektra.git] / elektra.spec
1 # TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
2 #
3 # Conditonal build:
4 %bcond_with     full    # "full" variant (libelektra-full with all plugins linked in)
5 %bcond_without  java    # Java support: JNA binding and JNI plugin (needs Java 8)
6 %bcond_without  glib    # GLib/GObject binding
7 %bcond_without  lua     # Lua (5.2) support: binding and plugin
8 %bcond_without  python2 # Python 2 support: binding and plugin
9 %bcond_without  python3 # Python 3 support: binding and plugin
10 %bcond_without  qt      # Qt GUI
11 #
12 Summary:        A key/value pair database to store software configurations
13 Summary(pl.UTF-8):      Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
14 Name:           elektra
15 Version:        0.8.19
16 Release:        1
17 License:        BSD
18 Group:          Applications/System
19 Source0:        http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  6669e765c834e259fb7570f126b85d7e
21 Patch1:         %{name}-no-markdown.patch
22 Patch2:         %{name}-no-deb.patch
23 URL:            http://www.libelektra.org/
24 %if %{with qt}
25 BuildRequires:  Qt5Core-devel >= 5
26 BuildRequires:  Qt5Gui-devel >= 5
27 BuildRequires:  Qt5Qml-devel >= 5
28 BuildRequires:  Qt5Quick-devel >= 5
29 BuildRequires:  Qt5Widgets-devel >= 5
30 BuildRequires:  Qt5Test-devel >= 5
31 %endif
32 BuildRequires:  augeas-devel >= 1.0
33 BuildRequires:  boost-devel
34 BuildRequires:  cmake >= 2.8.8
35 BuildRequires:  dbus-devel
36 BuildRequires:  doxygen
37 BuildRequires:  gettext-tools
38 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.36}
39 %{?with_glib:BuildRequires:     gobject-introspection-devel >= 1.38}
40 # for binding
41 %{?with_java:BuildRequires:     java-jna}
42 %{?with_java:BuildRequires:     jdk >= 1.8}
43 # jawt for plugin
44 %{?with_java:BuildRequires:     jre-X11 >= 1.8}
45 BuildRequires:  libgcrypt-devel
46 %{?with_qt:BuildRequires:       libmarkdown-devel}
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libxml2-devel >= 2.0
49 BuildRequires:  libxslt-progs
50 %{?with_lua:BuildRequires:      lua52-devel >= 5.2}
51 BuildRequires:  pkgconfig
52 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
53 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
54 BuildRequires:  ronn
55 BuildRequires:  rpm-pythonprov
56 BuildRequires:  rpmbuild(macros) >= 1.612
57 BuildRequires:  swig >= 2
58 %if %{with python2} || %{with python3}
59 BuildRequires:  swig-python >= 2
60 %endif
61 BuildRequires:  systemd-devel
62 BuildRequires:  tcl-devel
63 BuildRequires:  yajl-devel
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       mktemp
66 Obsoletes:      registry
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 The Elektra Project provides a framework to store generic
71 configuration data in an hierarchical key-value pair database, instead
72 of a human-readable only text file.
73
74 This way any software can read/save his configuration using a
75 consistent API. Also, applications can be aware of other applications
76 configurations, leveraging easy application integration.
77
78 %description -l pl.UTF-8
79 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
80 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
81 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
82
83 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
84 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
85 konfiguracji innych aplikacji, ułatwiając ich integrację.
86
87 %package gui
88 Summary:        Qt based GUI for Elektra
89 Summary(pl.UTF-8):      Oparty na Qt graficzny interfejs do Elektry
90 Group:          X11/Applications
91 Requires:       %{name} = %{version}-%{release}
92
93 %description gui
94 Qt based GUI for Elektra.
95
96 %description gui -l pl.UTF-8
97 Oparty na Qt graficzny interfejs do Elektry.
98
99 %package plugin-jni
100 Summary:        Java JNI plugin for Elektra
101 Summary(pl.UTF-8):      Wtyczka Java JNI dla Elektry
102 Group:          Libraries
103 Requires:       %{name} = %{version}-%{release}
104 # jawt
105 Requires:       jre-X11 >= 1.8
106
107 %description plugin-jni
108 Java JNI plugin for Elektra. It allows to use plugins written in Java.
109
110 %description plugin-jni -l pl.UTF-8
111 Wtyczka Java JNI dla Elektry. Pozwala na używanie wtyczek napisanych w
112 Javie.
113
114 %package plugin-lua
115 Summary:        Lua plugin for Elektra
116 Summary(pl.UTF-8):      Wtyczka Lua dla Elektry
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119 Requires:       lua52-libs >= 5.2
120
121 %description plugin-lua
122 Lua plugin for Elektra. It allows to use plugins written in Lua.
123
124 %description plugin-lua -l pl.UTF-8
125 Wtyczka Lua dla Elektry. Pozwala na używanie wtyczek napisanych w Lua.
126
127 %package plugin-python2
128 Summary:        Python 2 plugin for Elektra
129 Summary(pl.UTF-8):      Wtyczka Python 2 dla Elektry
130 Group:          Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       python-libs >= 1:2.7
133
134 %description plugin-python2
135 Python 2 plugin for Elektra. It allows to use plugins written in
136 Python 2.
137
138 %description plugin-python2 -l pl.UTF-8
139 Wtyczka 2 Python dla Elektry. Pozwala na używanie wtyczek napisanych w
140 Pythonie 2.
141
142 %package plugin-python3
143 Summary:        Python plugin for Elektra
144 Summary(pl.UTF-8):      Wtyczka Python dla Elektry
145 Group:          Libraries
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       python3-libs >= 1:3.2
148
149 %description plugin-python3
150 Python 3 plugin for Elektra. It allows to use plugins written in
151 Python 3.
152
153 %description plugin-python3 -l pl.UTF-8
154 Wtyczka Python 3 dla Elektry. Pozwala na używanie wtyczek napisanych w
155 Pythonie 3.
156
157 %package -n bash-completion-elektra
158 Summary:        Bash completion for Elektra commands
159 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
160 Group:          Applications/Shells
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       bash-completion
163
164 %description -n bash-completion-elektra
165 Bash completion for Elektra kdb command.
166
167 %description -n bash-completion-elektra -l pl.UTF-8
168 Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
169
170 %package libs
171 Summary:        Elektra Project libraries
172 Summary(pl.UTF-8):      Biblioteki projektu Elektra
173 Group:          Libraries
174 Obsoletes:      elektra-cpp < 0.8
175 Conflicts:      elektra < 0.7
176
177 %description libs
178 The Elektra Project provides a framework to store generic
179 configuration data in an hierarchical key-value pair database, instead
180 of a human-readable only text file.
181
182 This way any software can read/save his configuration using a
183 consistent API. Also, applications can be aware of other applications
184 configurations, leveraging easy application integration.
185
186 This package contains Elektra shared libraries.
187
188 %description libs -l pl.UTF-8
189 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
190 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
191 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
192
193 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
194 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
195 konfiguracji innych aplikacji, ułatwiając ich integrację.
196
197 Ten pakiet zawiera biblioteki współdzielone Elektry.
198
199 %package devel
200 Summary:        Include files and API documentation for Elektra Project
201 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API projektu Elektra
202 Group:          Development/Libraries
203 Requires:       %{name}-libs = %{version}-%{release}
204
205 %description devel
206 This package contains the include files and API manual pages to use
207 the Elektra API in C.
208
209 %description devel -l pl.UTF-8
210 Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
211 systemowego opisującego sposób użycia API Elektry w C.
212
213 %package static
214 Summary:        Static libraries for Elektra Project
215 Summary(pl.UTF-8):      Statyczne biblioteki projektu Elektra
216 Group:          Development/Libraries
217 Requires:       %{name}-devel = %{version}-%{release}
218
219 %description static
220 This package contains static libraries for Elektra Project.
221
222 %description static -l pl.UTF-8
223 Ten pakiet zawiera statyczne biblioteki projektu Elektra.
224
225 %package cpp-devel
226 Summary:        Header files of C++ interface for Elektra library
227 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
228 Group:          Development/Libraries
229 Requires:       %{name}-devel = %{version}-%{release}
230 Requires:       libstdc++-devel
231 Obsoletes:      elektra-cpp-static < 0.8
232
233 %description cpp-devel
234 Header files of C++ interface for Elektra library.
235
236 %description cpp-devel -l pl.UTF-8
237 Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
238
239 %package glib
240 Summary:        GLib/GObject binding for Elektra
241 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry
242 Group:          Libraries
243 Requires:       %{name}-libs = %{version}-%{release}
244 Requires:       glib2 >= 1:2.36
245
246 %description glib
247 GLib/GObject binding for Elektra.
248
249 %description glib -l pl.UTF-8
250 Wiązanie GLib/GObject do Elektry.
251
252 %package glib-devel
253 Summary:        GLib/GObject binding for Elektra - development files
254 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry - pliki programistyczne
255 Group:          Libraries
256 Requires:       %{name}-devel = %{version}-%{release}
257 Requires:       glib2-devel >= 1:2.36
258
259 %description glib-devel
260 GLib/GObject binding for Elektra - development files.
261
262 %description glib-devel -l pl.UTF-8
263 Wiązanie GLib/GObject do Elektry - pliki programistyczne.
264
265 %package -n java-elektra
266 Summary:        Java binding for Elektra
267 Summary(pl.UTF-8):      Wiązanie języka Java dla Elektry
268 Group:          Libraries
269 Requires:       %{name}-libs = %{version}-%{release}
270 Requires:       java-jna
271 Requires:       jre
272
273 %description -n java-elektra
274 Java binding for Elektra.
275
276 %description -n java-elektra -l pl.UTF-8
277 Wiązanie języka Java dla Elektry.
278
279 %package -n lua-elektra
280 Summary:        Lua binding for Elektra
281 Summary(pl.UTF-8):      Wiązanie języka Lua dla Elektry
282 Group:          Libraries
283 Requires:       %{name}-libs = %{version}-%{release}
284 Requires:       lua52-libs >= 5.2
285
286 %description -n lua-elektra
287 Lua binding for Elektra.
288
289 %description -n lua-elektra -l pl.UTF-8
290 Wiązanie języka Lua dla Elektry.
291
292 %package -n lua-elektra-glib
293 Summary:        Lua/GI binding for Elektra
294 Summary(pl.UTF-8):      Wiązanie Lua/GI dla Elektry
295 Group:          Libraries
296 Requires:       %{name}-glib = %{version}-%{release}
297 Requires:       lua52-libs >= 5.2
298 #R: lua52-lgi ?
299
300 %description -n lua-elektra-glib
301 Lua/GI binding for Elektra.
302
303 %description -n lua-elektra-glib -l pl.UTF-8
304 Wiązanie Lua/GI dla Elektry.
305
306 %package -n python-elektra
307 Summary:        Python 2 binding for Elektra
308 Summary(pl.UTF-8):      Wiązanie Pythona 2 dla Elektry
309 Group:          Libraries
310 Requires:       %{name}-libs = %{version}-%{release}
311 Requires:       python-libs >= 1:2.7
312
313 %description -n python-elektra
314 Python 2 binding for Elektra.
315
316 %description -n python-elektra -l pl.UTF-8
317 Wiązanie Pythona 2 dla Elektry.
318
319 %package -n python3-elektra
320 Summary:        Python 3 binding for Elektra
321 Summary(pl.UTF-8):      Wiązanie Pythona 3 dla Elektry
322 Group:          Libraries
323 Requires:       %{name}-libs = %{version}-%{release}
324 Requires:       python3-libs >= 1:3.2
325
326 %description -n python3-elektra
327 Python 3 binding for Elektra.
328
329 %description -n python3-elektra -l pl.UTF-8
330 Wiązanie Pythona 3 dla Elektry.
331
332 %package -n python3-elektra-glib
333 Summary:        Python 3 GI binding for Elektra
334 Summary(pl.UTF-8):      Wiązanie Pythona 3 GI dla Elektry
335 Group:          Libraries
336 Requires:       %{name}-glib = %{version}-%{release}
337 Requires:       python3-pygobject3 >= 3
338
339 %description -n python3-elektra-glib
340 Python 3 GI binding for Elektra.
341
342 %description -n python3-elektra-glib -l pl.UTF-8
343 Wiązanie Pythona 3 GI dla Elektry.
344
345 %prep
346 %setup -q
347 %patch1 -p1
348 %patch2 -p1
349
350 %build
351 install -d build
352 cd build
353 %cmake .. \
354         -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
355         %{!?with_full:-DBUILD_FULL=OFF} \
356         -DINSTALL_TESTING=FALSE \
357         -DPLUGINS=ALL \
358         -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
359         -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}" \
360         -DBUILD_STATIC=ON
361
362 %{__make} -j1
363
364 %install
365 rm -rf $RPM_BUILD_ROOT
366
367 %{__make} -C build install \
368         DESTDIR=$RPM_BUILD_ROOT
369
370 install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
371
372 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
373 mv $RPM_BUILD_ROOT{%{bash_compdir}/kdb,/etc/bash_completion.d/kdb}
374
375 %if %{with python2}
376 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
377 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
378 %py_postclean
379 %endif
380
381 %if %{with python3}
382 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
383 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
384 %endif
385
386 # prepare docs
387 %{__rm} -rf installed-doc
388 install -d installed-doc
389 %{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
390
391 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*}.3elektra
392
393 %clean
394 rm -rf $RPM_BUILD_ROOT
395
396 %post   libs -p /sbin/ldconfig
397 %postun libs -p /sbin/ldconfig
398
399 %post   glib -p /sbin/ldconfig
400 %postun glib -p /sbin/ldconfig
401
402 %files
403 %defattr(644,root,root,755)
404 %doc doc/{AUTHORS,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
405 # doc/standards installed-doc/scripts
406 %attr(755,root,root) %{_bindir}/kdb
407 %if %{with full}
408 %attr(755,root,root) %{_bindir}/kdb-full
409 %endif
410 %dir %{_libdir}/elektra
411 # R: augeas-libs
412 %attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
413 %attr(755,root,root) %{_libdir}/elektra/libelektra-base64.so
414 %attr(755,root,root) %{_libdir}/elektra/libelektra-blockresolver.so
415 %attr(755,root,root) %{_libdir}/elektra/libelektra-boolean.so
416 %attr(755,root,root) %{_libdir}/elektra/libelektra-c.so
417 %attr(755,root,root) %{_libdir}/elektra/libelektra-cachefilter.so
418 %attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
419 %attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
420 %attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
421 %attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
422 # R: libgcrypt
423 %attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_gcrypt.so
424 %attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_openssl.so
425 %attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
426 %attr(755,root,root) %{_libdir}/elektra/libelektra-curlget.so
427 # R: dbus
428 %attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
429 %attr(755,root,root) %{_libdir}/elektra/libelektra-desktop.so
430 %attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
431 %attr(755,root,root) %{_libdir}/elektra/libelektra-dpkg.so
432 %attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
433 %attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
434 %attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
435 %attr(755,root,root) %{_libdir}/elektra/libelektra-fcrypt.so
436 %attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
437 %attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
438 %attr(755,root,root) %{_libdir}/elektra/libelektra-gitresolver.so
439 %attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
440 %attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
441 %attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
442 %attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
443 %attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
444 # uses internal inih library
445 %attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
446 %attr(755,root,root) %{_libdir}/elektra/libelektra-iterate.so
447 # R: systemd-libs
448 %attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
449 %attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
450 %attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
451 %attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
452 %attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
453 %attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
454 %attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
455 %attr(755,root,root) %{_libdir}/elektra/libelektra-mozprefs.so
456 %attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
457 %attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
458 # uses internal nickel library
459 %attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
460 %attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
461 %attr(755,root,root) %{_libdir}/elektra/libelektra-passwd.so
462 %attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
463 %attr(755,root,root) %{_libdir}/elektra/libelektra-profile.so
464 %attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
465 %attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
466 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
467 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
468 %attr(755,root,root) %{_libdir}/elektra/libelektra-required.so
469 %attr(755,root,root) %{_libdir}/elektra/libelektra-semlock.so
470 %attr(755,root,root) %{_libdir}/elektra/libelektra-shell.so
471 %attr(755,root,root) %{_libdir}/elektra/libelektra-simplespeclang.so
472 %attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
473 %attr(755,root,root) %{_libdir}/elektra/libelektra-spec.so
474 %attr(755,root,root) %{_libdir}/elektra/libelektra-storage.so
475 %attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
476 %attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
477 %attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
478 %attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
479 %attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
480 %attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
481 %attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
482 %attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
483 %attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
484 %attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
485 %attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
486 # R: libxml2
487 %attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
488 # R: yajl
489 %attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
490 %dir %{_libdir}/elektra/tool_exec
491 %attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
492 %attr(755,root,root) %{_libdir}/elektra/tool_exec/configure-firefox
493 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
494 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
495 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
496 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
497 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
498 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
499 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
500 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-open
501 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
502 %attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
503 %dir %{_libdir}/elektra/tool_exec/ffconfig
504 %attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupConfig
505 %attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupHomepage
506 %attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupProxy
507 %attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/writeConfigFiles
508 %attr(755,root,root) %{_libdir}/elektra/tool_exec/find-tools
509 %attr(755,root,root) %{_libdir}/elektra/tool_exec/install-sh-completion
510 %attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
511 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
512 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
513 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
514 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
515 %attr(755,root,root) %{_libdir}/elektra/tool_exec/race
516 %attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
517 %attr(755,root,root) %{_libdir}/elektra/tool_exec/upgrade-bootstrap
518 %{_datadir}/sgml/elektra
519 %{_mandir}/man1/kdb.1*
520 %{_mandir}/man1/kdb-check.1*
521 %{_mandir}/man1/kdb-convert.1*
522 %{_mandir}/man1/kdb-cp.1*
523 %{_mandir}/man1/kdb-export.1*
524 %{_mandir}/man1/kdb-file.1*
525 %{_mandir}/man1/kdb-fstab.1*
526 %{_mandir}/man1/kdb-get.1*
527 %{_mandir}/man1/kdb-getmeta.1*
528 %{_mandir}/man1/kdb-help.1*
529 %{_mandir}/man1/kdb-import.1*
530 %{_mandir}/man1/kdb-info.1*
531 %{_mandir}/man1/kdb-introduction.1*
532 %{_mandir}/man1/kdb-list.1*
533 %{_mandir}/man1/kdb-list-tools.1*
534 %{_mandir}/man1/kdb-ls.1*
535 %{_mandir}/man1/kdb-lsmeta.1*
536 %{_mandir}/man1/kdb-merge.1*
537 %{_mandir}/man1/kdb-mount.1*
538 %{_mandir}/man1/kdb-mv.1*
539 %{_mandir}/man1/kdb-remount.1*
540 %{_mandir}/man1/kdb-rm.1*
541 %{_mandir}/man1/kdb-set.1*
542 %{_mandir}/man1/kdb-setmeta.1*
543 %{_mandir}/man1/kdb-sget.1*
544 %{_mandir}/man1/kdb-shell.1*
545 %{_mandir}/man1/kdb-test.1*
546 %{_mandir}/man1/kdb-umount.1*
547 %{_mandir}/man1/kdb-vset.1*
548 %{_mandir}/man7/elektra-*.7*
549
550 %if 0
551 %files gen ?
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
554 %{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
555 # FIXME: should be in elektra_gen subdir
556 %{py_sitescriptdir}/support
557 %{_datadir}/elektra/templates
558 %endif
559
560 %files gui
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_bindir}/elektra-qt-editor
563 %attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
564 %{_datadir}/appdata/org.libelektra.elektra-qt-editor.appdata.xml
565 %{_desktopdir}/org.libelektra.elektra-qt-editor.desktop
566 %{_iconsdir}/hicolor/scalable/apps/elektra-symbolic.svg
567 %{_iconsdir}/hicolor/scalable/apps/elektra.svg
568 %{_mandir}/man1/kdb-qt-gui.1*
569
570 %if %{with java}
571 %files plugin-jni
572 %defattr(644,root,root,755)
573 # R: jre with jawt
574 %attr(755,root,root) %{_libdir}/elektra/libelektra-jni.so
575 %endif
576
577 %if %{with lua}
578 %files plugin-lua
579 %defattr(644,root,root,755)
580 # R: lua52-libs
581 %attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
582 %endif
583
584 %if %{with python2}
585 %files plugin-python2
586 %defattr(644,root,root,755)
587 # R: python-libs
588 %attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
589 %endif
590
591 %if %{with python3}
592 %files plugin-python3
593 %defattr(644,root,root,755)
594 # R: python3-libs
595 %attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
596 %endif
597
598 %files -n bash-completion-elektra
599 %defattr(644,root,root,755)
600 /etc/bash_completion.d/kdb
601
602 %files libs
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
605 %attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
606 %attr(755,root,root) %{_libdir}/libelektra-core.so.*.*.*
607 %attr(755,root,root) %ghost %{_libdir}/libelektra-core.so.4
608 %attr(755,root,root) %{_libdir}/libelektra-ease.so.*.*.*
609 %attr(755,root,root) %ghost %{_libdir}/libelektra-ease.so.4
610 %attr(755,root,root) %{_libdir}/libelektra-kdb.so.*.*.*
611 %attr(755,root,root) %ghost %{_libdir}/libelektra-kdb.so.4
612 %attr(755,root,root) %{_libdir}/libelektra-meta.so.*.*.*
613 %attr(755,root,root) %ghost %{_libdir}/libelektra-meta.so.4
614 %attr(755,root,root) %{_libdir}/libelektra-plugin.so.*.*.*
615 %attr(755,root,root) %ghost %{_libdir}/libelektra-plugin.so.4
616 %attr(755,root,root) %{_libdir}/libelektra-proposal.so.*.*.*
617 %attr(755,root,root) %ghost %{_libdir}/libelektra-proposal.so.4
618 %attr(755,root,root) %{_libdir}/libelektratools.so.*.*.*
619 %attr(755,root,root) %ghost %{_libdir}/libelektratools.so.2
620 %if %{with full}
621 %attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
622 %attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
623 %endif
624
625 %files devel
626 %defattr(644,root,root,755)
627 %doc doc/API.md installed-doc/elektra-api/html
628 %attr(755,root,root) %{_libdir}/libelektra.so
629 %if %{with full}
630 %attr(755,root,root) %{_libdir}/libelektra-full.so
631 %endif
632 %dir %{_includedir}/elektra
633 %{_includedir}/elektra/kdb*.h
634 %{_pkgconfigdir}/elektra.pc
635 %{_datadir}/cmake/Modules/ElektraConfig*.cmake
636 %{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
637 %{_mandir}/man3/api.3elektra*
638 %{_mandir}/man3/deprecated.3elektra*
639 %{_mandir}/man3/kdb*.3elektra*
640 %{_mandir}/man3/key*.3elektra*
641 %{_mandir}/man3/meta.3elektra*
642 %{_mandir}/man3/plugin.3elektra*
643 %{_mandir}/man3/proposal.3elektra*
644
645 %files static
646 %defattr(644,root,root,755)
647 %{_libdir}/libelektra-static.a
648 %{_libdir}/libelektratools-static.a
649
650 %files cpp-devel
651 %defattr(644,root,root,755)
652 %{_includedir}/elektra/*.hpp
653 %{_includedir}/elektra/helper
654 %{_includedir}/elektra/merging
655 # libelektratools API man pages
656 %{_mandir}/man3/automergeconfiguration.hpp.3elektra*
657 %{_mandir}/man3/automergestrategy.cpp.3elektra*
658 %{_mandir}/man3/automergestrategy.hpp.3elektra*
659 %{_mandir}/man3/comparison.cpp.3elektra*
660 %{_mandir}/man3/comparison.hpp.3elektra*
661 %{_mandir}/man3/backend.hpp.3elektra*
662 %{_mandir}/man3/backends.hpp.3elektra*
663 %{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
664 %{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
665 %{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
666 %{_mandir}/man3/mergeconfiguration.hpp.3elektra*
667 %{_mandir}/man3/mergeconflict.hpp.3elektra*
668 %{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
669 %{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
670 %{_mandir}/man3/mergeresult.cpp.3elektra*
671 %{_mandir}/man3/mergeresult.hpp.3elektra*
672 %{_mandir}/man3/mergetask.hpp.3elektra*
673 %{_mandir}/man3/mergetestutils.cpp.3elektra*
674 %{_mandir}/man3/metamergestrategy.cpp.3elektra*
675 %{_mandir}/man3/metamergestrategy.hpp.3elektra*
676 %{_mandir}/man3/newkeystrategy.cpp.3elektra*
677 %{_mandir}/man3/newkeystrategy.hpp.3elektra*
678 %{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
679 %{_mandir}/man3/onesidestrategy.cpp.3elektra*
680 %{_mandir}/man3/onesidestrategy.hpp.3elektra*
681 %{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
682 %{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
683 %{_mandir}/man3/modules.cpp.3elektra*
684 %{_mandir}/man3/modules.hpp.3elektra*
685 %{_mandir}/man3/plugin.cpp.3elektra*
686 %{_mandir}/man3/plugin.hpp.3elektra*
687 %{_mandir}/man3/plugins.cpp.3elektra*
688 %{_mandir}/man3/plugins.hpp.3elektra*
689 %{_mandir}/man3/src_backend.cpp.3elektra*
690 %{_mandir}/man3/testtool_*.cpp.3elektra*
691 %{_mandir}/man3/threewaymerge.cpp.3elektra*
692 %{_mandir}/man3/threewaymerge.hpp.3elektra*
693 %{_mandir}/man3/toolexcept.hpp.3elektra*
694
695 %if %{with glib}
696 %files glib
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/libgelektra-4.0.so
699 %{_libdir}/girepository-1.0/GElektra-4.0.typelib
700
701 %files glib-devel
702 %defattr(644,root,root,755)
703 %{_datadir}/gir-1.0/GElektra-4.0.gir
704 %{_includedir}/elektra/gelektra-*.h
705 %{_pkgconfigdir}/gelektra-4.0.pc
706 %endif
707
708 %if %{with java}
709 %files -n java-elektra
710 %defattr(644,root,root,755)
711 %{_javadir}/libelektra-1.jar
712 %{_javadir}/libelektra.jar
713 %endif
714
715 %if %{with lua}
716 %files -n lua-elektra
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
719
720 %if %{with glib}
721 %files -n lua-elektra-glib
722 %defattr(644,root,root,755)
723 %dir %{_datadir}/lua/5.2/lgi
724 %dir %{_datadir}/lua/5.2/lgi/override
725 %{_datadir}/lua/5.2/lgi/override/GElektra.lua
726 %endif
727 %endif
728
729 %if %{with python2}
730 %files -n python-elektra
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{py_sitedir}/_kdb.so
733 %{py_sitedir}/kdb.py[co]
734 %endif
735
736 %if %{with python3}
737 %files -n python3-elektra
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{py3_sitedir}/_kdb.so
740 %{py3_sitedir}/kdb.py
741 %{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
742
743 %if %{with glib}
744 %files -n python3-elektra-glib
745 %defattr(644,root,root,755)
746 %{py3_sitedir}/gi/overrides/GElektra.py
747 %{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
748 %endif
749 %endif
This page took 0.469867 seconds and 3 git commands to generate.