]> git.pld-linux.org Git - packages/eldbus.git/blob - eldbus.spec
- note efl.spec for later versions
[packages/eldbus.git] / eldbus.spec
1 # NOTE: for versions >= 1.8 see efl.spec
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         ecore_ver       1.7.9
7 %define         eina_ver        1.7.9
8
9 Summary:        Easy access to D-Bus from EFL applications
10 Summary(pl.UTF-8):      Łatwy dostęp do usługi D-Bus z aplikacji EFL
11 Name:           eldbus
12 Version:        1.7.9
13 Release:        1
14 License:        LGPL v2.1+
15 Group:          Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  f86ddcdfbb3a3df5654e72940cd7c0b5
18 URL:            http://git.enlightenment.org/legacy/eldbus.git/
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  dbus-devel
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  eina-devel >= %{eina_ver}
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig >= 1:0.22
26 Requires:       ecore >= %{ecore_ver}
27 Requires:       eina >= %{eina_ver}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %undefine       __cxx
31
32 %description
33 Eldbus provides easy access to D-Bus from EFL applications.
34
35 Eldbus allows connecting to both system and session buses acting as
36 both client and service roles.
37
38 %description -l pl.UTF-8
39 Eldbus zapewnia łatwy dostęp do usługi D-Bus z aplikacji EFL.
40
41 Eldbus pozwala na łączenie się z szyną systemową lub sesyjną, zarówno
42 w roli klienta, jak i usługi.
43
44 %package devel
45 Summary:        Header files for eldbus library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki eldbus
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       dbus-devel
50 Requires:       ecore-devel >= %{ecore_ver}
51 Requires:       eina-devel >= %{eina_ver}
52
53 %description devel
54 Header files for eldbus library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki eldbus.
58
59 %package static
60 Summary:        Static eldbus library
61 Summary(pl.UTF-8):      Statyczna biblioteka eldbus
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static eldbus library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka eldbus.
70
71 %prep
72 %setup -q
73
74 %build
75 %{__libtoolize}
76 %{__aclocal} -I m4
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 %configure \
81         --disable-silent-rules \
82         %{?with_static_libs:--enable-static}
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # obsoleted by pkg-config
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libeldbus.la
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS COPYING README
103 %attr(755,root,root) %{_libdir}/libeldbus.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libeldbus.so.1
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_bindir}/eldbus-codegen
109 %attr(755,root,root) %{_libdir}/libeldbus.so
110 %{_includedir}/eldbus-1
111 %{_pkgconfigdir}/eldbus.pc
112
113 %if %{with static_libs}
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libeldbus.a
117 %endif
This page took 0.147158 seconds and 3 git commands to generate.