]> git.pld-linux.org Git - packages/ejabberd.git/blob - ejabberd.spec
Do not let the autotools run 'git describe'
[packages/ejabberd.git] / ejabberd.spec
1 #
2 # TODO:
3 #       - add systemd unit
4
5 # Conditional build:
6 %bcond_with     pam             # PAM authentication support
7 %bcond_with     logdb           # enable mod_logdb (server-side message logging)
8 #
9
10 %define realname        ejabberd
11
12 Summary:        Fault-tolerant distributed Jabber/XMPP server
13 Summary(pl.UTF-8):      Odporny na awarie rozproszony serwer Jabbera/XMPP
14 Name:           %{realname}
15 Version:        13.10
16 Release:        0.1
17 License:        GPL
18 Group:          Applications/Communications
19 Source0:        http://www.process-one.net/downloads/ejabberd/%{version}/%{realname}-%{version}.tgz
20 # Source0-md5:  94ce4fe244ee72771eeafe27209d6d3c
21 Source1:        %{realname}.init
22 Source2:        %{realname}.sysconfig
23 #
24 # Archives created with the ejabberd-pack_deps.sh script (in this repo)
25 Source10:       ejabberd-goldrush-20131108.tar.gz
26 # Source10-md5: 3f61708d20fcee2e7d47036cc470f4e9
27 Source11:       ejabberd-lager-20131111.tar.gz
28 # Source11-md5: e0933da9d0462b045f6b9c4bbd320d3e
29 Source12:       ejabberd-p1_cache_tab-20130515.tar.gz
30 # Source12-md5: f2500cffdaff434b354d01eeb24d136d
31 Source13:       ejabberd-p1_iconv-20130602.tar.gz
32 # Source13-md5: ab0118d4097ee756f65fd087265c88ae
33 Source14:       ejabberd-p1_stringprep-20131113.tar.gz
34 # Source14-md5: 282d70c792a78ea9a7415b0b4e65e157
35 Source15:       ejabberd-p1_tls-20130717.tar.gz
36 # Source15-md5: 1211c5d8f0a95b58dfc5fb5bf4e13ded
37 Source16:       ejabberd-p1_xml-20131017.tar.gz
38 # Source16-md5: dc7ebd7ed1ed6340ff0e7739173d4438
39 Source17:       ejabberd-p1_yaml-20131031.tar.gz
40 # Source17-md5: 82d4bb5c5d56ab93a60f5d1c6e583dc1
41 Source18:       ejabberd-p1_zlib-20130515.tar.gz
42 # Source18-md5: a203d9359122ead64966eeb0bd1c8cf7
43 Source19:       ejabberd-xmlrpc-20130116.tar.gz
44 # Source19-md5: 22e02ff7ca174b4ac225005f63da10ad
45 Source20:       ejabberd-jiffy-20130702.tar.gz
46 # Source20-md5: 01b156e97005f07ce8bb46ecf27471ff
47 Source21:       ejabberd-p1_mysql-20131024.tar.gz
48 # Source21-md5: c02921f21ba030357d2cbbbf182af54a
49 Source22:       ejabberd-p1_pam-20130515.tar.gz
50 # Source22-md5: 0ca31094d93dfb047f05c7539136433a
51 Source23:       ejabberd-p1_pgsql-20130515.tar.gz
52 # Source23-md5: 1958be8e59d1b472499ef1bdf8edc1db
53 Source24:       ejabberd-p1_stun-20130624.tar.gz
54 # Source24-md5: 9a1c5ad9b3b95364d3f76446fcf58dc3
55 #
56 Patch0:         %{realname}-makefile.patch
57 # not available for 13.10
58 #Patch1:                %{realname}-vcard-access-get.patch
59 # http://www.dp.uz.gov.ua/o.palij/mod_logdb/patch-mod_logdb-2.1.12.diff
60 Patch2:         %{realname}-mod_logdb.patch
61 Patch3:         %{realname}-inetrc_path.patch
62 URL:            http://www.ejabberd.im/
63 BuildRequires:  autoconf
64 BuildRequires:  automake
65 BuildRequires:  erlang >= 1:R15B01
66 BuildRequires:  expat-devel >= 1.95
67 BuildRequires:  openssl-devel
68 %if %{with pam}
69 BuildRequires:  pam-devel
70 %endif
71 BuildRequires:  rpmbuild(macros) >= 1.268
72 BuildRequires:  yaml-devel
73 BuildRequires:  zlib-devel
74 Requires(post): /usr/bin/perl
75 Requires(post): jabber-common
76 Requires(post): sed >= 4.0
77 Requires(post): textutils
78 Requires(post,preun):   /sbin/chkconfig
79 Requires:       erlang
80 Requires:       expat >= 1.95
81 Requires:       rc-scripts
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _noautoprovfiles        %{_libdir}/%{name}/priv/lib/
85
86 %description
87 ejabberd is a Free and Open Source fault-tolerant distributed Jabber
88 server. It is written mostly in Erlang.
89
90 %description -l pl.UTF-8
91 ejabberd to darmowy, z otwartymi źródłami, odporny na awarie
92 rozproszony serwer Jabbera. Jest napisany w większości w Erlangu.
93
94 %package logdb
95 Summary:        Server-side logging module
96 Group:          Applications/Communications
97 Requires:       %{name} = %{version}-%{release}
98
99 %description logdb
100 Server-side logging module.
101
102 %prep
103 %setup -q -a 10 -a 11 -a 12 -a 13 -a 14 -a 15 -a 16 -a 17 -a 18 -a 19 -a 20 -a 21 -a 22 -a 23 -a 24
104 %patch0 -p1
105 #%%patch1 -p1
106 %if %{with logdb}
107 %patch2 -p0
108 %endif
109 %patch3 -p1
110
111 # do not let it use 'git describe' to fetch version
112 # it uses nonsense during manual builds and fails on the builder
113 sed -i -e"s/AC_INIT(ejabberd,[^,]*,/AC_INIT(ejabberd,community %{version},/" configure.ac
114 ! grep -q "git describe" configure.ac
115
116 %build
117 %{__aclocal} -I m4
118 %{__autoconf}
119 %configure \
120         %{?with_pam --enable-pam} \
121         --with-openssl=%{_prefix} \
122         --enable-user=jabber \
123         --enable-full-xml \
124         --enable-nif \
125         --enable-odbc \
126         --enable-mysql \
127         --enable-pgsql \
128         %{?with_pam:--enable-pam} \
129         --enable-zlib \
130         --enable-stun \
131         --enable-json \
132         --enable-iconv \
133         --enable-lager
134 touch deps/.got
135
136 cd deps/p1_iconv
137 %configure
138 cd ../..
139 cd deps/p1_stringprep
140 %configure
141 cd ../..
142 cd deps/p1_tls
143 %configure
144 cd ../..
145 cd deps/p1_xml
146 %configure \
147         --enable-nif \
148         --enable-full-xml
149 cd ../..
150 cd deps/p1_yaml
151 %configure
152 cd ../..
153 cd deps/p1_zlib
154 %configure
155 cd ../..
156
157 %{__make} -j1
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT{/var/lib/%{realname},/etc/{sysconfig,rc.d/init.d},%{_sbindir}}
162
163 %{__make} install -j1 \
164         CHOWN_COMMAND=true \
165         O_USER="" \
166         G_USER="" \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 sed -e's,@libdir@,%{_libdir},g' -e 's,@EJABBERD_DOC_PATH@,%{_docdir}/%{name}-%{version}/doc,g' %{SOURCE1} > $RPM_BUILD_ROOT/etc/rc.d/init.d/%{realname}
170 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{realname}
171
172 chmod u+rw $RPM_BUILD_ROOT%{_sbindir}/%{realname}*
173
174 chmod 755 $RPM_BUILD_ROOT%{_libdir}/ejabberd/priv/lib/*.so
175
176 rm -rf _doc 2>/dev/null || :
177 mv $RPM_BUILD_ROOT%{_docdir}/%{name} _doc
178
179 touch $RPM_BUILD_ROOT%{_sysconfdir}/jabber/ejabberd.cfg
180 touch $RPM_BUILD_ROOT/var/lib/ejabberd/.erlang.cookie
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %pre
186 if [ -e /etc/jabber/ejabberd.cfg ] ; then
187         if grep -Eq '^[^#]*access_get' ; then
188                 echo "Your 'ejabberd.cfg' config file seems to use 'access_get' option of mod_vcard" >&2
189                 echo "this is not supported by this ejabberd version in PLD" >&2
190                 exit 1
191         fi
192         %banner -e %{name} <<'EOF'
193 Old-style /etc/jabber/ejabberd.cfg configuration file exists. You should
194 consider converting it to the new YAML format. You can do this with the
195 ejabberctl command.
196 EOF
197 fi
198
199 %post
200 if [ -f %{_sysconfdir}/jabber/secret ] ; then
201         SECRET=`cat %{_sysconfdir}/jabber/secret`
202         if [ -n "$SECRET" ] ; then
203                 echo "Updating component authentication secret in ejabberd config file..."
204                 %{__sed} -i -e "s/>secret</>$SECRET</" /etc/jabber/ejabberd.yml
205         fi
206 fi
207
208 /sbin/chkconfig --add ejabberd
209 %service ejabberd restart "ejabberd server"
210
211 %preun
212 if [ "$1" = "0" ]; then
213         %service ejabberd stop
214         /sbin/chkconfig --del ejabberd
215 fi
216
217 %triggerpostun -- %{name} < 13.10
218 # convert old 'NODENAME' in /etc/sysconfig/ejabberd
219 # to 'ERLANG_NODE' in /etc/jabber/ejabberdctl.cfg
220 # and move other settings
221 NODENAME="$(hostname)"
222 if [ -e /etc/sysconfig/ejabberd ] ; then
223         . /etc/sysconfig/ejabberd || :
224 fi
225 subst="s/^#ERLANG_NODE=.*/ERLANG_NODE=ejabberd@${NODENAME}/"
226 if [ -n "$ERL_MAX_PORTS" ] ; then
227         subst="$subst;s/^#ERL_MAX_PORTS=.*/ERL_MAX_PORTS=${ERL_MAX_PORTS}/"
228 fi
229 sed -i -e"$subst" /etc/jabber/ejabberdctl.cfg || :
230 if [ -e /etc/sysconfig/ejabberd ] ; then
231         sed -i.rpmsave \
232                 -e'/^[#[:space:]]*NODENAME=/d;/^# Node name/d' \
233                 -e'/^[#[:space:]]*ERL_MAX_PORTS=/d;/^# uncomment this to allow more then 1024 connections/d' \
234                 -e'/^[#[:space:]]*ERL_FULLSWEEP_AFTER=/d;/^# uncomment this to limit memory usage/d' \
235                 /etc/sysconfig/ejabberd || :
236 fi
237 cp %{_sysconfdir}/jabber/cookie /var/lib/ejabberd/.erlang.cookie || :
238
239 %files
240 %defattr(644,root,root,755)
241 %doc sql _doc/*
242 %attr(755,root,root) %{_sbindir}/*
243 %attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/ejabberd-inetrc
244 %attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/ejabberd.yml
245 %attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/ejabberdctl.cfg
246 # legacy config may still be there
247 %attr(640,root,jabber) %ghost %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/ejabberd.cfg
248 %attr(770,root,jabber) /var/log/ejabberd
249 %if %{with logdb}
250 %exclude %{_libdir}/ejabberd/ebin/mod_logdb*
251 %endif
252 %{_libdir}/ejabberd
253 %dir %attr(770,root,jabber) /var/lib/ejabberd
254 %ghost %attr(400,jabber,jabber) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/ejabberd/.erlang.cookie
255 %attr(754,root,root) /etc/rc.d/init.d/%{realname}
256 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{realname}
257
258 %if %{with logdb}
259 %files logdb
260 %defattr(644,root,root,755)
261 %{_libdir}/ejabberd/ebin/mod_logdb*
262 %endif
This page took 0.693157 seconds and 3 git commands to generate.