]> git.pld-linux.org Git - packages/eio.git/blob - eio.spec
- x32 rebuild
[packages/eio.git] / eio.spec
1 # NOTE: for versions >= 1.8 see efl.spec
2 # TODO
3 # - -devel conflicts with libeio-devel
4 #       file /usr/lib64/libeio.la from install of eio-devel-0.1.0.65643-1.x86_64 conflicts with file from package libeio-devel-1.0-1.x86_64
5 #       file /usr/lib64/libeio.so from install of eio-devel-0.1.0.65643-1.x86_64 conflicts with file from package libeio-devel-1.0-1.x86_64
6 #
7 # Conditional build:
8 %bcond_without  static_libs     # don't build static libraries
9 #
10 %define         ecore_ver       1.7.10
11 %define         eet_ver         1.7.10
12 %define         eina_ver        1.7.10
13 Summary:        Enlightenment Input Output Library
14 Summary(pl.UTF-8):      Enlightenment Input Output - biblioteka wejścia/wyjścia z projektu Enlightenment
15 Name:           eio
16 Version:        1.7.10
17 Release:        2
18 License:        LGPL v2.1+
19 Group:          Libraries
20 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  7c36b8e98ba06ecd2ab6c67768601944
22 URL:            http://trac.enlightenment.org/e/wiki/Eio
23 BuildRequires:  ecore-devel >= %{ecore_ver}
24 BuildRequires:  eet-devel >= %{eet_ver}
25 BuildRequires:  eina-devel >= %{eina_ver}
26 BuildRequires:  pkgconfig >= 1:0.22
27 Requires:       ecore >= %{ecore_ver}
28 Requires:       eet >= %{eet_ver}
29 Requires:       eina >= %{eina_ver}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This library is intended to provide non blocking I/O by using thread
34 for all operation that may block. It depends only on eina and ecore
35 right now. It should integrate all the features/functions of
36 Ecore_File that could block.
37
38 %description -l pl.UTF-8
39 Ta biblioteka na za zadanie zapewniać nieblokujące operacje we/wy
40 poprzez użycie wątków dla wszystkich operacji, które mogę być
41 blokujące. Na razie wymaga tylko bibliotek eina i ecore. Powinna
42 zawierać wszystkie funkcje Ecore_File, które mogą być blokujące.
43
44 %package devel
45 Summary:        Header files for Eio library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Eio
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       ecore-devel >= %{ecore_ver}
50 Requires:       eet-devel >= %{eet_ver}
51 Requires:       eina-devel >= %{eina_ver}
52 Conflicts:      libeio-devel
53
54 %description devel
55 Header files for Eio library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki Eio.
59
60 %package static
61 Summary:        Static Eio library
62 Summary(pl.UTF-8):      Statyczna biblioteka Eio
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static Eio library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka Eio.
71
72 %prep
73 %setup -q
74
75 %build
76 %configure \
77         --disable-silent-rules \
78         %{!?with_static_libs:--disable-static}
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS README
96 %attr(755,root,root) %{_libdir}/libeio.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libeio.so.1
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libeio.so
102 %{_libdir}/libeio.la
103 %{_includedir}/eio-1
104 %{_pkgconfigdir}/eio.pc
105
106 %if %{with static_libs}
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libeio.a
110 %endif
This page took 0.080555 seconds and 3 git commands to generate.