]> git.pld-linux.org Git - packages/eina.git/blob - eina.spec
- updated to 1.0.0-alpha
[packages/eina.git] / eina.spec
1 #
2 # Conditional build:
3 %bcond_without  mmx             # without MMX and MMX2
4 %bcond_without  sse             # without SSE
5 %bcond_without  altivec         # without altivec
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
9 %undefine       with_mmx
10 %endif
11 %ifnarch i686 pentium3 pentium4 athlon %{x8664}
12 %undefine       with_sse
13 %endif
14 %ifnarch ppc
15 %undefine       with_altivec
16 %endif
17
18 Summary:        Data types library (list, hash, etc.)
19 Summary(pl.UTF-8):      Bilblioteka struktur danych (lista, hasz, itp.)
20 Name:           eina
21 %define subver  alpha
22 Version:        1.0.0
23 Release:        0.%{subver}.1
24 License:        LGPL v2.1
25 Group:          Libraries
26 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}-%{subver}.tar.bz2
27 # Source0-md5:  d417ca58a3b919257b23e5bdd57dfe1b
28 URL:            http://trac.enlightenment.org/e/wiki/Eina
29 BuildRequires:  pkgconfig
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Data types library (list, hash, etc.)
34
35 %description -l pl.UTF-8
36 Bilblioteka struktur danych (lista, hasz, itp.).
37
38 %package devel
39 Summary:        Eina header files
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Eina
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for Eina.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki Eina.
49
50 %package static
51 Summary:        Static Eina library
52 Summary(pl.UTF-8):      Statyczna biblioteka Eina
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static Eina library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka Eina.
61
62 %prep
63 %setup -q -n %{name}-%{version}-%{subver}
64
65 %build
66 %configure \
67         --disable-silent-rules \
68         %{?with_static_libs:--enable-static} \
69 %if %{with mmx}
70         --enable-cpu-mmx        \
71 %else
72         --disable-cpu-mmx       \
73 %endif
74 %if %{with sse}
75         --enable-cpu-sse        \
76 %else
77         --disable-cpu-sse       \
78 %endif
79 %if %{with altivec}
80         --enable-cpu-altivec    \
81 %else
82         --disable-cpu-altivec   \
83 %endif
84
85 %{__make} V=1
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS README
102 %attr(755,root,root) %{_libdir}/libeina.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libeina.so.1
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libeina.so
108 %{_libdir}/libeina.la
109 %{_includedir}/eina-1
110 %{_pkgconfigdir}/eina.pc
111
112 %if %{with static_libs}
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libeina.a
116 %endif
This page took 0.049427 seconds and 3 git commands to generate.