]> git.pld-linux.org Git - packages/eina.git/blob - eina.spec
- release 2 (by relup.sh)
[packages/eina.git] / eina.spec
1 # NOTE: for versions >= 1.8 see efl.spec
2 #
3 # Conditional build:
4 %bcond_without  mmx             # without MMX and MMX2
5 %bcond_without  sse             # without SSE
6 %bcond_without  sse2            # without SSE2
7 %bcond_without  altivec         # without altivec
8 %bcond_without  static_libs     # don't build static library
9 #
10 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
11 %undefine       with_mmx
12 %endif
13 %ifnarch i686 pentium3 pentium4 athlon %{x8664}
14 %undefine       with_sse
15 %endif
16 %ifnarch pentium4 %{x8664}
17 %undefine       with_sse2
18 %endif
19 %ifnarch ppc
20 %undefine       with_altivec
21 %endif
22
23 Summary:        Data types library (list, hash, etc.)
24 Summary(pl.UTF-8):      Biblioteka struktur danych (lista, hasz, itp.)
25 Name:           eina
26 Version:        1.7.10
27 Release:        2
28 License:        LGPL v2.1+
29 Group:          Libraries
30 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
31 # Source0-md5:  60064b8ee520ccf106641e87ff24e9da
32 URL:            http://trac.enlightenment.org/e/wiki/Eina
33 BuildRequires:  pkgconfig >= 1:0.22
34 # ememoa-devel >= 0.0.26
35 # escape (for ps3 platform)
36 # evil >= 1.7.9 (for win32 platform)
37 # exotic (for ??? platforms)
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Data types library (list, hash, etc.)
42
43 %description -l pl.UTF-8
44 Bilblioteka struktur danych (lista, hasz, itp.).
45
46 %package devel
47 Summary:        Eina header files
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Eina
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for Eina.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki Eina.
57
58 %package static
59 Summary:        Static Eina library
60 Summary(pl.UTF-8):      Statyczna biblioteka Eina
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static Eina library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka Eina.
69
70 %prep
71 %setup -q
72
73 %build
74 %configure \
75         --disable-silent-rules \
76         %{?with_static_libs:--enable-static} \
77         --enable-cpu-mmx%{!?with_mmx:=no} \
78         --enable-cpu-sse%{!?with_sse:=no} \
79         --enable-cpu-sse2%{!?with_sse2:=no} \
80         --enable-cpu-altivec%{!?with_altivec:=no}
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog NEWS README
99 %attr(755,root,root) %{_libdir}/libeina.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libeina.so.1
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libeina.so
105 %{_libdir}/libeina.la
106 %{_includedir}/eina-1
107 %{_pkgconfigdir}/eina.pc
108
109 %if %{with static_libs}
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libeina.a
113 %endif
This page took 0.074912 seconds and 3 git commands to generate.