]> git.pld-linux.org Git - packages/efreet.git/blob - efreet.spec
- LATEST snapshot
[packages/efreet.git] / efreet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       0.9.9.49898
6 %define         svn             -ver-svn-06
7
8 Summary:        freedesktop.org standards implementation for the EFL
9 Summary(pl.UTF-8):      Implementacja standardów freedesktop.org dla EFL
10 Name:           efreet
11 Version:        0.5.0.49898
12 Release:        0.1
13 License:        LGPL v2.1
14 Group:          X11/Libraries
15 Source0:        http://download.enlightenment.org/snapshots/LATEST/%{name}-%{version}.tar.bz2
16 # Source0-md5:  28a45a199332ff1183c9d8b352286b1e
17 URL:            http://enlightenment.org/p.php?p=about/libs/efreet
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake >= 1.6
20 # ecore-file; ecore-desktop for tests
21 BuildRequires:  ecore-devel >= %{ecore_ver}
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  sed >= 4.0
25 Requires:       ecore-file >= %{ecore_ver}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Efreet is an implementation of the following specifications from
30 freedesktop.org:
31  - Base Directory - Locations for system and user specific desktop
32    configuration files,
33  - Desktop Entries - The metadata associated with the applications
34    installed on a system,
35  - Application Menus - The arrangement of available applications into
36    a hierarchical menu,
37  - Icon Themes - A means of associating icons with various objects on
38    the desktop in a themable fashion.
39
40 By following these specifications, Enlightenment 0.17 uses the same
41 format for describing application launchers, menus and icon themes as
42 the GNOME, KDE and XFCE Desktop Environments. A system must only
43 provide a single set of this data for use with any of these desktops.
44
45 %description -l pl.UTF-8
46 Efreet to implementacja następujących specyfikacji z freedesktop.org:
47  - Base Directory - położenie plików konfiguracyjnych środowiska dla
48    systemu i użytkownika,
49  - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
50    systemie,
51  - Application Menus - uporządkowanie dostępnych aplikacji w menu
52    hierarchiczne,
53  - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
54    w sposób pozwalający na ustawianie motywów.
55
56 %package devel
57 Summary:        Efreet header files
58 Summary(pl.UTF-8):      Pliki nagłówkowe Efreet
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 # ecore-file
62 BuildRequires:  ecore-devel >= %{ecore_ver}
63
64 %description devel
65 Header files for Efreet.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe Efreet.
69
70 %package static
71 Summary:        Static Efreet library
72 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static Efreet library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka Efreet.
81
82 %prep
83 %setup -q
84
85 sed -i -e 's/-g -O0//' src/lib/Makefile.am
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         %{!?with_static_libs:--disable-static}
95 %{__make} V=1
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # just tests
104 rm -f $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
105 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/test
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS COPYING README TODO
116 %attr(755,root,root) %{_libdir}/libefreet%{svn}.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libefreet%{svn}.so.0
118 %attr(755,root,root) %{_libdir}/libefreet_mime%{svn}.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libefreet_mime%{svn}.so.0
120 %attr(755,root,root) %{_libdir}/libefreet_trash%{svn}.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libefreet_trash%{svn}.so.0
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libefreet.so
126 %attr(755,root,root) %{_libdir}/libefreet_mime.so
127 %attr(755,root,root) %{_libdir}/libefreet_trash.so
128 %{_libdir}/libefreet.la
129 %{_libdir}/libefreet_mime.la
130 %{_libdir}/libefreet_trash.la
131 %{_includedir}/efreet
132 %{_pkgconfigdir}/efreet.pc
133 %{_pkgconfigdir}/efreet-mime.pc
134 %{_pkgconfigdir}/efreet-trash.pc
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libefreet.a
140 %{_libdir}/libefreet_mime.a
141 %{_libdir}/libefreet_trash.a
142 %endif
This page took 0.035139 seconds and 4 git commands to generate.