]> git.pld-linux.org Git - packages/efreet.git/blob - efreet.spec
- up to the snapshot 0.5.0.49898
[packages/efreet.git] / efreet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       0.9.9.49898
6 %define         snapdate        2010-06-27
7 %define         svn             -ver-svn-06
8
9 Summary:        freedesktop.org standards implementation for the EFL
10 Summary(pl.UTF-8):      Implementacja standardów freedesktop.org dla EFL
11 Name:           efreet
12 Version:        0.5.0.49898
13 Release:        0.1
14 License:        LGPL v2.1
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/snapshots/%{snapdate}/%{name}-%{version}.tar.bz2
17 # Source0-md5:  28a45a199332ff1183c9d8b352286b1e
18 URL:            http://enlightenment.org/p.php?p=about/libs/efreet
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 # ecore-file; ecore-desktop for tests
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig
25 BuildRequires:  sed >= 4.0
26 Requires:       ecore-file >= %{ecore_ver}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Efreet is an implementation of the following specifications from
31 freedesktop.org:
32  - Base Directory - Locations for system and user specific desktop
33    configuration files,
34  - Desktop Entries - The metadata associated with the applications
35    installed on a system,
36  - Application Menus - The arrangement of available applications into
37    a hierarchical menu,
38  - Icon Themes - A means of associating icons with various objects on
39    the desktop in a themable fashion.
40
41 By following these specifications, Enlightenment 0.17 uses the same
42 format for describing application launchers, menus and icon themes as
43 the GNOME, KDE and XFCE Desktop Environments. A system must only
44 provide a single set of this data for use with any of these desktops.
45
46 %description -l pl.UTF-8
47 Efreet to implementacja następujących specyfikacji z freedesktop.org:
48  - Base Directory - położenie plików konfiguracyjnych środowiska dla
49    systemu i użytkownika,
50  - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
51    systemie,
52  - Application Menus - uporządkowanie dostępnych aplikacji w menu
53    hierarchiczne,
54  - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
55    w sposób pozwalający na ustawianie motywów.
56
57 %package devel
58 Summary:        Efreet header files
59 Summary(pl.UTF-8):      Pliki nagłówkowe Efreet
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 # ecore-file
63 BuildRequires:  ecore-devel >= %{ecore_ver}
64
65 %description devel
66 Header files for Efreet.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe Efreet.
70
71 %package static
72 Summary:        Static Efreet library
73 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static Efreet library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka Efreet.
82
83 %prep
84 %setup -q
85
86 sed -i -e 's/-g -O0//' src/lib/Makefile.am
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         %{!?with_static_libs:--disable-static}
96 %{__make} V=1
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 # just tests
105 rm -f $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
106 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/test
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS COPYING README TODO
117 %attr(755,root,root) %{_libdir}/libefreet%{svn}.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libefreet%{svn}.so.0
119 %attr(755,root,root) %{_libdir}/libefreet_mime%{svn}.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libefreet_mime%{svn}.so.0
121 %attr(755,root,root) %{_libdir}/libefreet_trash%{svn}.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libefreet_trash%{svn}.so.0
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libefreet.so
127 %attr(755,root,root) %{_libdir}/libefreet_mime.so
128 %attr(755,root,root) %{_libdir}/libefreet_trash.so
129 %{_libdir}/libefreet.la
130 %{_libdir}/libefreet_mime.la
131 %{_libdir}/libefreet_trash.la
132 %{_includedir}/efreet
133 %{_pkgconfigdir}/efreet.pc
134 %{_pkgconfigdir}/efreet-mime.pc
135 %{_pkgconfigdir}/efreet-trash.pc
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libefreet.a
141 %{_libdir}/libefreet_mime.a
142 %{_libdir}/libefreet_trash.a
143 %endif
This page took 0.045344 seconds and 4 git commands to generate.