]> git.pld-linux.org Git - packages/efreet.git/blob - efreet.spec
- updated to 1.0.1
[packages/efreet.git] / efreet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.0.0
6 %define         eet_ver         1.4.0
7
8 Summary:        freedesktop.org standards implementation for the EFL
9 Summary(pl.UTF-8):      Implementacja standardów freedesktop.org dla EFL
10 Name:           efreet
11 Version:        1.0.1
12 Release:        1
13 License:        BSD
14 Group:          X11/Libraries
15 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
16 # Source0-md5:  f9f6b4767faf7df9dbc87c97a99cc000
17 URL:            http://trac.enlightenment.org/e/wiki/Efreet
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake >= 1.6
20 BuildRequires:  ecore-devel >= %{ecore_ver}
21 BuildRequires:  ecore-file-devel >= %{ecore_ver}
22 BuildRequires:  eet-devel >= %{eet_ver}
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig >= 1:0.22
25 Requires:       eet >= %{eet_ver}
26 Requires:       ecore >= %{ecore_ver}
27 Requires:       ecore-file >= %{ecore_ver}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Efreet is an implementation of the following specifications from
32 freedesktop.org:
33  - Base Directory - Locations for system and user specific desktop
34    configuration files,
35  - Desktop Entries - The metadata associated with the applications
36    installed on a system,
37  - Application Menus - The arrangement of available applications into
38    a hierarchical menu,
39  - Icon Themes - A means of associating icons with various objects on
40    the desktop in a themable fashion.
41
42 By following these specifications, Enlightenment 0.17 uses the same
43 format for describing application launchers, menus and icon themes as
44 the GNOME, KDE and XFCE Desktop Environments. A system must only
45 provide a single set of this data for use with any of these desktops.
46
47 %description -l pl.UTF-8
48 Efreet to implementacja następujących specyfikacji z freedesktop.org:
49  - Base Directory - położenie plików konfiguracyjnych środowiska dla
50    systemu i użytkownika,
51  - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
52    systemie,
53  - Application Menus - uporządkowanie dostępnych aplikacji w menu
54    hierarchiczne,
55  - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
56    w sposób pozwalający na ustawianie motywów.
57
58 %package devel
59 Summary:        Efreet header files
60 Summary(pl.UTF-8):      Pliki nagłówkowe Efreet
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       ecore-devel >= %{ecore_ver}
64 Requires:       ecore-file-devel >= %{ecore_ver}
65 Requires:       eet-devel >= %{eet_ver}
66
67 %description devel
68 Header files for Efreet.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe Efreet.
72
73 %package static
74 Summary:        Static Efreet library
75 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static Efreet library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka Efreet.
84
85 %prep
86 %setup -q
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --disable-silent-rules \
96         %{!?with_static_libs:--disable-static}
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 # just tests
106 %{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
107 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS COPYING ChangeLog README TODO
118 %attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
120 %attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
122 %attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
124 %dir %{_libdir}/efreet
125 %attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libefreet.so
130 %attr(755,root,root) %{_libdir}/libefreet_mime.so
131 %attr(755,root,root) %{_libdir}/libefreet_trash.so
132 %{_libdir}/libefreet.la
133 %{_libdir}/libefreet_mime.la
134 %{_libdir}/libefreet_trash.la
135 %{_includedir}/efreet-1
136 %{_pkgconfigdir}/efreet.pc
137 %{_pkgconfigdir}/efreet-mime.pc
138 %{_pkgconfigdir}/efreet-trash.pc
139
140 %if %{with static_libs}
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libefreet.a
144 %{_libdir}/libefreet_mime.a
145 %{_libdir}/libefreet_trash.a
146 %endif
This page took 0.101107 seconds and 4 git commands to generate.