]> git.pld-linux.org Git - packages/efreet.git/blob - efreet.spec
- updated to 1.7.5
[packages/efreet.git] / efreet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.7.5
6 %define         eina_ver        1.7.5
7 %define         eet_ver         1.7.5
8
9 Summary:        freedesktop.org standards implementation for the EFL
10 Summary(pl.UTF-8):      Implementacja standardów freedesktop.org dla EFL
11 Name:           efreet
12 Version:        1.7.5
13 Release:        1
14 License:        BSD
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  d21e59631022d6fbdfa0e19b6b2ff93a
18 Patch0:         %{name}-am.patch
19 URL:            http://trac.enlightenment.org/e/wiki/Efreet
20 BuildRequires:  autoconf >= 2.52
21 BuildRequires:  automake >= 1.6
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  ecore-file-devel >= %{ecore_ver}
24 BuildRequires:  eet-devel >= %{eet_ver}
25 BuildRequires:  eina-devel >= %{eina_ver}
26 BuildRequires:  gettext-devel >= 0.17
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig >= 1:0.22
29 Requires:       ecore >= %{ecore_ver}
30 Requires:       ecore-file >= %{ecore_ver}
31 Requires:       eet >= %{eet_ver}
32 Requires:       eina >= %{eina_ver}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Efreet is an implementation of the following specifications from
37 freedesktop.org:
38  - Base Directory - Locations for system and user specific desktop
39    configuration files,
40  - Desktop Entries - The metadata associated with the applications
41    installed on a system,
42  - Application Menus - The arrangement of available applications into
43    a hierarchical menu,
44  - Icon Themes - A means of associating icons with various objects on
45    the desktop in a themable fashion.
46
47 By following these specifications, Enlightenment 0.17 uses the same
48 format for describing application launchers, menus and icon themes as
49 the GNOME, KDE and XFCE Desktop Environments. A system must only
50 provide a single set of this data for use with any of these desktops.
51
52 %description -l pl.UTF-8
53 Efreet to implementacja następujących specyfikacji z freedesktop.org:
54  - Base Directory - położenie plików konfiguracyjnych środowiska dla
55    systemu i użytkownika,
56  - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
57    systemie,
58  - Application Menus - uporządkowanie dostępnych aplikacji w menu
59    hierarchiczne,
60  - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
61    w sposób pozwalający na ustawianie motywów.
62
63 %package devel
64 Summary:        Efreet header files
65 Summary(pl.UTF-8):      Pliki nagłówkowe Efreet
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       ecore-devel >= %{ecore_ver}
69 Requires:       ecore-file-devel >= %{ecore_ver}
70 Requires:       eet-devel >= %{eet_ver}
71 Requires:       eina-devel >= %{eina_ver}
72
73 %description devel
74 Header files for Efreet.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe Efreet.
78
79 %package static
80 Summary:        Static Efreet library
81 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static Efreet library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka Efreet.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 %{__gettextize}
97 %{__libtoolize}
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --disable-silent-rules \
104         %{!?with_static_libs:--disable-static}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # just tests
114 %{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
115 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %doc AUTHORS COPYING ChangeLog NEWS README TODO
128 %attr(755,root,root) %{_bindir}/efreet_icon_cache_dump
129 %attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
131 %attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
133 %attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
135 %dir %{_libdir}/efreet
136 %attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
137 %attr(755,root,root) %{_libdir}/efreet/efreet_icon_cache_create
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libefreet.so
142 %attr(755,root,root) %{_libdir}/libefreet_mime.so
143 %attr(755,root,root) %{_libdir}/libefreet_trash.so
144 %{_libdir}/libefreet.la
145 %{_libdir}/libefreet_mime.la
146 %{_libdir}/libefreet_trash.la
147 %{_includedir}/efreet-1
148 %{_pkgconfigdir}/efreet.pc
149 %{_pkgconfigdir}/efreet-mime.pc
150 %{_pkgconfigdir}/efreet-trash.pc
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libefreet.a
156 %{_libdir}/libefreet_mime.a
157 %{_libdir}/libefreet_trash.a
158 %endif
This page took 0.064534 seconds and 4 git commands to generate.