]> git.pld-linux.org Git - packages/efreet.git/blob - efreet.spec
up to 0.5.0.043
[packages/efreet.git] / efreet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       0.9.9.043
6
7 Summary:        freedesktop.org standards implementation for the EFL
8 Summary(pl.UTF-8):      Implementacja standardów freedesktop.org dla EFL
9 Name:           efreet
10 Version:        0.5.0.043
11 Release:        1
12 License:        BSD
13 Group:          X11/Libraries
14 Source0:        http://download.enlightenment.org/snapshots/2008-05-19/%{name}-%{version}.tar.bz2
15 # Source0-md5:  430493b0b3ac8d2221d94c653cf75163
16 URL:            http://enlightenment.org/p.php?p=about/libs/efreet
17 BuildRequires:  autoconf
18 BuildRequires:  automake >= 1.4
19 # ecore-file; ecore-desktop for tests
20 BuildRequires:  ecore-devel >= %{ecore_ver}
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  sed >= 4.0
24 Requires:       ecore-file >= %{ecore_ver}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Efreet is an implementation of the following specifications from
29 freedesktop.org:
30  - Base Directory - Locations for system and user specific desktop
31    configuration files,
32  - Desktop Entries - The metadata associated with the applications
33    installed on a system,
34  - Application Menus - The arrangement of available applications into
35    a hierarchical menu,
36  - Icon Themes - A means of associating icons with various objects on
37    the desktop in a themable fashion.
38
39 By following these specifications, Enlightenment 0.17 uses the same
40 format for describing application launchers, menus and icon themes as
41 the GNOME, KDE and XFCE Desktop Environments. A system must only
42 provide a single set of this data for use with any of these desktops.
43
44 %description -l pl.UTF-8
45 Efreet to implementacja następujących specyfikacji z freedesktop.org:
46  - Base Directory - położenie plików konfiguracyjnych środowiska dla
47    systemu i użytkownika,
48  - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
49    systemie,
50  - Application Menus - uporządkowanie dostępnych aplikacji w menu
51    hierarchiczne,
52  - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
53    w sposób pozwalający na ustawianie motywów.
54
55 %package devel
56 Summary:        Efreet header files
57 Summary(pl.UTF-8):      Pliki nagłówkowe Efreet
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 # ecore-file
61 BuildRequires:  ecore-devel >= %{ecore_ver}
62
63 %description devel
64 Header files for Efreet.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe Efreet.
68
69 %package static
70 Summary:        Static Efreet library
71 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static Efreet library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka Efreet.
80
81 %prep
82 %setup -q
83
84 sed -i -e 's/-g -O0//' src/lib/Makefile.am
85
86 %build
87 %{__libtoolize}
88 %{__aclocal} -I m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         %{!?with_static_libs:--disable-static}
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # just tests
103 rm -f $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
104 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/test
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING README TODO
115 %attr(755,root,root) %{_libdir}/libefreet*.so.*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libefreet*.so
120 %{_libdir}/libefreet*.la
121 %{_includedir}/efreet
122 %{_pkgconfigdir}/efreet*.pc
123
124 %if %{with static_libs}
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/libefreet*.a
128 %endif
This page took 0.119588 seconds and 4 git commands to generate.