]> git.pld-linux.org Git - packages/efreet.git/blob - efreet.spec
- really updated to 1.0.0.beta3
[packages/efreet.git] / efreet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.0.0
6 %define         eet_ver         1.4.0
7
8 Summary:        freedesktop.org standards implementation for the EFL
9 Summary(pl.UTF-8):      Implementacja standardów freedesktop.org dla EFL
10 Name:           efreet
11 %define subver  beta3
12 Version:        1.0.0
13 Release:        0.%{subver}.1
14 License:        BSD
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
17 # Source0-md5:  2e79009e049613dfbfe3801e264937ca
18 URL:            http://enlightenment.org/p.php?p=about/libs/efreet
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  ecore-devel >= %{ecore_ver}
22 BuildRequires:  ecore-file-devel >= %{ecore_ver}
23 BuildRequires:  eet-devel >= %{eet_ver}
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig >= 1:0.22
26 Requires:       eet >= %{eet_ver}
27 Requires:       ecore >= %{ecore_ver}
28 Requires:       ecore-file >= %{ecore_ver}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Efreet is an implementation of the following specifications from
33 freedesktop.org:
34  - Base Directory - Locations for system and user specific desktop
35    configuration files,
36  - Desktop Entries - The metadata associated with the applications
37    installed on a system,
38  - Application Menus - The arrangement of available applications into
39    a hierarchical menu,
40  - Icon Themes - A means of associating icons with various objects on
41    the desktop in a themable fashion.
42
43 By following these specifications, Enlightenment 0.17 uses the same
44 format for describing application launchers, menus and icon themes as
45 the GNOME, KDE and XFCE Desktop Environments. A system must only
46 provide a single set of this data for use with any of these desktops.
47
48 %description -l pl.UTF-8
49 Efreet to implementacja następujących specyfikacji z freedesktop.org:
50  - Base Directory - położenie plików konfiguracyjnych środowiska dla
51    systemu i użytkownika,
52  - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
53    systemie,
54  - Application Menus - uporządkowanie dostępnych aplikacji w menu
55    hierarchiczne,
56  - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
57    w sposób pozwalający na ustawianie motywów.
58
59 %package devel
60 Summary:        Efreet header files
61 Summary(pl.UTF-8):      Pliki nagłówkowe Efreet
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       ecore-devel >= %{ecore_ver}
65 Requires:       ecore-file-devel >= %{ecore_ver}
66 Requires:       eet-devel >= %{eet_ver}
67
68 %description devel
69 Header files for Efreet.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe Efreet.
73
74 %package static
75 Summary:        Static Efreet library
76 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static Efreet library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka Efreet.
85
86 %prep
87 %setup -q -n %{name}-%{version}.%{subver}
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --disable-silent-rules \
97         %{!?with_static_libs:--disable-static}
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # just tests
107 %{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
108 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS COPYING README TODO
119 %attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
121 %attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
123 %attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
125 %dir %{_libdir}/efreet
126 %attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libefreet.so
131 %attr(755,root,root) %{_libdir}/libefreet_mime.so
132 %attr(755,root,root) %{_libdir}/libefreet_trash.so
133 %{_libdir}/libefreet.la
134 %{_libdir}/libefreet_mime.la
135 %{_libdir}/libefreet_trash.la
136 %{_includedir}/efreet-1
137 %{_pkgconfigdir}/efreet.pc
138 %{_pkgconfigdir}/efreet-mime.pc
139 %{_pkgconfigdir}/efreet-trash.pc
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libefreet.a
145 %{_libdir}/libefreet_mime.a
146 %{_libdir}/libefreet_trash.a
147 %endif
This page took 0.066586 seconds and 4 git commands to generate.