]> git.pld-linux.org Git - packages/efreet.git/blob - efreet.spec
- updated to 1.1.0
[packages/efreet.git] / efreet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.1.0
6 %define         eina_ver        1.1.0
7 %define         eet_ver         1.5.0
8
9 Summary:        freedesktop.org standards implementation for the EFL
10 Summary(pl.UTF-8):      Implementacja standardów freedesktop.org dla EFL
11 Name:           efreet
12 Version:        1.1.0
13 Release:        1
14 License:        BSD
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  286b7d66ede62c87f4effef938c2ee7e
18 URL:            http://trac.enlightenment.org/e/wiki/Efreet
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  ecore-devel >= %{ecore_ver}
22 BuildRequires:  ecore-file-devel >= %{ecore_ver}
23 BuildRequires:  eet-devel >= %{eet_ver}
24 BuildRequires:  eina-devel >= %{eina_ver}
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig >= 1:0.22
27 Requires:       ecore >= %{ecore_ver}
28 Requires:       ecore-file >= %{ecore_ver}
29 Requires:       eet >= %{eet_ver}
30 Requires:       eina-devel >= %{eina_ver}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Efreet is an implementation of the following specifications from
35 freedesktop.org:
36  - Base Directory - Locations for system and user specific desktop
37    configuration files,
38  - Desktop Entries - The metadata associated with the applications
39    installed on a system,
40  - Application Menus - The arrangement of available applications into
41    a hierarchical menu,
42  - Icon Themes - A means of associating icons with various objects on
43    the desktop in a themable fashion.
44
45 By following these specifications, Enlightenment 0.17 uses the same
46 format for describing application launchers, menus and icon themes as
47 the GNOME, KDE and XFCE Desktop Environments. A system must only
48 provide a single set of this data for use with any of these desktops.
49
50 %description -l pl.UTF-8
51 Efreet to implementacja następujących specyfikacji z freedesktop.org:
52  - Base Directory - położenie plików konfiguracyjnych środowiska dla
53    systemu i użytkownika,
54  - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
55    systemie,
56  - Application Menus - uporządkowanie dostępnych aplikacji w menu
57    hierarchiczne,
58  - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
59    w sposób pozwalający na ustawianie motywów.
60
61 %package devel
62 Summary:        Efreet header files
63 Summary(pl.UTF-8):      Pliki nagłówkowe Efreet
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       ecore-devel >= %{ecore_ver}
67 Requires:       ecore-file-devel >= %{ecore_ver}
68 Requires:       eet-devel >= %{eet_ver}
69 Requires:       eina-devel >= %{eina_ver}
70
71 %description devel
72 Header files for Efreet.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe Efreet.
76
77 %package static
78 Summary:        Static Efreet library
79 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static Efreet library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka Efreet.
88
89 %prep
90 %setup -q
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         --disable-silent-rules \
100         %{!?with_static_libs:--disable-static}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 # just tests
110 %{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
111 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS COPYING ChangeLog NEWS README TODO
122 %attr(755,root,root) %{_bindir}/efreet_icon_cache_dump
123 %attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
125 %attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
127 %attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
129 %dir %{_libdir}/efreet
130 %attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
131 %attr(755,root,root) %{_libdir}/efreet/efreet_icon_cache_create
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libefreet.so
136 %attr(755,root,root) %{_libdir}/libefreet_mime.so
137 %attr(755,root,root) %{_libdir}/libefreet_trash.so
138 %{_libdir}/libefreet.la
139 %{_libdir}/libefreet_mime.la
140 %{_libdir}/libefreet_trash.la
141 %{_includedir}/efreet-1
142 %{_pkgconfigdir}/efreet.pc
143 %{_pkgconfigdir}/efreet-mime.pc
144 %{_pkgconfigdir}/efreet-trash.pc
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libefreet.a
150 %{_libdir}/libefreet_mime.a
151 %{_libdir}/libefreet_trash.a
152 %endif
This page took 0.085115 seconds and 4 git commands to generate.