]> git.pld-linux.org Git - packages/efreet.git/blob - efreet.spec
- updated to 1.7.9
[packages/efreet.git] / efreet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.7.9
6 %define         eet_ver         1.7.9
7 %define         eina_ver        1.7.9
8
9 Summary:        freedesktop.org standards implementation for the EFL
10 Summary(pl.UTF-8):      Implementacja standardów freedesktop.org dla EFL
11 Name:           efreet
12 Version:        1.7.9
13 Release:        1
14 License:        BSD
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  9efa96905ad5ed613c0fb4fe74af84de
18 URL:            http://trac.enlightenment.org/e/wiki/Efreet
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  ecore-devel >= %{ecore_ver}
22 BuildRequires:  ecore-file-devel >= %{ecore_ver}
23 BuildRequires:  eet-devel >= %{eet_ver}
24 BuildRequires:  eina-devel >= %{eina_ver}
25 BuildRequires:  gettext-devel >= 0.17
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig >= 1:0.22
28 Requires:       ecore >= %{ecore_ver}
29 Requires:       ecore-file >= %{ecore_ver}
30 Requires:       eet >= %{eet_ver}
31 Requires:       eina >= %{eina_ver}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Efreet is an implementation of the following specifications from
36 freedesktop.org:
37  - Base Directory - Locations for system and user specific desktop
38    configuration files,
39  - Desktop Entries - The metadata associated with the applications
40    installed on a system,
41  - Application Menus - The arrangement of available applications into
42    a hierarchical menu,
43  - Icon Themes - A means of associating icons with various objects on
44    the desktop in a themable fashion.
45
46 By following these specifications, Enlightenment 0.17 uses the same
47 format for describing application launchers, menus and icon themes as
48 the GNOME, KDE and XFCE Desktop Environments. A system must only
49 provide a single set of this data for use with any of these desktops.
50
51 %description -l pl.UTF-8
52 Efreet to implementacja następujących specyfikacji z freedesktop.org:
53  - Base Directory - położenie plików konfiguracyjnych środowiska dla
54    systemu i użytkownika,
55  - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
56    systemie,
57  - Application Menus - uporządkowanie dostępnych aplikacji w menu
58    hierarchiczne,
59  - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
60    w sposób pozwalający na ustawianie motywów.
61
62 %package devel
63 Summary:        Efreet header files
64 Summary(pl.UTF-8):      Pliki nagłówkowe Efreet
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       ecore-devel >= %{ecore_ver}
68 Requires:       ecore-file-devel >= %{ecore_ver}
69 Requires:       eet-devel >= %{eet_ver}
70 Requires:       eina-devel >= %{eina_ver}
71
72 %description devel
73 Header files for Efreet.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe Efreet.
77
78 %package static
79 Summary:        Static Efreet library
80 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static Efreet library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka Efreet.
89
90 %prep
91 %setup -q
92
93 %build
94 %{__gettextize}
95 %{__libtoolize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --disable-silent-rules \
102         %{!?with_static_libs:--disable-static}
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 # just tests
112 %{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
113 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
114
115 %find_lang %{name}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS COPYING ChangeLog NEWS README TODO
126 %attr(755,root,root) %{_bindir}/efreet_icon_cache_dump
127 %attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
129 %attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
131 %attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
133 %dir %{_libdir}/efreet
134 %attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
135 %attr(755,root,root) %{_libdir}/efreet/efreet_icon_cache_create
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libefreet.so
140 %attr(755,root,root) %{_libdir}/libefreet_mime.so
141 %attr(755,root,root) %{_libdir}/libefreet_trash.so
142 %{_libdir}/libefreet.la
143 %{_libdir}/libefreet_mime.la
144 %{_libdir}/libefreet_trash.la
145 %{_includedir}/efreet-1
146 %{_pkgconfigdir}/efreet.pc
147 %{_pkgconfigdir}/efreet-mime.pc
148 %{_pkgconfigdir}/efreet-trash.pc
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libefreet.a
154 %{_libdir}/libefreet_mime.a
155 %{_libdir}/libefreet_trash.a
156 %endif
This page took 0.078366 seconds and 3 git commands to generate.