]> git.pld-linux.org Git - packages/efilinux.git/blob - efilinux.spec
- updated to 1.1
[packages/efilinux.git] / efilinux.spec
1 Summary:        UEFI bootloader
2 Summary(pl.UTF-8):      Bootloader UEFI
3 Name:           efilinux
4 Version:        1.1
5 Release:        1
6 License:        BSD
7 Group:          Applications/System
8 Source0:        https://www.kernel.org/pub/linux/utils/boot/efilinux/%{name}-%{version}.tar.xz
9 # Source0-md5:  2d3c46111cd661e65c912a7450cf40e3
10 BuildRequires:  gnu-efi
11 BuildRequires:  sed >= 4.0
12 BuildRequires:  tar >= 1:1.22
13 BuildRequires:  xz
14 ExclusiveArch:  %{ix86} %{x8664}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # not supported by gnu-efi toolchain
18 %define         _fortify_cflags %{nil}
19 %define         _ssp_cflags     %{nil}
20
21 %description
22 efilinux is a UEFI OS loader. It was created as a reference
23 implementation with the aim of being well documented and containing
24 well written source code.
25
26 %description -l pl.UTF-8
27 efilinux to bootloader systemów operacyjnych dla UEFI. Powstał jako
28 wzorcowa implementacja, której głównym celem jest dobra dokumentacja i
29 dobrze napisany kod źródłowy.
30
31 %prep
32 %setup -q
33
34 %{__sed} -i -e 's/^CFLAGS=/CFLAGS=$(OPTFLAGS) /' Makefile
35 # entry.c:457:6: error: 'cmdline' may be used uninitialized in this function [-Werror=uninitialized]
36 # entry.c:457:6: error: 'name' may be used uninitialized in this function [-Werror=uninitialized]
37 %{__sed} -i -e 's/-Werror//' Makefile
38
39 %build
40 %{__make} \
41         CC="%{__cc}" \
42         OPTFLAGS="%{rpmcflags}"
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 install -D efilinux.efi $RPM_BUILD_ROOT/boot/efi/efilinux.efi
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README
55 %dir /boot/efi
56 /boot/efi/efilinux.efi
This page took 0.11469 seconds and 3 git commands to generate.