]> git.pld-linux.org Git - packages/efi-boot-update.git/blob - efi-boot-update.spec
- disable debug packages
[packages/efi-boot-update.git] / efi-boot-update.spec
1 # $Revision: 1.81 $, $Date: 2012/04/20 10:52:52 $
2 Summary:        EFI bootloader updater
3 Summary(pl.UTF-8):      Skrypt do uaktualniania bootloaderów EFI
4 Name:           efi-boot-update
5 Version:        0.2
6 Release:        3
7 License:        GPL v2
8 Group:          Applications/System
9 Source0:        %{name}
10 Source1:        update.conf
11 Source2:        grub.conf
12 Source3:        grub-installed.conf
13 Source4:        kernel.conf
14 Source5:        kernel-old.conf
15 Source10:       README
16 Source11:       TODO
17 URL:            http://www.pld-linux.org/
18 BuildRequires:  help2man
19 Suggests:       efibootmgr
20 Suggests:       efi-shell-x64
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _debugsource_packages   0
24
25 %define         _sbindir /sbin
26
27 %description
28 Script to update EFI bootloaders.
29
30 %description -l pl.UTF-8
31 Skrypt do uaktualniania bootloaderów EFI.
32
33 %prep
34 %setup -qcT
35 cp %{SOURCE0} .
36 cp %{SOURCE10} %{SOURCE11} .
37
38 %build
39 chmod a+x %{name}
40 help2man --no-info ./%{name} > %{name}.8
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
45 install -d $RPM_BUILD_ROOT{/lib/efi/{ia32,x64},%{_sbindir},%{_mandir}/man8}
46
47 install %{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
48 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}.8
49 install %{SOURCE1} $RPM_BUILD_ROOT/etc/efi-boot
50 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT/etc/efi-boot/update.d
51 install %{SOURCE4} %{SOURCE5} $RPM_BUILD_ROOT/etc/efi-boot/update.d
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 # Most efi-boot-update-managed loaders will use kernel files
57 # even if the kernel itself is not built as EFI
58 %triggerin -- kernel
59 /sbin/efi-boot-update --auto || :
60 %triggerin -- kernel-longterm
61 /sbin/efi-boot-update --auto || :
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README TODO
66 %attr(755,root,root) %{_sbindir}/%{name}
67 %dir /etc/efi-boot
68 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.conf
69 %dir /etc/efi-boot/update.d
70 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/grub.conf
71 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/grub-installed.conf
72 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/kernel.conf
73 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/kernel-old.conf
74 %dir /lib/efi
75 %dir /lib/efi/ia32
76 %dir /lib/efi/x64
77 %{_mandir}/man8/%{name}.8*
This page took 0.124218 seconds and 4 git commands to generate.