]> git.pld-linux.org Git - packages/eet.git/blob - eet.spec
- 0.9.10.028
[packages/eet.git] / eet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Library for speedy data storage, retrieval, and compression
6 Summary(pl):    Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
7 Name:           eet
8 Version:        0.9.10.028
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz 
13 # Source0-md5:  01142c78613c2865a4f30523d99d89c6
14 URL:            http://enlightenment.org/Libraries/Eet/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libtool
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %undefine       __cxx
23
24 %description
25 Eet is a tiny library designed to write an arbitary set of chunks of
26 data to a file and optionally compress each chunk (very much like a
27 zip file) and allow fast random-access reading of the file later on.
28 It does not do zip as a zip itself has more complexity than is needed,
29 and it was much simpler to implement this once here.
30
31 It also can encode and decode data structures in memory, as well as
32 image data for saving to eet files or sending across the network to
33 other machines, or just writing to arbitary files on the system. All
34 data is encoded in a platform independant way and can be written and
35 read by any architecture.
36
37 %description -l pl
38 Eet to ma³a biblioteka zaprojektowana do zapisu dowolnego zbioru
39 porcji danych do pliku i opcjonalnej kompresji ka¿dej porcji (podobnie
40 do pliku zip) oraz umo¿liwienia pó¼niej szybkiego odczytu pliku ze
41 swobodnym dostêpem. Nie jest to zip, jako ¿e sam zip jest bardziej
42 z³o¿ony ni¿ trzeba, a by³o du¿o pro¶ciej zaimplementowaæ to tak, jak
43 jest.
44
45 Biblioteka mo¿e tak¿e kodowaæ i dekodowaæ struktury danych w pamiêci,
46 a tak¿e dane obrazów do zapisu do plików eet lub wysy³ania po sieci na
47 inne maszyny, lub po prostu zapisywania do dowolnych plików w
48 systemie. Wszystkie dane s± kodowane w sposób niezale¿ny od platformy
49 i mog± byæ zapisywane i odczytywane na dowolnej architekturze.
50
51 %package devel
52 Summary:        Header files for Eet library
53 Summary(pl):    Pliki nag³ówkowe biblioteki Eet
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       libjpeg-devel
57 Requires:       zlib-devel
58
59 %description devel
60 Header files for Eet library.
61
62 %description devel -l pl
63 Pliki nag³ówkowe biblioteki Eet.
64
65 %package static
66 Summary:        Static Eet library
67 Summary(pl):    Statyczna biblioteka Eet
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static Eet library.
73
74 %description static -l pl
75 Statyczna biblioteka Eet.
76
77 %prep
78 %setup -q
79
80 %build
81 %configure \
82         %{!?with_static_libs:--disable-static}
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
100 %attr(755,root,root) %{_bindir}/eet
101 %attr(755,root,root) %{_bindir}/eet_bench
102 %attr(755,root,root) %{_libdir}/libeet.so.*.*.*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_bindir}/eet-config
107 %attr(755,root,root) %{_libdir}/libeet.so
108 %{_libdir}/libeet.la
109 %{_pkgconfigdir}/eet.pc
110 %{_includedir}/Eet*
111
112 %if %{with static_libs}
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libeet.a
116 %endif
This page took 0.104793 seconds and 3 git commands to generate.