]> git.pld-linux.org Git - packages/eet.git/blob - eet.spec
- release 2 (by relup.sh)
[packages/eet.git] / eet.spec
1 # NOTE: for versions >= 1.8 see efl.spec
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define eina_ver        1.7.10
7 Summary:        Library for speedy data storage, retrieval, and compression
8 Summary(pl.UTF-8):      Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
9 Name:           eet
10 Version:        1.7.10
11 Release:        2
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
15 # Source0-md5:  396ccb7094518cb9ce6939e7d2c6ef8c
16 URL:            http://trac.enlightenment.org/e/wiki/Eet
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  eina-devel >= %{eina_ver}
20 BuildRequires:  gnutls-devel >= 1.7.6
21 BuildRequires:  libgcrypt-devel
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig >= 1:0.22
25 BuildRequires:  sed >= 4.0
26 BuildRequires:  zlib-devel
27 Requires:       eina >= %{eina_ver}
28 Requires:       gnutls >= 1.7.6
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Eet is a tiny library designed to write an arbitary set of chunks of
33 data to a file and optionally compress each chunk (very much like a
34 zip file) and allow fast random-access reading of the file later on.
35 It does not do zip as a zip itself has more complexity than is needed,
36 and it was much simpler to implement this once here.
37
38 It also can encode and decode data structures in memory, as well as
39 image data for saving to eet files or sending across the network to
40 other machines, or just writing to arbitary files on the system. All
41 data is encoded in a platform independant way and can be written and
42 read by any architecture.
43
44 %description -l pl.UTF-8
45 Eet to mała biblioteka zaprojektowana do zapisu dowolnego zbioru
46 porcji danych do pliku i opcjonalnej kompresji każdej porcji (podobnie
47 do pliku zip) oraz umożliwienia później szybkiego odczytu pliku ze
48 swobodnym dostępem. Nie jest to zip, jako że sam zip jest bardziej
49 złożony niż trzeba, a było dużo prościej zaimplementować to tak, jak
50 jest.
51
52 Biblioteka może także kodować i dekodować struktury danych w pamięci,
53 a także dane obrazów do zapisu do plików eet lub wysyłania po sieci na
54 inne maszyny, lub po prostu zapisywania do dowolnych plików w
55 systemie. Wszystkie dane są kodowane w sposób niezależny od platformy
56 i mogą być zapisywane i odczytywane na dowolnej architekturze.
57
58 %package devel
59 Summary:        Header files for Eet library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Eet
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       eina-devel >= %{eina_ver}
64 Requires:       gnutls-devel >= 1.7.6
65 Requires:       libgcrypt-devel
66 Requires:       libjpeg-devel
67 Requires:       zlib-devel
68
69 %description devel
70 Header files for Eet library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki Eet.
74
75 %package static
76 Summary:        Static Eet library
77 Summary(pl.UTF-8):      Statyczna biblioteka Eet
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static Eet library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka Eet.
86
87 %prep
88 %setup -q
89
90 %build
91 %{__libtoolize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         --disable-silent-rules \
98         %{!?with_static_libs:--disable-static}
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 install -d $RPM_BUILD_ROOT%{_examplesdir}
108 mv -f $RPM_BUILD_ROOT%{_datadir}/eet/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS COPYING NEWS README
119 %attr(755,root,root) %{_bindir}/eet
120 %attr(755,root,root) %{_libdir}/libeet.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libeet.so.1
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libeet.so
126 %{_libdir}/libeet.la
127 %{_includedir}/eet-1
128 %{_pkgconfigdir}/eet.pc
129 %{_examplesdir}/%{name}-%{version}
130
131 %if %{with static_libs}
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libeet.a
135 %endif
This page took 0.139672 seconds and 3 git commands to generate.