]> git.pld-linux.org Git - packages/eet.git/blob - eet.spec
- 1.4.0.beta2
[packages/eet.git] / eet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Library for speedy data storage, retrieval, and compression
6 Summary(pl.UTF-8):      Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
7 Name:           eet
8 %define subver  beta2
9 Version:        1.4.0
10 Release:        0.%{subver}.1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
14 # Source0-md5:  ebf2a65bd46df797e8dd0256913d22b7
15 URL:            http://enlightenment.org/p.php?p=about/efl/eet
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1.6
18 BuildRequires:  eina-devel >= 1.0.0
19 BuildRequires:  gnutls-devel >= 1.7.6
20 BuildRequires:  libgcrypt-devel
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig >= 1:0.22
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  zlib-devel
26 Requires:       gnutls >= 1.7.6
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Eet is a tiny library designed to write an arbitary set of chunks of
31 data to a file and optionally compress each chunk (very much like a
32 zip file) and allow fast random-access reading of the file later on.
33 It does not do zip as a zip itself has more complexity than is needed,
34 and it was much simpler to implement this once here.
35
36 It also can encode and decode data structures in memory, as well as
37 image data for saving to eet files or sending across the network to
38 other machines, or just writing to arbitary files on the system. All
39 data is encoded in a platform independant way and can be written and
40 read by any architecture.
41
42 %description -l pl.UTF-8
43 Eet to mała biblioteka zaprojektowana do zapisu dowolnego zbioru
44 porcji danych do pliku i opcjonalnej kompresji każdej porcji (podobnie
45 do pliku zip) oraz umożliwienia później szybkiego odczytu pliku ze
46 swobodnym dostępem. Nie jest to zip, jako że sam zip jest bardziej
47 złożony niż trzeba, a było dużo prościej zaimplementować to tak, jak
48 jest.
49
50 Biblioteka może także kodować i dekodować struktury danych w pamięci,
51 a także dane obrazów do zapisu do plików eet lub wysyłania po sieci na
52 inne maszyny, lub po prostu zapisywania do dowolnych plików w
53 systemie. Wszystkie dane są kodowane w sposób niezależny od platformy
54 i mogą być zapisywane i odczytywane na dowolnej architekturze.
55
56 %package devel
57 Summary:        Header files for Eet library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Eet
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       eina-devel >= 1.0.0
62 Requires:       gnutls-devel >= 1.7.6
63 Requires:       libgcrypt-devel
64 Requires:       libjpeg-devel
65 Requires:       zlib-devel
66
67 %description devel
68 Header files for Eet library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki Eet.
72
73 %package static
74 Summary:        Static Eet library
75 Summary(pl.UTF-8):      Statyczna biblioteka Eet
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static Eet library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka Eet.
84
85 %prep
86 %setup -q -n %{name}-%{version}.%{subver}
87
88 %{__sed} -i -e 's/eina-0/eina/' configure.ac
89
90 %build
91 %{__libtoolize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         --disable-silent-rules \
98         %{!?with_static_libs:--disable-static}
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS COPYING NEWS README 
116 %attr(755,root,root) %{_bindir}/eet
117 %attr(755,root,root) %{_libdir}/libeet.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libeet.so.1
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libeet.so
123 %{_libdir}/libeet.la
124 %{_pkgconfigdir}/eet.pc
125 %{_includedir}/eet-1/Eet.h
126
127 %if %{with static_libs}
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libeet.a
131 %endif
This page took 0.070394 seconds and 3 git commands to generate.