]> git.pld-linux.org Git - packages/eet.git/blob - eet.spec
- rel 3; fix gnutls build
[packages/eet.git] / eet.spec
1 # NOTE: for versions >= 1.8 see efl.spec
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define eina_ver        1.7.10
7 Summary:        Library for speedy data storage, retrieval, and compression
8 Summary(pl.UTF-8):      Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
9 Name:           eet
10 Version:        1.7.10
11 Release:        3
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://download.enlightenment.org/att/releases/%{name}-%{version}.tar.bz2
15 # Source0-md5:  396ccb7094518cb9ce6939e7d2c6ef8c
16 Patch0:         gnutls.patch
17 URL:            http://trac.enlightenment.org/e/wiki/Eet
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake >= 1.6
20 BuildRequires:  eina-devel >= %{eina_ver}
21 BuildRequires:  gnutls-devel >= 1.7.6
22 BuildRequires:  libgcrypt-devel
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig >= 1:0.22
26 BuildRequires:  sed >= 4.0
27 BuildRequires:  zlib-devel
28 Requires:       eina >= %{eina_ver}
29 Requires:       gnutls >= 1.7.6
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Eet is a tiny library designed to write an arbitary set of chunks of
34 data to a file and optionally compress each chunk (very much like a
35 zip file) and allow fast random-access reading of the file later on.
36 It does not do zip as a zip itself has more complexity than is needed,
37 and it was much simpler to implement this once here.
38
39 It also can encode and decode data structures in memory, as well as
40 image data for saving to eet files or sending across the network to
41 other machines, or just writing to arbitary files on the system. All
42 data is encoded in a platform independant way and can be written and
43 read by any architecture.
44
45 %description -l pl.UTF-8
46 Eet to mała biblioteka zaprojektowana do zapisu dowolnego zbioru
47 porcji danych do pliku i opcjonalnej kompresji każdej porcji (podobnie
48 do pliku zip) oraz umożliwienia później szybkiego odczytu pliku ze
49 swobodnym dostępem. Nie jest to zip, jako że sam zip jest bardziej
50 złożony niż trzeba, a było dużo prościej zaimplementować to tak, jak
51 jest.
52
53 Biblioteka może także kodować i dekodować struktury danych w pamięci,
54 a także dane obrazów do zapisu do plików eet lub wysyłania po sieci na
55 inne maszyny, lub po prostu zapisywania do dowolnych plików w
56 systemie. Wszystkie dane są kodowane w sposób niezależny od platformy
57 i mogą być zapisywane i odczytywane na dowolnej architekturze.
58
59 %package devel
60 Summary:        Header files for Eet library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Eet
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       eina-devel >= %{eina_ver}
65 Requires:       gnutls-devel >= 1.7.6
66 Requires:       libgcrypt-devel
67 Requires:       libjpeg-devel
68 Requires:       zlib-devel
69
70 %description devel
71 Header files for Eet library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki Eet.
75
76 %package static
77 Summary:        Static Eet library
78 Summary(pl.UTF-8):      Statyczna biblioteka Eet
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static Eet library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka Eet.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         --disable-silent-rules \
100         %{!?with_static_libs:--disable-static}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install -d $RPM_BUILD_ROOT%{_examplesdir}
110 mv -f $RPM_BUILD_ROOT%{_datadir}/eet/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS COPYING NEWS README
121 %attr(755,root,root) %{_bindir}/eet
122 %attr(755,root,root) %{_libdir}/libeet.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libeet.so.1
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libeet.so
128 %{_libdir}/libeet.la
129 %{_includedir}/eet-1
130 %{_pkgconfigdir}/eet.pc
131 %{_examplesdir}/%{name}-%{version}
132
133 %if %{with static_libs}
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libeet.a
137 %endif
This page took 0.075827 seconds and 3 git commands to generate.