]> git.pld-linux.org Git - packages/eet.git/blame - eet.spec
- rel 3; fix gnutls build
[packages/eet.git] / eet.spec
CommitLineData
bbb25e4e 1# NOTE: for versions >= 1.8 see efl.spec
2fb44219
KK
2#
3# Conditional build:
4%bcond_without static_libs # don't build static library
5#
5bcdce3e 6%define eina_ver 1.7.10
146ac757 7Summary: Library for speedy data storage, retrieval, and compression
9dd89ee4 8Summary(pl.UTF-8): Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
231027b5 9Name: eet
9d4318c6 10Version: 1.7.10
8668a904 11Release: 3
146ac757 12License: BSD
13Group: Libraries
8668a904 14Source0: http://download.enlightenment.org/att/releases/%{name}-%{version}.tar.bz2
9d4318c6 15# Source0-md5: 396ccb7094518cb9ce6939e7d2c6ef8c
8668a904 16Patch0: gnutls.patch
2893dd8f 17URL: http://trac.enlightenment.org/e/wiki/Eet
98181c2d
JB
18BuildRequires: autoconf >= 2.52
19BuildRequires: automake >= 1.6
5bcdce3e 20BuildRequires: eina-devel >= %{eina_ver}
baf4560b 21BuildRequires: gnutls-devel >= 1.7.6
a6e34d2e 22BuildRequires: libgcrypt-devel
146ac757 23BuildRequires: libjpeg-devel
24BuildRequires: libtool
0c57ecba
JB
25BuildRequires: pkgconfig >= 1:0.22
26BuildRequires: sed >= 4.0
146ac757 27BuildRequires: zlib-devel
5bcdce3e 28Requires: eina >= %{eina_ver}
baf4560b 29Requires: gnutls >= 1.7.6
146ac757 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Eet is a tiny library designed to write an arbitary set of chunks of
34data to a file and optionally compress each chunk (very much like a
35zip file) and allow fast random-access reading of the file later on.
36It does not do zip as a zip itself has more complexity than is needed,
37and it was much simpler to implement this once here.
38
39It also can encode and decode data structures in memory, as well as
40image data for saving to eet files or sending across the network to
41other machines, or just writing to arbitary files on the system. All
42data is encoded in a platform independant way and can be written and
43read by any architecture.
44
347bfef3
JR
45%description -l pl.UTF-8
46Eet to mała biblioteka zaprojektowana do zapisu dowolnego zbioru
47porcji danych do pliku i opcjonalnej kompresji każdej porcji (podobnie
48do pliku zip) oraz umożliwienia później szybkiego odczytu pliku ze
49swobodnym dostępem. Nie jest to zip, jako że sam zip jest bardziej
50złożony niż trzeba, a było dużo prościej zaimplementować to tak, jak
2760e594
JB
51jest.
52
347bfef3
JR
53Biblioteka może także kodować i dekodować struktury danych w pamięci,
54a także dane obrazów do zapisu do plików eet lub wysyłania po sieci na
55inne maszyny, lub po prostu zapisywania do dowolnych plików w
56systemie. Wszystkie dane są kodowane w sposób niezależny od platformy
57i mogą być zapisywane i odczytywane na dowolnej architekturze.
2760e594 58
146ac757 59%package devel
2760e594 60Summary: Header files for Eet library
9dd89ee4 61Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Eet
146ac757 62Group: Development/Libraries
2760e594 63Requires: %{name} = %{version}-%{release}
5bcdce3e 64Requires: eina-devel >= %{eina_ver}
baf4560b 65Requires: gnutls-devel >= 1.7.6
0c57ecba 66Requires: libgcrypt-devel
f6dec708
KK
67Requires: libjpeg-devel
68Requires: zlib-devel
146ac757 69
70%description devel
2760e594
JB
71Header files for Eet library.
72
347bfef3
JR
73%description devel -l pl.UTF-8
74Pliki nagłówkowe biblioteki Eet.
146ac757 75
76%package static
2760e594 77Summary: Static Eet library
9dd89ee4 78Summary(pl.UTF-8): Statyczna biblioteka Eet
146ac757 79Group: Development/Libraries
2760e594 80Requires: %{name}-devel = %{version}-%{release}
146ac757 81
82%description static
2760e594
JB
83Static Eet library.
84
347bfef3 85%description static -l pl.UTF-8
2760e594 86Statyczna biblioteka Eet.
146ac757 87
88%prep
22cba8c0 89%setup -q
8668a904 90%patch0 -p1
146ac757 91
92%build
f2726464 93%{__libtoolize}
a6e34d2e 94%{__aclocal} -I m4
f2726464 95%{__autoconf}
96%{__autoheader}
97%{__automake}
2fb44219 98%configure \
0c57ecba 99 --disable-silent-rules \
2fb44219 100 %{!?with_static_libs:--disable-static}
0c57ecba 101%{__make}
146ac757 102
103%install
104rm -rf $RPM_BUILD_ROOT
2760e594 105
146ac757 106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
e41fe325
JB
109install -d $RPM_BUILD_ROOT%{_examplesdir}
110mv -f $RPM_BUILD_ROOT%{_datadir}/eet/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111
146ac757 112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%files
119%defattr(644,root,root,755)
231027b5 120%doc AUTHORS COPYING NEWS README
c3e75f65 121%attr(755,root,root) %{_bindir}/eet
4a540096
JB
122%attr(755,root,root) %{_libdir}/libeet.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libeet.so.1
146ac757 124
125%files devel
126%defattr(644,root,root,755)
146ac757 127%attr(755,root,root) %{_libdir}/libeet.so
128%{_libdir}/libeet.la
2ff37400 129%{_includedir}/eet-1
146ac757 130%{_pkgconfigdir}/eet.pc
e41fe325 131%{_examplesdir}/%{name}-%{version}
146ac757 132
2fb44219 133%if %{with static_libs}
146ac757 134%files static
135%defattr(644,root,root,755)
136%{_libdir}/libeet.a
2fb44219 137%endif
This page took 0.078581 seconds and 4 git commands to generate.