]> git.pld-linux.org Git - packages/eet.git/blame - eet.spec
- release 2 (by relup.sh)
[packages/eet.git] / eet.spec
CommitLineData
bbb25e4e 1# NOTE: for versions >= 1.8 see efl.spec
2fb44219
KK
2#
3# Conditional build:
4%bcond_without static_libs # don't build static library
5#
5bcdce3e 6%define eina_ver 1.7.10
146ac757 7Summary: Library for speedy data storage, retrieval, and compression
9dd89ee4 8Summary(pl.UTF-8): Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
231027b5 9Name: eet
9d4318c6 10Version: 1.7.10
209807c8 11Release: 2
146ac757 12License: BSD
13Group: Libraries
22cba8c0 14Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
9d4318c6 15# Source0-md5: 396ccb7094518cb9ce6939e7d2c6ef8c
2893dd8f 16URL: http://trac.enlightenment.org/e/wiki/Eet
98181c2d
JB
17BuildRequires: autoconf >= 2.52
18BuildRequires: automake >= 1.6
5bcdce3e 19BuildRequires: eina-devel >= %{eina_ver}
baf4560b 20BuildRequires: gnutls-devel >= 1.7.6
a6e34d2e 21BuildRequires: libgcrypt-devel
146ac757 22BuildRequires: libjpeg-devel
23BuildRequires: libtool
0c57ecba
JB
24BuildRequires: pkgconfig >= 1:0.22
25BuildRequires: sed >= 4.0
146ac757 26BuildRequires: zlib-devel
5bcdce3e 27Requires: eina >= %{eina_ver}
baf4560b 28Requires: gnutls >= 1.7.6
146ac757 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Eet is a tiny library designed to write an arbitary set of chunks of
33data to a file and optionally compress each chunk (very much like a
34zip file) and allow fast random-access reading of the file later on.
35It does not do zip as a zip itself has more complexity than is needed,
36and it was much simpler to implement this once here.
37
38It also can encode and decode data structures in memory, as well as
39image data for saving to eet files or sending across the network to
40other machines, or just writing to arbitary files on the system. All
41data is encoded in a platform independant way and can be written and
42read by any architecture.
43
347bfef3
JR
44%description -l pl.UTF-8
45Eet to mała biblioteka zaprojektowana do zapisu dowolnego zbioru
46porcji danych do pliku i opcjonalnej kompresji każdej porcji (podobnie
47do pliku zip) oraz umożliwienia później szybkiego odczytu pliku ze
48swobodnym dostępem. Nie jest to zip, jako że sam zip jest bardziej
49złożony niż trzeba, a było dużo prościej zaimplementować to tak, jak
2760e594
JB
50jest.
51
347bfef3
JR
52Biblioteka może także kodować i dekodować struktury danych w pamięci,
53a także dane obrazów do zapisu do plików eet lub wysyłania po sieci na
54inne maszyny, lub po prostu zapisywania do dowolnych plików w
55systemie. Wszystkie dane są kodowane w sposób niezależny od platformy
56i mogą być zapisywane i odczytywane na dowolnej architekturze.
2760e594 57
146ac757 58%package devel
2760e594 59Summary: Header files for Eet library
9dd89ee4 60Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Eet
146ac757 61Group: Development/Libraries
2760e594 62Requires: %{name} = %{version}-%{release}
5bcdce3e 63Requires: eina-devel >= %{eina_ver}
baf4560b 64Requires: gnutls-devel >= 1.7.6
0c57ecba 65Requires: libgcrypt-devel
f6dec708
KK
66Requires: libjpeg-devel
67Requires: zlib-devel
146ac757 68
69%description devel
2760e594
JB
70Header files for Eet library.
71
347bfef3
JR
72%description devel -l pl.UTF-8
73Pliki nagłówkowe biblioteki Eet.
146ac757 74
75%package static
2760e594 76Summary: Static Eet library
9dd89ee4 77Summary(pl.UTF-8): Statyczna biblioteka Eet
146ac757 78Group: Development/Libraries
2760e594 79Requires: %{name}-devel = %{version}-%{release}
146ac757 80
81%description static
2760e594
JB
82Static Eet library.
83
347bfef3 84%description static -l pl.UTF-8
2760e594 85Statyczna biblioteka Eet.
146ac757 86
87%prep
22cba8c0 88%setup -q
146ac757 89
90%build
f2726464 91%{__libtoolize}
a6e34d2e 92%{__aclocal} -I m4
f2726464 93%{__autoconf}
94%{__autoheader}
95%{__automake}
2fb44219 96%configure \
0c57ecba 97 --disable-silent-rules \
2fb44219 98 %{!?with_static_libs:--disable-static}
0c57ecba 99%{__make}
146ac757 100
101%install
102rm -rf $RPM_BUILD_ROOT
2760e594 103
146ac757 104%{__make} install \
105 DESTDIR=$RPM_BUILD_ROOT
106
e41fe325
JB
107install -d $RPM_BUILD_ROOT%{_examplesdir}
108mv -f $RPM_BUILD_ROOT%{_datadir}/eet/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109
146ac757 110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(644,root,root,755)
231027b5 118%doc AUTHORS COPYING NEWS README
c3e75f65 119%attr(755,root,root) %{_bindir}/eet
4a540096
JB
120%attr(755,root,root) %{_libdir}/libeet.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libeet.so.1
146ac757 122
123%files devel
124%defattr(644,root,root,755)
146ac757 125%attr(755,root,root) %{_libdir}/libeet.so
126%{_libdir}/libeet.la
2ff37400 127%{_includedir}/eet-1
146ac757 128%{_pkgconfigdir}/eet.pc
e41fe325 129%{_examplesdir}/%{name}-%{version}
146ac757 130
2fb44219 131%if %{with static_libs}
146ac757 132%files static
133%defattr(644,root,root,755)
134%{_libdir}/libeet.a
2fb44219 135%endif
This page took 0.095607 seconds and 4 git commands to generate.