]> git.pld-linux.org Git - packages/edje.git/blob - edje.spec
- up to 0.5.0.028
[packages/edje.git] / edje.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Complex Graphical Design/Layout Engine
6 Summary(pl):    Z³o¿ony silnik graficznego projektowania/planowania
7 Name:           edje
8 Version:        0.5.0.028
9 Release:        1
10 License:        BSD
11 Group:          X11/Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  8e7541cdbe29cc130d2801555aa98b76
14 URL:            http://enlightenment.org/Libraries/Edje/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  ecore-devel
18 BuildRequires:  embryo-devel
19 BuildRequires:  imlib2-devel >= 1.2.1
20 BuildRequires:  libtool
21 Requires:       %{name}-libs = %{version}-%{release}
22 Requires:       cpp
23 Requires:       fonts-TTF-bitstream-vera
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %undefine       __cxx
27
28 %description
29 Edje is a complex graphical design and layout engine. It provides a
30 mechanism for allowing configuration data to define visual elements in
31 terms of layout, behavior, and appearance. Edje allows for multiple
32 collections of layouts in one file, allowing a complete set of images,
33 animations, and controls to exist as a unified whole.
34
35 Edje separates the arrangement, appearance, and behavior logic into
36 distinct independent entities. This allows visual objects to share
37 image data and configuration information without requiring them to do
38 so. This separation and simplistic event driven style of programming
39 can produce almost any look and feel one could want for basic visual
40 elements. Anything more complex is likely the domain of an application
41 or widget set that may use Edje as a convenient way of being able to
42 configure parts of the display.
43
44 %description -l pl
45 Edje to z³o¿ony silnik graficznego projektowania i planowania.
46 Dostarcza mechanizm pozwalaj±cy na definiowanie elementów graficznych
47 za pomoc± danych konfiguracyjnych poprzez rozmieszczenie, zachowanie i
48 wygl±d. Edje pozwala na wiele kolekcji projektów w jednym pliku,
49 zezwalaj±c na istnienie pe³nego zbioru obrazów, animacji i kontrolek
50 jako ca³o¶ci.
51
52 Edje oddziela rozmieszczenie, wygl±d i logikê zachowania na ró¿ne,
53 niezale¿ne elementy. Pozwala to na wspó³dzielenie danych obrazów i
54 informacji o konfiguracji elementów graficznych bez wymagania tego.
55 Rozdzielenie to i uproszczony model programowania sterowanego
56 zdarzeniami mo¿e stworzyæ prawie dowolny wygl±d i zachowanie
57 podstawowych elementów graficznych. Wszystko bardziej z³o¿one jest
58 raczej domen± aplikacji lub zbioru widgetów, które mog± u¿ywaæ Edje
59 jako wygodnego sposobu konfigurowania czê¶ci ekranu.
60
61 %package libs
62 Summary:        Edje library
63 Summary(pl):    Biblioteka edje
64 Group:          X11/Libraries
65
66 %description libs
67 Edje library.
68
69 %description libs -l pl
70 Biblioteka edje.
71
72 %package devel
73 Summary:        Edje header files
74 Summary(pl):    Pliki nag³ówkowe Edje
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       ecore-devel
78 Requires:       embryo-devel
79 Requires:       imlib2-devel >= 1.2.1
80
81 %description devel
82 Header files for Edje.
83
84 %description devel -l pl
85 Pliki nag³ówkowe Edje.
86
87 %package static
88 Summary:        Static Edje library
89 Summary(pl):    Statyczna biblioteka Edje
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static Edje library.
95
96 %description static -l pl
97 Statyczna biblioteka Edje.
98
99 %prep
100 %setup -q
101
102 %build
103 %configure \
104         %{!?with_static_libs:--disable-static} \
105         --enable-edje-cc
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 cd $RPM_BUILD_ROOT%{_datadir}/%{name}/data/test/fonts
115 VERA=$(ls Vera*.ttf)
116 for FONT in $VERA; do
117         rm -f $FONT
118         ln -s %{_fontsdir}/TTF/$FONT .
119 done
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post libs      -p /sbin/ldconfig
125 %postun libs    -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
130 %attr(755,root,root) %{_bindir}/edje
131 %attr(755,root,root) %{_bindir}/edje_*
132 %{_datadir}/%{name}
133
134 %files libs
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libedje.so.*.*.*
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/edje-config
141 %attr(755,root,root) %{_libdir}/libedje.so
142 %{_libdir}/libedje.la
143 %{_includedir}/Edje*
144 %{_pkgconfigdir}/edje.pc
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libedje.a
150 %endif
This page took 0.114722 seconds and 3 git commands to generate.