]> git.pld-linux.org Git - packages/edje.git/blob - edje.spec
- note efl.spec for later versions
[packages/edje.git] / edje.spec
1 # NOTE: for versions >= 1.8 see efl.spec
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 %bcond_with     remix           # remix support (not used now as multisense is disabled)
6 #
7 %define         ecore_ver       1.7.9
8 %define         eet_ver         1.7.9
9 %define         eina_ver        1.7.9
10 %define         eio_ver         1.7.9
11 %define         embryo_ver      1.7.9
12 %define         evas_ver        1.7.9
13 Summary:        Complex Graphical Design/Layout Engine
14 Summary(pl.UTF-8):      Złożony silnik graficznego projektowania/planowania
15 Name:           edje
16 Version:        1.7.9
17 Release:        1
18 License:        BSD
19 Group:          X11/Libraries
20 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  4486344a8c0cd7518148ee635db45820
22 Patch0:         %{name}-deps.patch
23 URL:            http://trac.enlightenment.org/e/wiki/Edje
24 # for alsa_snd_player plugin for remix
25 %{?with_remix:BuildRequires:    alsa-lib-devel >= 1.0.21}
26 BuildRequires:  autoconf >= 2.52
27 BuildRequires:  automake >= 1.6
28 BuildRequires:  ecore-devel >= %{ecore_ver}
29 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
30 BuildRequires:  ecore-file-devel >= %{ecore_ver}
31 BuildRequires:  ecore-imf-devel >= %{ecore_ver}
32 BuildRequires:  ecore-imf-evas-devel >= %{ecore_ver}
33 BuildRequires:  eina-devel >= %{eina_ver}
34 BuildRequires:  eio-devel >= %{eio_ver}
35 BuildRequires:  eet-devel >= %{eet_ver}
36 BuildRequires:  embryo-devel >= %{embryo_ver}
37 BuildRequires:  evas-devel >= %{evas_ver}
38 BuildRequires:  flac-devel >= 1.2.1
39 BuildRequires:  libogg-devel >= 1:1.1.4
40 BuildRequires:  libsndfile-devel >= 1.0.21
41 BuildRequires:  libvorbis-devel >= 1:1.2.3
42 BuildRequires:  libtool
43 BuildRequires:  lua51 >= 5.1.0
44 BuildRequires:  pkgconfig >= 1:0.22
45 BuildRequires:  python >= 1:2.5
46 %{?with_remix:BuildRequires:    remix-devel >= 0.2.4}
47 %{?with_remix:Requires: alsa-lib >= 1.0.21}
48 Requires:       %{name}-libs = %{version}-%{release}
49 Requires:       evas-engine-buffer >= %{evas_ver}
50 Requires:       evas-loader-png >= %{evas_ver}
51 Requires:       flac >= 1.2.1
52 Requires:       libogg >= 1:1.1.4
53 Requires:       libvorbis >= 1:1.2.3
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %undefine       __cxx
57 %define         specflags_x86_64        -mfpmath=387
58 %define         specflags_amd64         -mfpmath=387
59
60 %description
61 Edje is a complex graphical design and layout engine. It provides a
62 mechanism for allowing configuration data to define visual elements in
63 terms of layout, behavior, and appearance. Edje allows for multiple
64 collections of layouts in one file, allowing a complete set of images,
65 animations, and controls to exist as a unified whole.
66
67 Edje separates the arrangement, appearance, and behavior logic into
68 distinct independent entities. This allows visual objects to share
69 image data and configuration information without requiring them to do
70 so. This separation and simplistic event driven style of programming
71 can produce almost any look and feel one could want for basic visual
72 elements. Anything more complex is likely the domain of an application
73 or widget set that may use Edje as a convenient way of being able to
74 configure parts of the display.
75
76 %description -l pl.UTF-8
77 Edje to złożony silnik graficznego projektowania i planowania.
78 Dostarcza mechanizm pozwalający na definiowanie elementów graficznych
79 za pomocą danych konfiguracyjnych poprzez rozmieszczenie, zachowanie i
80 wygląd. Edje pozwala na wiele kolekcji projektów w jednym pliku,
81 zezwalając na istnienie pełnego zbioru obrazów, animacji i kontrolek
82 jako całości.
83
84 Edje oddziela rozmieszczenie, wygląd i logikę zachowania na różne,
85 niezależne elementy. Pozwala to na współdzielenie danych obrazów i
86 informacji o konfiguracji elementów graficznych bez wymagania tego.
87 Rozdzielenie to i uproszczony model programowania sterowanego
88 zdarzeniami może stworzyć prawie dowolny wygląd i zachowanie
89 podstawowych elementów graficznych. Wszystko bardziej złożone jest
90 raczej domeną aplikacji lub zbioru widgetów, które mogą używać Edje
91 jako wygodnego sposobu konfigurowania części ekranu.
92
93 %package libs
94 Summary:        Edje library
95 Summary(pl.UTF-8):      Biblioteka edje
96 Group:          X11/Libraries
97 Requires:       ecore >= %{ecore_ver}
98 Requires:       ecore-file >= %{ecore_ver}
99 Requires:       ecore-imf >= %{ecore_ver}
100 Requires:       ecore-imf-evas >= %{ecore_ver}
101 Requires:       eina >= %{eina_ver}
102 Requires:       eio >= %{eio_ver}
103 Requires:       eet >= %{eet_ver}
104 Requires:       embryo >= %{embryo_ver}
105 Requires:       evas >= %{evas_ver}
106 Requires:       libsndfile >= 1.0.21
107 %{?with_remix:Requires: remix >= 0.2.4}
108
109 %description libs
110 Edje library.
111
112 %description libs -l pl.UTF-8
113 Biblioteka edje.
114
115 %package devel
116 Summary:        Edje header files
117 Summary(pl.UTF-8):      Pliki nagłówkowe Edje
118 Group:          Development/Libraries
119 Requires:       %{name}-libs = %{version}-%{release}
120 Requires:       ecore-devel >= %{ecore_ver}
121 Requires:       ecore-file-devel >= %{ecore_ver}
122 Requires:       ecore-imf-devel >= %{ecore_ver}
123 Requires:       ecore-imf-evas-devel >= %{ecore_ver}
124 Requires:       eet-devel >= %{eet_ver}
125 Requires:       eio-devel >= %{eio_ver}
126 Requires:       embryo-devel >= %{embryo_ver}
127 Requires:       evas-devel >= %{evas_ver}
128 Requires:       libsndfile-devel >= 1.0.21
129 %{?with_remix:Requires: remix-devel >= 0.2.4}
130
131 %description devel
132 Header files for Edje.
133
134 %description devel -l pl.UTF-8
135 Pliki nagłówkowe Edje.
136
137 %package static
138 Summary:        Static Edje library
139 Summary(pl.UTF-8):      Statyczna biblioteka Edje
140 Group:          Development/Libraries
141 Requires:       %{name}-devel = %{version}-%{release}
142
143 %description static
144 Static Edje library.
145
146 %description static -l pl.UTF-8
147 Statyczna biblioteka Edje.
148
149 %package -n vim-syntax-edc
150 Summary:        EDC syntax support for Vim
151 Summary(pl.UTF-8):      Obsługa składni EDC dla Vima
152 Group:          Applications/Editors/Vim
153 Requires:       vim-rt
154
155 %description -n vim-syntax-edc
156 EDC syntax support for Vim.
157
158 %description -n vim-syntax-edc -l pl.UTF-8
159 Obsługa składni EDC dla Vima.
160
161 %prep
162 %setup -q
163 %patch0 -p1
164
165 %build
166 %{__libtoolize}
167 %{__aclocal} -I m4
168 %{__autoconf}
169 %{__autoheader}
170 %{__automake}
171 %configure \
172         --disable-silent-rules \
173         %{!?with_remix:--disable-remix} \
174         %{!?with_static_libs:--disable-static} \
175         --enable-edje-cc \
176         --with-vim=/usr/share/vim/vimfiles
177 %{__make}
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181
182 %{__make} install \
183         DESTDIR=$RPM_BUILD_ROOT
184
185 install -d $RPM_BUILD_ROOT%{_libdir}/edje/modules
186 install -D data/edc.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/edc.vim
187
188 %if %{with remix}
189 %{__rm} $RPM_BUILD_ROOT%{_libdir}/remix/*.la
190 %endif
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post   libs -p /sbin/ldconfig
196 %postun libs -p /sbin/ldconfig
197
198 %files
199 %defattr(644,root,root,755)
200 %doc AUTHORS COPYING ChangeLog NEWS README
201 %attr(755,root,root) %{_bindir}/edje_cc
202 %attr(755,root,root) %{_bindir}/edje_decc
203 %attr(755,root,root) %{_bindir}/edje_external_inspector
204 %attr(755,root,root) %{_bindir}/edje_inspector
205 %attr(755,root,root) %{_bindir}/edje_player
206 %attr(755,root,root) %{_bindir}/edje_recc
207 %attr(755,root,root) %{_bindir}/edje_watch
208 %attr(755,root,root) %{_bindir}/inkscape2edc
209 %dir %{_libdir}/%{name}/utils
210 %attr(755,root,root) %dir %{_libdir}/%{name}/utils/epp
211 %{_datadir}/%{name}
212 %{_datadir}/mime/packages/edje.xml
213
214 %files libs
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/libedje.so.*.*.*
217 %attr(755,root,root) %ghost %{_libdir}/libedje.so.1
218 %dir %{_libdir}/%{name}
219 %dir %{_libdir}/%{name}/modules
220 %if %{with remix}
221 %attr(755,root,root) %{_libdir}/remix/libalsa_snd_player.so
222 %attr(755,root,root) %{_libdir}/remix/libeet_sndfile_reader.so
223 %endif
224
225 %files devel
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/libedje.so
228 %{_libdir}/libedje.la
229 %{_includedir}/edje-1
230 %{_pkgconfigdir}/edje.pc
231
232 %if %{with static_libs}
233 %files static
234 %defattr(644,root,root,755)
235 %{_libdir}/libedje.a
236 %endif
237
238 %files -n vim-syntax-edc
239 %defattr(644,root,root,755)
240 %{_datadir}/vim/vimfiles/syntax/edc.vim
This page took 0.874953 seconds and 3 git commands to generate.