]> git.pld-linux.org Git - packages/edje.git/blob - edje.spec
- 1.0.0.beta2
[packages/edje.git] / edje.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.0.0
6 %define         eet_ver         1.4.0
7 %define         embryo_ver      1.0.0
8 %define         evas_ver        1.0.0
9 %define         svn             %{nil}
10 Summary:        Complex Graphical Design/Layout Engine
11 Summary(pl.UTF-8):      Złożony silnik graficznego projektowania/planowania
12 Name:           edje
13 %define subver  beta2
14 Version:        1.0.0
15 Release:        0.%{subver}.1
16 License:        LGPL v2.1
17 Group:          X11/Libraries
18 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
19 # Source0-md5:  7538edb5e6a5801502f9d7e831a250c6
20 URL:            http://enlightenment.org/p.php?p=about/libs/edje
21 BuildRequires:  autoconf >= 2.52
22 BuildRequires:  automake >= 1.6
23 # ecore-evas, ecore-job
24 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
25 BuildRequires:  eet-devel >= %{eet_ver}
26 BuildRequires:  embryo-devel >= %{embryo_ver}
27 BuildRequires:  evas-devel >= %{evas_ver}
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 Requires:       %{name}-libs = %{version}-%{release}
31 Requires:       cpp
32 Requires:       evas-engine-buffer >= %{evas_ver}
33 Requires:       evas-loader-png >= %{evas_ver}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %undefine       __cxx
37 %define         specflags_x86_64        -mfpmath=387
38 %define         specflags_amd64         -mfpmath=387
39
40 %description
41 Edje is a complex graphical design and layout engine. It provides a
42 mechanism for allowing configuration data to define visual elements in
43 terms of layout, behavior, and appearance. Edje allows for multiple
44 collections of layouts in one file, allowing a complete set of images,
45 animations, and controls to exist as a unified whole.
46
47 Edje separates the arrangement, appearance, and behavior logic into
48 distinct independent entities. This allows visual objects to share
49 image data and configuration information without requiring them to do
50 so. This separation and simplistic event driven style of programming
51 can produce almost any look and feel one could want for basic visual
52 elements. Anything more complex is likely the domain of an application
53 or widget set that may use Edje as a convenient way of being able to
54 configure parts of the display.
55
56 %description -l pl.UTF-8
57 Edje to złożony silnik graficznego projektowania i planowania.
58 Dostarcza mechanizm pozwalający na definiowanie elementów graficznych
59 za pomocą danych konfiguracyjnych poprzez rozmieszczenie, zachowanie i
60 wygląd. Edje pozwala na wiele kolekcji projektów w jednym pliku,
61 zezwalając na istnienie pełnego zbioru obrazów, animacji i kontrolek
62 jako całości.
63
64 Edje oddziela rozmieszczenie, wygląd i logikę zachowania na różne,
65 niezależne elementy. Pozwala to na współdzielenie danych obrazów i
66 informacji o konfiguracji elementów graficznych bez wymagania tego.
67 Rozdzielenie to i uproszczony model programowania sterowanego
68 zdarzeniami może stworzyć prawie dowolny wygląd i zachowanie
69 podstawowych elementów graficznych. Wszystko bardziej złożone jest
70 raczej domeną aplikacji lub zbioru widgetów, które mogą używać Edje
71 jako wygodnego sposobu konfigurowania części ekranu.
72
73 %package libs
74 Summary:        Edje library
75 Summary(pl.UTF-8):      Biblioteka edje
76 Group:          X11/Libraries
77 Requires:       ecore-evas >= %{ecore_ver}
78 Requires:       eet >= %{eet_ver}
79 Requires:       embryo >= %{embryo_ver}
80 Requires:       evas >= %{evas_ver}
81
82 %description libs
83 Edje library.
84
85 %description libs -l pl.UTF-8
86 Biblioteka edje.
87
88 %package devel
89 Summary:        Edje header files
90 Summary(pl.UTF-8):      Pliki nagłówkowe Edje
91 Group:          Development/Libraries
92 Requires:       %{name}-libs = %{version}-%{release}
93 # ecore-evas, ecore-job
94 Requires:       ecore-evas-devel >= %{ecore_ver}
95 Requires:       eet-devel >= %{eet_ver}
96 Requires:       embryo-devel >= %{embryo_ver}
97 Requires:       evas-devel >= %{evas_ver}
98
99 %description devel
100 Header files for Edje.
101
102 %description devel -l pl.UTF-8
103 Pliki nagłówkowe Edje.
104
105 %package static
106 Summary:        Static Edje library
107 Summary(pl.UTF-8):      Statyczna biblioteka Edje
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 Static Edje library.
113
114 %description static -l pl.UTF-8
115 Statyczna biblioteka Edje.
116
117 %package -n vim-syntax-edc
118 Summary:        EDC syntax support for Vim
119 Summary(pl.UTF-8):      Obsługa składni EDC dla Vima
120 Group:          Applications/Editors/Vim
121 Requires:       vim-rt
122
123 %description -n vim-syntax-edc
124 EDC syntax support for Vim.
125
126 %description -n vim-syntax-edc -l pl.UTF-8
127 Obsługa składni EDC dla Vima.
128
129 %prep
130 %setup -q -n %{name}-%{version}.%{subver}
131
132 %build
133 %{__libtoolize}
134 %{__aclocal} -I m4
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         %{!?with_static_libs:--disable-static} \
140         --enable-edje-cc \
141         --with-vim=/usr/share/vim/vimfiles
142 %{__make} V=1
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 install -d $RPM_BUILD_ROOT%{_libdir}/edje
151 install -D data/edc.vim $RPM_BUILD_ROOT/usr/share/vim/vimfiles/syntax/edc.vim
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   libs -p /sbin/ldconfig
157 %postun libs -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc AUTHORS COPYING NEWS README
162 %attr(755,root,root) %{_bindir}/edje_cc
163 %attr(755,root,root) %{_bindir}/edje_decc
164 %attr(755,root,root) %{_bindir}/edje_player
165 %attr(755,root,root) %{_bindir}/edje_recc
166 %attr(755,root,root) %{_bindir}/inkscape2edc
167 %dir %{_libdir}/%{name}
168 %{_datadir}/%{name}
169 %{_datadir}/mime/packages/edje.xml
170
171 %files libs
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libedje%{svn}.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libedje%{svn}.so.1
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libedje.so
179 %{_libdir}/libedje.la
180 %dir %{_includedir}/edje-1
181 %{_includedir}/edje-1/*.h
182 %{_pkgconfigdir}/edje.pc
183
184 %if %{with static_libs}
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/libedje.a
188 %endif
189
190 %files -n vim-syntax-edc
191 %defattr(644,root,root,755)
192 /usr/share/vim/vimfiles/syntax/edc.vim
This page took 0.100925 seconds and 3 git commands to generate.