]> git.pld-linux.org Git - packages/edje.git/blob - edje.spec
- fix for new automake; rel 2
[packages/edje.git] / edje.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.1.0
6 %define         eet_ver         1.5.0
7 %define         eina_ver        1.1.0
8 %define         embryo_ver      1.1.0
9 %define         evas_ver        1.1.0
10 Summary:        Complex Graphical Design/Layout Engine
11 Summary(pl.UTF-8):      Złożony silnik graficznego projektowania/planowania
12 Name:           edje
13 Version:        1.1.0
14 Release:        2
15 License:        BSD
16 Group:          X11/Libraries
17 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
18 # Source0-md5:  c51cbc0c0d8f93ceadfb2173c2f9135c
19 Patch0:         automake.patch
20 URL:            http://trac.enlightenment.org/e/wiki/Edje
21 BuildRequires:  autoconf >= 2.52
22 BuildRequires:  automake >= 1.6
23 BuildRequires:  ecore-devel >= %{ecore_ver}
24 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
25 BuildRequires:  ecore-file-devel >= %{ecore_ver}
26 BuildRequires:  ecore-imf-devel >= %{ecore_ver}
27 BuildRequires:  ecore-imf-evas-devel >= %{ecore_ver}
28 BuildRequires:  eina-devel >= %{eina_ver}
29 BuildRequires:  eet-devel >= %{eet_ver}
30 BuildRequires:  embryo-devel >= %{embryo_ver}
31 BuildRequires:  evas-devel >= %{evas_ver}
32 BuildRequires:  libtool
33 BuildRequires:  lua51 >= 5.1.0
34 BuildRequires:  pkgconfig >= 1:0.22
35 BuildRequires:  python >= 1:2.5
36 Requires:       %{name}-libs = %{version}-%{release}
37 Requires:       eina >= %{eina_ver}
38 Requires:       evas-engine-buffer >= %{evas_ver}
39 Requires:       evas-loader-png >= %{evas_ver}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %undefine       __cxx
43 %define         specflags_x86_64        -mfpmath=387
44 %define         specflags_amd64         -mfpmath=387
45
46 %description
47 Edje is a complex graphical design and layout engine. It provides a
48 mechanism for allowing configuration data to define visual elements in
49 terms of layout, behavior, and appearance. Edje allows for multiple
50 collections of layouts in one file, allowing a complete set of images,
51 animations, and controls to exist as a unified whole.
52
53 Edje separates the arrangement, appearance, and behavior logic into
54 distinct independent entities. This allows visual objects to share
55 image data and configuration information without requiring them to do
56 so. This separation and simplistic event driven style of programming
57 can produce almost any look and feel one could want for basic visual
58 elements. Anything more complex is likely the domain of an application
59 or widget set that may use Edje as a convenient way of being able to
60 configure parts of the display.
61
62 %description -l pl.UTF-8
63 Edje to złożony silnik graficznego projektowania i planowania.
64 Dostarcza mechanizm pozwalający na definiowanie elementów graficznych
65 za pomocą danych konfiguracyjnych poprzez rozmieszczenie, zachowanie i
66 wygląd. Edje pozwala na wiele kolekcji projektów w jednym pliku,
67 zezwalając na istnienie pełnego zbioru obrazów, animacji i kontrolek
68 jako całości.
69
70 Edje oddziela rozmieszczenie, wygląd i logikę zachowania na różne,
71 niezależne elementy. Pozwala to na współdzielenie danych obrazów i
72 informacji o konfiguracji elementów graficznych bez wymagania tego.
73 Rozdzielenie to i uproszczony model programowania sterowanego
74 zdarzeniami może stworzyć prawie dowolny wygląd i zachowanie
75 podstawowych elementów graficznych. Wszystko bardziej złożone jest
76 raczej domeną aplikacji lub zbioru widgetów, które mogą używać Edje
77 jako wygodnego sposobu konfigurowania części ekranu.
78
79 %package libs
80 Summary:        Edje library
81 Summary(pl.UTF-8):      Biblioteka edje
82 Group:          X11/Libraries
83 Requires:       ecore >= %{ecore_ver}
84 Requires:       ecore-file >= %{ecore_ver}
85 Requires:       ecore-imf >= %{ecore_ver}
86 Requires:       ecore-imf-evas >= %{ecore_ver}
87 Requires:       eina-devel >= %{eina_ver}
88 Requires:       eet >= %{eet_ver}
89 Requires:       embryo >= %{embryo_ver}
90 Requires:       evas >= %{evas_ver}
91
92 %description libs
93 Edje library.
94
95 %description libs -l pl.UTF-8
96 Biblioteka edje.
97
98 %package devel
99 Summary:        Edje header files
100 Summary(pl.UTF-8):      Pliki nagłówkowe Edje
101 Group:          Development/Libraries
102 Requires:       %{name}-libs = %{version}-%{release}
103 Requires:       ecore-devel >= %{ecore_ver}
104 Requires:       ecore-file-devel >= %{ecore_ver}
105 Requires:       ecore-imf-devel >= %{ecore_ver}
106 Requires:       ecore-imf-evas-devel >= %{ecore_ver}
107 Requires:       eet-devel >= %{eet_ver}
108 Requires:       embryo-devel >= %{embryo_ver}
109 Requires:       evas-devel >= %{evas_ver}
110
111 %description devel
112 Header files for Edje.
113
114 %description devel -l pl.UTF-8
115 Pliki nagłówkowe Edje.
116
117 %package static
118 Summary:        Static Edje library
119 Summary(pl.UTF-8):      Statyczna biblioteka Edje
120 Group:          Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description static
124 Static Edje library.
125
126 %description static -l pl.UTF-8
127 Statyczna biblioteka Edje.
128
129 %package -n vim-syntax-edc
130 Summary:        EDC syntax support for Vim
131 Summary(pl.UTF-8):      Obsługa składni EDC dla Vima
132 Group:          Applications/Editors/Vim
133 Requires:       vim-rt
134
135 %description -n vim-syntax-edc
136 EDC syntax support for Vim.
137
138 %description -n vim-syntax-edc -l pl.UTF-8
139 Obsługa składni EDC dla Vima.
140
141 %prep
142 %setup -q
143 %patch0 -p1
144
145 %build
146 %{__libtoolize}
147 %{__aclocal} -I m4
148 %{__autoconf}
149 %{__autoheader}
150 %{__automake}
151 %configure \
152         --disable-silent-rules \
153         %{!?with_static_libs:--disable-static} \
154         --enable-edje-cc \
155         --with-vim=/usr/share/vim/vimfiles
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 install -d $RPM_BUILD_ROOT%{_libdir}/edje/modules
165 install -D data/edc.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/edc.vim
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   libs -p /sbin/ldconfig
171 %postun libs -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %doc AUTHORS COPYING ChangeLog NEWS README
176 %attr(755,root,root) %{_bindir}/edje_cc
177 %attr(755,root,root) %{_bindir}/edje_decc
178 %attr(755,root,root) %{_bindir}/edje_external_inspector
179 %attr(755,root,root) %{_bindir}/edje_inspector
180 %attr(755,root,root) %{_bindir}/edje_player
181 %attr(755,root,root) %{_bindir}/edje_recc
182 %attr(755,root,root) %{_bindir}/inkscape2edc
183 %dir %{_libdir}/%{name}/utils
184 %attr(755,root,root) %dir %{_libdir}/%{name}/utils/epp
185 %{_datadir}/%{name}
186 %{_datadir}/mime/packages/edje.xml
187
188 %files libs
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libedje.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libedje.so.1
192 %dir %{_libdir}/%{name}
193 %dir %{_libdir}/%{name}/modules
194
195 %files devel
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/libedje.so
198 %{_libdir}/libedje.la
199 %{_includedir}/edje-1
200 %{_pkgconfigdir}/edje.pc
201
202 %if %{with static_libs}
203 %files static
204 %defattr(644,root,root,755)
205 %{_libdir}/libedje.a
206 %endif
207
208 %files -n vim-syntax-edc
209 %defattr(644,root,root,755)
210 %{_datadir}/vim/vimfiles/syntax/edc.vim
This page took 0.044187 seconds and 3 git commands to generate.