]> git.pld-linux.org Git - packages/edelib.git/blob - edelib.spec
- adaptarized
[packages/edelib.git] / edelib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build documentation
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        edelib library for EDE
7 Summary(pl.UTF-8):      Biblioteka pomocnicza dla EDE
8 Name:           edelib
9 Version:        2.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/ede/%{name}-%{version}.tar.gz
14 # Source0-md5:  4964c7395a097bf747ebf9da1f836e6e
15 Patch0:         %{name}-ksh.patch
16 Patch1:         %{name}-am.patch
17 URL:            http://equinox-project.org/
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.10
20 BuildRequires:  dbus-devel
21 %{?with_apidocs:BuildRequires:  doxygen}
22 BuildRequires:  fltk-devel >= 1.1.7
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  pkgconfig
25 BuildRequires:  tar >= 1:1.22
26 Requires:       glib2 >= 1:2.26.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 edelib is small and portable C++ library for EDE (Equinox Desktop
31 Environment).
32
33 Aims are to provide enough background for easier EDE components
34 construction and development.
35
36 %description -l pl.UTF-8
37 edelib jest małą przenośną biblioteką C++ dla środowiska EDE.
38
39 Jej celem jest dostarczenie wystarczającej podstawy dla konstruowania
40 i rozwijania komponentów środowiska EDE.
41
42 %package devel
43 Summary:        edelib header files
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki edelib
45 License:        LGPL v2.1+
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 Header files for edelib-based programs development.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe do tworzenia programów opartych o edelib.
54
55 %package static
56 Summary:        Static edelib library
57 Summary(pl.UTF-8):      Statyczna biblioteka edelib
58 License:        LGPL v2.1+
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static edelib library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka edelib.
67
68 %package apidocs
69 Summary:        edelib API documentation
70 Summary(pl.UTF-8):      Dokumentacja API biblioteki edelib
71 Group:          Documentation
72
73 %description apidocs
74 edelib API documentation.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API biblioteki edelib.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83
84 %build
85 %{__aclocal} -I m4
86 %{__libtoolize}
87 %{__autoheader}
88 %{__automake}
89 %{__autoconf}
90 %configure \
91         %{!?with_static_libs:--disable-static} \
92         --enable-shared
93
94 %{__make} V=1
95 %if %{with apidocs}
96 %{__make} html V=1
97 %endif
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc ChangeLog README
116 %attr(755,root,root) %{_bindir}/*
117 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libedelib.so.2
119 %attr(755,root,root) %ghost %{_libdir}/libedelib_dbus.so.2
120 %attr(755,root,root) %ghost %{_libdir}/libedelib_gui.so.2
121 %dir %{_libdir}/edelib
122 %{_libdir}/edelib/sslib
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libedelib.so
127 %attr(755,root,root) %{_libdir}/libedelib_dbus.so
128 %attr(755,root,root) %{_libdir}/libedelib_gui.so
129 %{_pkgconfigdir}/*.pc
130 %{_includedir}/edelib
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/lib*.a
136 %endif
137
138 %if %{with apidocs}
139 %files apidocs
140 %defattr(644,root,root,755)
141 %doc doc/html/*
142 %endif
This page took 0.097785 seconds and 3 git commands to generate.